•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 8
  •   
WIP Ember Media Manager 1.11.x - Download & Discussion Thread
#16
(2021-06-13, 23:36)Daydream Wrote: The Premiere Date (new info) <-> Year (old info) relationship is a bit funny. Year gets imported from the old database and is displayed as a column on left, but scraping any other single info field for a movie (say ratings) will wipe it clean until the premiere date info (or the whole movie) is (re)scraped too and Year gets computed from that. Not a big deal, just saying.
Have to check that. The year is still present because of the filter but it will (should) be parsed from the premiered date if you do a rescrape. The field in the database is still named "releasedate" becous I've forgot to change that. But i should'nt be cleaned if something other has been scraped.
 
(2021-06-13, 23:36)Daydream Wrote: That brings me to ask what new things does the new database have? The online description is for ver 4.3 and we are at 4.7. A billion years ago I believed I asked if EMM can store the resolution of the media art too. Cause that will lead to automatic views the likes of "show only movies with poster/fanart/whatever art size less than" so I'd know what media I have to work on to improve its art.
I've just updated the overview (I've completely forgotten this "feature").
In 3.0 the resolution of art will be stored in the database. I started to add this feature also to 2.0 but I have rejected it again because i wanted to get the latest release ready. Ember now is a "feature freeze" state and after I've fixed the last mainor bugs I will release it as 2.0 and restart working on 3.0 (after a break of more than a year Sad
 
(2021-06-13, 23:36)Daydream Wrote: Do you have any thoughts on switching to color media flags? Could you share some info/thoughts here as I'm not sure what's the intention is. The flags are not the size of what Kodi uses in (some of its) skins. They're smaller and then the size gets doubled up or something when displayed. Not sure if this is some mechanism meant to deal with the DPI settings of displays or something else. Anyways I custom made my own. Maybe the set of flags can be added to theming, so they would have a separate location and not be wiped out at every EMM update?
I thinks that's something with the Windows scaling. WindowsForms (the GUI engine of .NET) is years old and not really made for scaling. There are a few option to set the scaling by DPI or something other, but i never invested time to learn how that works.
I don't want invest time in new icons (I'm not a designer and i tooks to long to create fancy icons and flags) but I can see if I can implement your wish for a separate location for custom images inside the "profiles" folder.
 
(2021-06-13, 23:36)Daydream Wrote: Taking about rating/media flags... Now that EMM displays a lot more ratings, a very long movie name combined with showing a lot of columns on the left section, will push its allowed space into the flags area, cutting them out. (i.e. "Birds of Prey (and the Fantabulous Emancipation of One Harley Quinn)" with cut into IMDB/Metacritic/TheMovieDB flag space). Maybe the movie name can be broken on multiple lines if it exceeds a certain length?
Just buy a bitter monitor Big Grin. I've a 21:9 and it's perfect!
Now, i know. You can try to reduce the character size in the theme. The top part is a table with 2 main columns and at some point the screen is to small to display all the flags and text. As i said, i don't want to invest time in coding that will be obsolete with version 3.0.
Reply
#17
Great update Dan, thanks!

Couple of minor issues for me:

1. The movie's runtime seems to have disappeared from the main display window?  Is there a setting I am missing to switch it back on perhaps?

2. The 'Play' button next to the File Path no longer launches my default video application (VLC). It was working fine in v1.9.2.
Reply
#18
Upgraded from 1.9.2 to 1.10.0 (Installed to old directory)
I cannot open Ember after upgraded (unless downgrade).
Throw an error box and auto closed.

SQL logic error
no such column: Certification
Reply
#19
(2021-06-14, 10:30)mark0380 Wrote: The movie's runtime seems to have disappeared from the main display window?  Is there a setting I am missing to switch it back on perhaps?
I forgot to put it back in. Will be fixed in the next release.
 
(2021-06-14, 10:30)mark0380 Wrote: The 'Play' button next to the File Path no longer launches my default video application (VLC). It was working fine in v1.9.2.
I've to check that.
Reply
#20
(2021-06-14, 10:34)WatsonsW Wrote: Upgraded from 1.9.2 to 1.10.0 (Installed to old directory)
I cannot open Ember after upgraded (unless downgrade).
Throw an error box and auto closed.

SQL logic error
no such column: Certification
Sounds like a DB-Upgrade problem. Please try to delete the file .\Ember Media Manager\Profiles\PROFILENAME\MyVideos47.emm and start Ember again. If you still have this issue please post your log (maybe delete all logs from today before to get a clean one) and post it on http://pastebin.com
Reply
#21
(2021-06-14, 11:25)DanCooper Wrote:
(2021-06-14, 10:34)WatsonsW Wrote: Upgraded from 1.9.2 to 1.10.0 (Installed to old directory)
I cannot open Ember after upgraded (unless downgrade).
Throw an error box and auto closed.

SQL logic error
no such column: Certification
Sounds like a DB-Upgrade problem. Please try to delete the file .\Ember Media Manager\Profiles\PROFILENAME\MyVideos47.emm and start Ember again. If you still have this issue please post your log (maybe delete all logs from today before to get a clean one) and post it on http://pastebin.com

Thanks. The method works and no data loss.
I can start ember 1.10.0 now.
Reply
#22
Another issue

I cannot keep Always Display Genre Text checked.
(Check It -> Apply or OK -> Close & Open [Settings] -> Still Uncheck)

I tried check/uncheck the other options under [Main Windows].
All works except Always Display Genre Text.

Settings > Options (Tab) > General (Tab) 
Image
Reply
#23
(2021-06-14, 12:50)WatsonsW Wrote: All works except Always Display Genre Text.
I also liked to notice that the texts are not displayed after I activated the option. But I didn't notice that the setting was not saved, so thanks for the information.
Reply
#24
I like the changes so far.  Noticed a few problem.  When I scaped new movies in the past, I had it auto create extrathumbs.  I had this set to 100 in the settings for the limit, which worked great.  Now when I add a new movie it only does 20 and not the 100 it did before. 

I also use to place additional images in the extrathumbs folder which use to add in, now they get deleted from the folder after doing any type of  edit.

The year does not always show up after the title in the list when scrapping new movies.
Reply
#25
(2021-06-14, 11:23)DanCooper Wrote:
(2021-06-14, 10:30)mark0380 Wrote: The movie's runtime seems to have disappeared from the main display window?  Is there a setting I am missing to switch it back on perhaps?
I forgot to put it back in. Will be fixed in the next release.
 
(2021-06-14, 10:30)mark0380 Wrote: The 'Play' button next to the File Path no longer launches my default video application (VLC). It was working fine in v1.9.2.
I've to check that.
Thanks for that.

Another little thing to add to the list: changes made to the movie's title in the 'Edit' window are not refreshed on the left column list until Ember is closed and re-opened.
Reply
#26
(2021-06-14, 17:50)Zacgates2017 Wrote: I like the changes so far.  Noticed a few problem.  When I scaped new movies in the past, I had it auto create extrathumbs.  I had this set to 100 in the settings for the limit, which worked great.  Now when I add a new movie it only does 20 and not the 100 it did before. 

I also use to place additional images in the extrathumbs folder which use to add in, now they get deleted from the folder after doing any type of  edit.

The year does not always show up after the title in the list when scrapping new movies.
Ditto for me also regarding the movie year. Previously it would be displayed with the title as "Movie Title (2021)". Now I see there is a new column with the year displayed, which is fine. But all my old movies are displayed in the old format. The only way I can find to "remove" the (year) from the title is re-scrape the movie. With a large library that prohibitive.
Reply
#27
Installed new version. Have a few minor issues.

On the initial scan for new movies, the TMDb column displays "-1", instead of blank. If I need to manually add an image to a movie, if I click on the "folder" icon to add image, it opens the last folder I had opened in File Explorer, not the folder of the selected movie.

After upgrading my previous version of EMM, I had a 4 custom tab views, but only the first two were migrated to new version. They were easy enough to recreate. It would also be nice to have the ability to change the order of the custom tabs.

Similar to the movies displaying with the "(year)" in the title. The TV Shows used to display "(status)" after the show title. Now there's new column displaying the status. Unless I re-scrape the TV Show there doesn't seem to be a method to remove the "(status)" from the displayed title.

It does seem to scrape quicker than previously.
Reply
#28
Hi Dan - great work, much more stable and better interface for several windows! I however wanted to confirm the issue that I am facing, I have 2 libraries one with over 16k movies and another one with over 1K, for smaller 1K libraries the scan and scrape is super fast and very pleased. However the bigger library with 16k movies the scan takes a long time over 15-20 mins and you pointed out thats expected, however after the update I see even scraping 10 movies is taking 20-30 mins while in smaller library takes less than 2-3 mins. I am not sure why a larger library would take longer to scrape?
Reply
#29
Thumbs Up 
(2021-06-13, 23:09)DanCooper Wrote:
(2021-06-13, 19:02)slowpard Wrote: IMDB ratings scraper seems to broken for me atm, can anybody else confirm this?
(2021-06-13, 19:32)ralfonat Wrote: Seems something is amiss. This should be 6.4:
(2021-06-13, 20:57)Anomen Wrote: Yep, I can confirm that too. If you change the 64 to 6.4 it works though.
Hotfix is linked in the first post. Please report if that helps.
works!  thank you so much
Reply
#30
(2021-06-13, 11:05)DanCooper Wrote:
(2021-06-13, 09:29)madmax2 Wrote: what happen to the old bugtracker?
now we need to create new account.. 
does that mean all our reported bugs/feature request is now gone?

Just yesterday they updated the old bug tracker with a rewriten version. The old data and your accounts are still there but I'm not able to change the (new) permissions to give the users access to it.
Atm i have to wait for an update...

can you update when the old login will work?

I got version 1.10.0 x64
Also where is the hotfix link... is that new than this version?

is version 2.0 coming soon?
since link says
-Pre-Build of Ember Media Manager 2.0.0
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 8
  •   



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.11.x - Download & Discussion Thread0
This forum uses Lukasz Tkacz MyBB addons.