Release Kinos2 - Kodi 16.1 & Retroarch for Apple TV 1
Hi is there a way to get component 480i output? I tried setting component.480i in the config file and that didn't work, i cant use progressive as my tv cant display 480p
Dont think the apple tv supports 480i, only 1080i. I’d try try the composite option. Kinda sucks but..
I'm pretty sure the default is 480i, the boot logo etc shows over component cables fine but it breaks once booting into kodi and the resolution changes its much clearer than using composite
I just checked and it seems I myself skipped support 480i and 576i because I thought nobody was going to need that. I have a separate xorg file for each supported resolution instead of a common one for component/composite which then should be dynamically adjusted according to the resolution set in the config file. Again, probably did it that coz I thought nobody needed that and it saved me 5mins Smile
Easiest thing is that you set it to component.480p in the .kinosrc config file.

Now you need to ssh in and type:
sudo nano /etc/X11/xorg.conf.component.480p

find the line:
Option         "TVStandard" "HD480p" #[HD576i|HD480i/p|576i/p|HD720i/p|HD1080i/p]

change HD480p to HD480i
Awesome thats working thankyou
Hi Soli, hi everyone.

I'm using my good'ol ATV1 with Kinos 2 a lot recently to watch some old movies.
I'm thinking of upgrading it's msata ssd to have more space for more movies and I was wondering if it's possible to change the Kinos install script to create a separate user partition and keep this partition if I need to reinstall the system. Is it feasible?

Sorry, I can’t invest time making that. I’d just use the backup feature, then backup the movies. Install Kinos to the new msata, copy back the movies manually, then restore the backup
Hi, it's me again. After I switched over to a different internet provider just recently, I tried to update the configuration on my ATV. After leaving mine turned off for a while, I turned it back on to reconfigure the WiFi settings, but all WiFi settings had been erased because my ATV had turned off. I tried to access the console with my keyboard, but since I was connected with Component video, the console was a garbled mess, making it impossible to reliably connect to WiFi. So the problems are:
1. My WiFi settings are erased every time the ATV turns off, therefore I can't SSH in remotely
2. The console is unreadable over Component; if I'm not getting an Unsupported Signal error, I see a load of rolling garbage which just barely resembles the actual console.
3. I can't change to use HDMI because I can't do either of these things. This also means I can't update my WiFi settings
So far the only idea I've come up with is to connect to my laptop with an ethernet cable and SSH from there, but is there any easier way?
It should save the wifi settings, but I dunno why it doesnt. you could always try to delete everything under /var/lib/connman (aka sudo rm /var/lib/connman/*)

Can’t you just put it near the router and use an ethernet cable? When everythings up, you could move it near your tv.
Hi Soli,

Nice, that's what i did.
It's impressive what you've accomplished with Kinos. Weeks ago I opened a 30Gb mkv 1080p movie with a bitrate of 40.5 Mbps, DTS audio and Kinos played it smoothly. Even fast forwarding and rewinding was smooth. Quite impressive for such an old and underpowered device like the Apple TV1!

best regards

Logout Mark Read Team Forum Stats Members Help
Kinos2 - Kodi 16.1 & Retroarch for Apple TV 10
This forum uses Lukasz Tkacz MyBB addons.