Solved Can't clean library from movies that existed on a removed network drive - Kodi hangs
#1
I changed my NAS setup at home and removed one NAS that held video source for my Kodi. When I started Kodi I thought I could just clean the library and remove the movies from that old source. I got a question if I wanted to remove the movies from that old (not connected) video source I said ok. Now Kodi hangs and no movies are deleted. I have restarted and tried a few times with the same result.
This is how I understood I should remove thois video source. Is there another way?

I can add another source and when I add the same movies from the new source I get duplicates of those movies.
I can manually remove each of the movies that are mounted from the old source but there are too many movies.

Anyone who has a proposal for me?

I'm running Kodi 19.1 on Linux.
Reply
#2
(2021-07-03, 10:46)nilaz Wrote: Is there another way?

Do a video library export (using separate files), all 'working' movies will be exported. Don't forget to activate the use of watched statuses and resume points in the advancedsettings.xml file.
Backup/rename your current database file(s).
Restart Kodi, setup your movie source(s), and repopulate your video database.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#3
(2021-07-03, 11:21)Klojum Wrote:
(2021-07-03, 10:46)nilaz Wrote: Is there another way?

Do a video library export (using separate files), all 'working' movies will be exported. Don't forget to activate the use of watched statuses and resume points in the advancedsettings.xml file.
Backup/rename your current database file(s).
Restart Kodi, setup your movie source(s), and repopulate your video database.
Thanks! I will try that.

Regards,
Niklas
Reply
#4
(2021-07-03, 11:21)Klojum Wrote:
(2021-07-03, 10:46)nilaz Wrote: Is there another way?

Do a video library export (using separate files), all 'working' movies will be exported. Don't forget to activate the use of watched statuses and resume points in the advancedsettings.xml file.
Backup/rename your current database file(s).
Restart Kodi, setup your movie source(s), and repopulate your video database.

Thanks! It worked direct.

Regards,
Niklas
Reply
#5
Thread marked solved.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Can't clean library from movies that existed on a removed network drive - Kodi hangs0
This forum uses Lukasz Tkacz MyBB addons.