Suddenly xCode stating "Unable to Install Kodi"... iPad 7th & 8th, ios 14.6
#1
Oh wise colleagues...
 
I'm baffled because I haven't changed any variables in my Kodi experiment, and yet am seeing different outcomes.
 
Context:
  o Own an iPad 7th gen and an iPad 8th gen
  o Both running ios 14.6
  o Have been loading Kodi 18.6 on the newer, 19.1 on the older for weeks and weeks now
  o Using a nice M1 mac laptop, Xcode 12.5 (I -believe- 12.5.1) 
  o Standard process every week:  delete certs from keychain, open xcode to refresh certs, use App Signer to resign .ipa files, use xcode to load onto iPad.
 
Challenge:
  o I tried the same process this week and am greeted with the error " Unable to Install"
 
Debug / QA steps:
  o Have tried using a different (free) developer ID - same results
  o Did a fresh install of Xcode on an older x86-based laptop, did a fresh download and build of the IPA files there, same results
  o Tried installing signed .ipas via itunes, same results, different error: " This app cannot be installed because its integrity could not be verified".  But I used App Signer... am confused.  Did the free developer accounts suddenly become persona non grata?
 
Any thoughts would be welcomed!
Reply
#2
(2021-07-16, 07:04)Klojum Wrote: @island Did you forget how to type in a forum? Quoting a post without any reply is really not useful and not appreciated.

Folks, might either of you have thoughts on what's going on?  Any chance anyone using a free dev license and the process above can verify it's still working for them (eg that this is my issue not a general issue)?

thx

K
Reply
#3
please check if troubleshooting steps from https://forum.kodi.tv/showthread.php?tid=353308 help you
Reply
#4
(2021-07-23, 14:09)kambala Wrote: please check if troubleshooting steps from https://forum.kodi.tv/showthread.php?tid=353308 help you

OH, SON OF A ...  

1. Thank you.
2. Worked a charm.
3. I have -no- idea why everything was working perfectly previously and then magically stopped working. Really, I changed no variables. But clearly xcode lost the UUID somehow.
4. For the simple fix (that'd be me), "RTFM" -- as the original Kodi instructions say:
       -Plug in the device
       -Go to the Product Menu
       -Under Destination, select your device
...THEN regenerate your certificate, and all's well. 

Ugh. But thanks. Smile
Reply



Logout Mark Read Team Forum Stats Members Help
Suddenly xCode stating "Unable to Install Kodi"... iPad 7th & 8th, ios 14.60
This forum uses Lukasz Tkacz MyBB addons.