Kodi from Debian - Support Thread
#16
(2021-09-02, 19:05)MsKlywenn Wrote: Hello,
I switched to 2:19.1+dfsg2-2 and it didn't solve the problem. I tried erasing my .kodi folder and it didn't solve the problem either.
I installed netconsole to read the syslogs from another PC in case there was a kernel panic I was missing, no luck either :/
OK, let's start Smile Does the freeze occur only if you start Twitch stream or playing every video is affected?
Can you also post "glxinfo" and "vainfo" outputs, just to be sure which renderer is in use?
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#17
The computer froze once while not playing any video, I was just looking around in the kodi settings menu. It crashed once while playing a simple xvid video.

glxinfo: https://paste.kodi.tv/xixoreropi
vainfo:
Quote:libva info: VA-API version 1.10.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_10
libva error: /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so init failed
libva info: va_openDriver() returns 1
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_8
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.10 (libva 2.10.0)
vainfo: Driver version: Intel i965 driver for Intel® CherryView - 2.4.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
Reply
#18
Quote:The computer froze once while not playing any video
Can you run "glxgears" for several minutes on X server without Kodi running and a stress tester like cputest? I would like to distinct Kodi related issue from X11 / mesa / drivers issue.
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#19
(2021-09-03, 11:38)basilgello Wrote: Can you run "glxgears" for several minutes on X server without Kodi running and a stress tester like cputest? I would like to distinct Kodi related issue from X11 / mesa / drivers issue.

apt search cputest doesn't yield me any result. I assume this is some kind of app to stress test the cpu. I have a boinc client running at 80% cpu constantly, is that good enough?

I have glxgears running for more than an hour now, no freeze so far, looks fine. Kodi never managed to run more than 30min without freezing the machine. By the way: most of the time I don't have an x server running on this machine, I only start it for kodi and now for glxgears. If that matters.
Reply
#20
You say it happens on a Twitch stream. Do the freezes happen otherwise?
Reply
#21
No, it also froze while playing a simple mp4 video (xvid) and even while not playing any, when I was just going through the settings menu.
Reply
#22
Does this have a metainfo file? Can you point me to it or patch it similar to https://github.com/flathub/tv.kodi.Kodi/pull/115

Thanks
Reply
#23
(2021-07-17, 22:18)basilgello Wrote: For Debian 11 "bullseye":

* To install Kodi, execute the following command in root terminal or shell:

apt-get install kodi
This is simply not working for me:
Quote:[email protected]:~ # lsb_release -a 2>/dev/null | grep Description
Description:    Raspbian GNU/Linux 11 (bullseye)
[email protected]:~ # apt-get install kodi
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package kodi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'kodi' has no installation candidate
[email protected]:~ #
Do I need to add something to sources.list or is there some other way to make this work?
Reply
#24
(2021-09-08, 19:36)MsKlywenn Wrote: No, it also froze while playing a simple mp4 video (xvid) and even while not playing any, when I was just going through the settings menu.
Did you encounter freezes last week? The graphics firmware packages were pushed to bullseye-updates.
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#25
(2021-09-12, 14:52)Razze Wrote: Does this have a metainfo file? Can you point me to it or patch it similar to https://github.com/flathub/tv.kodi.Kodi/pull/115

Thanks

Isn't metainfo file supposed to be in upstream tree (i.e Kodi master branch)? I don't see any files related to it upstream. Can you please file a PR first so I can propagate it to debian packaging?
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#26
(2021-09-12, 18:28)2A0aJTCd Wrote:
(2021-07-17, 22:18)basilgello Wrote: For Debian 11 "bullseye":

* To install Kodi, execute the following command in root terminal or shell:

apt-get install kodi
This is simply not working for me:
Quote:[email protected]:~ # lsb_release -a 2>/dev/null | grep Description
Description:    Raspbian GNU/Linux 11 (bullseye)
[email protected]:~ # apt-get install kodi
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package kodi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'kodi' has no installation candidate
[email protected]:~ #
Do I need to add something to sources.list or is there some other way to make this work?
Please show output of "apt-cache policy kodi kodi-bin kodi-data kodi-repository-kodi"
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#27
(2021-09-14, 10:48)basilgello Wrote:
(2021-09-08, 19:36)MsKlywenn Wrote: No, it also froze while playing a simple mp4 video (xvid) and even while not playing any, when I was just going through the settings menu.
Did you encounter freezes last week? The graphics firmware packages were pushed to bullseye-updates.

That's interesting. Could you tell me which package are you talking about exactly?
Reply
#28
(2021-09-14, 11:39)MsKlywenn Wrote: Could you tell me which package are you talking about exactly?

firmware-amd-graphics, intel-microcode, realtek-firmware at least... There were several CVEs fixed so all three suites were updated (buster, bullseye, bookworm/sid). Please update your system, reboot and try reproducing. If nothing helps, I'll try crafting the gdbserver script to capture the hang.
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#29
(2021-09-14, 11:47)basilgello Wrote:
(2021-09-14, 11:39)MsKlywenn Wrote: Could you tell me which package are you talking about exactly?

firmware-amd-graphics, intel-microcode, realtek-firmware at least... There were several CVEs fixed so all three suites were updated (buster, bullseye, bookworm/sid). Please update your system, reboot and try reproducing. If nothing helps, I'll try crafting the gdbserver script to capture the hang.
I just checked the apt logs. It looks like I got those firmwares at the same time I was doing the upgrade to bullseye.
Reply
#30
@MsKlywenn yesterday VAAPI libraries (libva and friends) got updated. Can you try updating your system?
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi from Debian - Support Thread0
This forum uses Lukasz Tkacz MyBB addons.