Use of FanArt (and NFO files) in file-mode?
#46
OK first of all, YES I HAVE USED THE SEARCH FUNCTION AND READ ALL POSTS AND FOLLOWED ALL LINKS ABOUT THE SUBJECT....

I know that there is a small hack you can do to publish fanart in fileview..
I just don´t get it to work.

I followed the instructions made here: http://forum.xbmc.org/showthread.php?tid=36372&page=2

which would be this:

Quote:I tried to read between the lines and figured out that MyVideoFiles.xml really meant MyVideo.xml.

Since I like xTV, I did it with this skin.

I was able to add the following lines into MyVideo.xml (right before the Video Label control) and it worked. No need to have any Video Library if the movie-fanart.jpg is available.

I have tested this with XBMCPC so there may be a dimension change need for the real thing...

Quote:
Code:
<control type="image">
<posx>0</posx>
<posy>0</posy>
<width>480</width>
<height>400</height>
<visible>!IsEmpty(listitem.property(fanart_image)) </visible>
<animation effect="fade" end="0" time="200">WindowClose</animation>
<animation effect="fade" start="0" end="100" time="200">VisibleChange</animation>
<texture>$INFO[listitem.property(fanart_image)]</texture>
</control>

Now to answer your question:

Quote:
quick question... does it only show the fanart in files mode after scanning to the library? (i'm still in the office and cant check right now.)
I wasn't sure so I went into Settings/Video and Cleaned the Library (before unchecking it)

Went back to the Movies section in my folder and the fanart still work so I assume, it reads it straight from the disk... which is what I wanted

Thanks for your help !

Now I can try to make it a special view that would work better but the proof of concept is here.

When I did so I pasted the code above 6 rows up from the bottom in XBMC/Skin/720p/MyVideo.xml just above:
Code:
<control type="label">
            <include>WindowTitleCommons</include>

Making it look like this:

Code:
<control type="image">
            <posx>0</posx>
            <posy>0</posy>
            <width>1280</width>
            <height>128</height>
            <texture>Header.png</texture>
        </control>
[b]<!-- Start Test fanart in fileview--> [/b]
<control type="image">
<posx>0</posx>
<posy>0</posy>
<width>480</width>
<height>400</height>
<visible>!IsEmpty(listitem.property(fanart_image)) </visible>
<animation effect="fade" end="0" time="200">WindowClose</animation>
<animation effect="fade" start="0" end="100" time="200">VisibleChange</animation>
<texture>$INFO[listitem.property(fanart_image)]</texture>
</control>
[b]<!-- Stop Test fanart in fileview-->[/b]
        <control type="label">
            <include>WindowTitleCommons</include>
            <label>$LOCALIZE[9] - $LOCALIZE[31021]$INFO[Container.PluginName, - ]</label>
        </control>
    </controls>
</window>

The result was, Yes I get the fanart picture, but it is placed in a smaller window up in the left corner, "over" of the navigation bar which is no longer visible due to the Fanart picture.

I realize I probably placed the code at the wrong place since it obviously found the fanart I just wonder where to put the code to get the fanart in the background of the DVDfolders view...

So please help me place the code in the right place...
(Please explain to me as if I where 5yrs old since my programing skills equals that...Smile)

I hope this makes sense to you...

I do thank you all in advance!!!!

//Talle


I use:
XBOX (NTSC 720p, not 480p or 1080i)
T3CH XBMC Atlantis Beta2 build 15805
PM3.HD
Reply
#47
I am not sure why you would need to "edit" anything.
Just get the files in the post #16 of this thread and replace yours per the provided instructions.

Good luck.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Use of FanArt (and NFO files) in file-mode?00