Solved Music Scraping Wrong Artists or Duplicating Artists
#1
I've been on a deep-dive for over a week to clean my music artist/album artist tags, but I'm going nuts over a handful of items that Kodi continues to associate with the wrong artist.  I've made sure the artist.nfo & album.nfo are correct or I deleted them.  For Artist Information Provider I've tried Generic Artist Scraper (discog & allmusic), TheAudioDB Artist Scraper, and Universal Artist Scraper.  They either get the wrong artist all-together, or duplicate multiple entries for the same artist in my library.  I used MP3tag to make sure every item within an artist's folder have exactly the same Artist & Album Artist.  Just yesterday removed my music source from kodi, manually deleted MyMusic82.db & started over.

What can I be missing? 

Example:  Eurythmics/Ultimate Collection keeps scanning it into the library for the artist El Debarge.  I left artist.nfo alone in the Eurythmics folder since that data is correct.  Indeed I also have an El Debarge (don't judge) artist folder (without an artist.nfo file yet) with also an Ultimate Collection album (no album.nfo).  Clearly Kodi is mixing them up or putting them together.

Example2: A couple of tracks in a Third Eye Blind/Demos folder (again, no album.nfo files), and all tags are correct.  One scraper puts one track with some artist "i4Ni" I've never heard of, nor have anything else from.  Another scraper created 6 Third Eye Blind entries in my library.  I even tried clearing the tag for this track & creating the tag from scratch.

Kodi 19.1 (19.1.0) Git:20210822-34a88a9059
Win7x64. Intel Core2Duo E8500 3.26GHz on Gigabyte GA-EP43-UD3L. 4GB DDR2 1066MHz RAM. Nvidia GT240 512MB PCIx16. Multiple displays, including Epson Pro Cinema 7500UB projector + 100" Da-Lite screen.
Reply
#2
Adding MusicBrainz ArtistIDs for both Artist and AlbumArtist will fix those issues for all songs in those albums will resolve the issue.

Do you have AlbumArtist tags?
Reply
#3
The music library is created from the embedded tags, not from nfo files. The way I read your post I believe there is an issue with your embedded tags.

Run your music files through MusicBrainz Picard instead of mp3tag. See if there is a difference with tagging.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#4
Ok, problem resolved.  I had attempted to clean up my library with MusciBrainz Picard earlier this year, and that seems to have contributed to my little problem.  A couple of my problematic tracks are live, and the AcoustID's are wrong. I had to clear the entire tag & go manual.  But this was only half of my problem...

My other issue indeed is some tags in Picard that don't show or align with mp3tag & Kodi must be using those.  In mp3tag I see my correct artists in "Artist" and "Album Artist".  But Picard also has "Album Artist Sort Order" and "Artists" (plural), which were wrong.  I'll just use Picard from here-on.

... big help as always.  thanks.
Win7x64. Intel Core2Duo E8500 3.26GHz on Gigabyte GA-EP43-UD3L. 4GB DDR2 1066MHz RAM. Nvidia GT240 512MB PCIx16. Multiple displays, including Epson Pro Cinema 7500UB projector + 100" Da-Lite screen.
Reply
#5
(2021-08-29, 00:20)curtis-r Wrote: I'll just use Picard from here-on.
Ensure you also set 4.2 and 4.3 here... https://kodi.wiki/view/Music_tagging#Tagging
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#6
I had not!  Thanks.
Win7x64. Intel Core2Duo E8500 3.26GHz on Gigabyte GA-EP43-UD3L. 4GB DDR2 1066MHz RAM. Nvidia GT240 512MB PCIx16. Multiple displays, including Epson Pro Cinema 7500UB projector + 100" Da-Lite screen.
Reply
#7
Thread marked solved.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Music Scraping Wrong Artists or Duplicating Artists0
This forum uses Lukasz Tkacz MyBB addons.