New Shield Pro -> Audio settings in Kodi - need some help
#1
Currently upgrading to a shield pro.

I've been having some issues with Matrix 19.1 (the audio side)...so I downgraded to 18.9 -> Figured that out.

My problem is the Audio Setting under System>Audio>audio decoder...

Now...19.1 has two choices...1 - Android IEC Packer...2 - Kodi IEC Packer (Recommended). I used the 2nd one (Kodi IEC Packer because it is recommended) and it keeps dropping out and reverting to the Android one. Once this has happened, the choice is no longer selectable in the GUI and I have to exit Kodi to bring it back ( I have a thread about this (Still no reply.) (Further -> this happens to the passthrough setting as well -> that is...they both change.)

So I thought I would downgrade to 18.9 (A lot of shield people are saying theirs is butter smooth), so seemed like a reasonable thing to do.

However, once I had 18.9 installed, I found that the audio decoder setting is greyed out (unselectable) (set for the Android one) and there is NO other option to select anything else.

So my questions are this...

1 -> what setting are you using here? (Is the Android one the only one available in 18.9?? What about 19.1 -> which one are you using)

2 -> Are there any settings in the Shield side menu that affect what Kodi does with it's audio??

Really appreciate any help you can offer. Many thanks.
ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION with LIVE on SSD (now updated to Nvidia Shield Pro (P2897)
Reply
#2
Kodi (Matrix):

Kodi IEC Packer

Shield:

Advanced sound settings -
Dolby audio processing: Enabled

Available formats -
Auto: Use the formats your audio device reports supporting (recommended)
Reply
#3
(2021-09-15, 10:30)Hitcher Wrote: Kodi (Leia):

Kodi IEC Packer

Shield:

Advanced sound settings -
Dolby audio processing: Enabled

Available formats -
Auto: Use the formats your audio device reports supporting (recommended)
Really appreciate the input Hitcher.

Okay...so my problem is that on 18.9 (leia) -> only the Android packer is available and it is blanked out (unselectable). There is NO option to change it with a new install.

Any idea why this would be the case? I have seen in mentioned a few times around the net, but there are NO answers. Would a shield setting be the cause, or perhaps some setting in Kodi I have overlooked? Thanks
ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION with LIVE on SSD (now updated to Nvidia Shield Pro (P2897)
Reply
#4
It was probably a v19 feature.
Reply
#5
(2021-09-16, 00:04)Hitcher Wrote: It was probably a v19 feature.
I'm a little unsure exactly what part of my reply this relates too?

Are you saying the ability to select a packer is a V19 feature?

What confuses me is that above, you say you use the Kodi IEC Packer in V18 (leia) -> yet for me, there is NO option to use the Kodi IEC Packer. It is blanked out and the Android (RAW) one is shown.
ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION with LIVE on SSD (now updated to Nvidia Shield Pro (P2897)
Reply
#6
Sorry, meant Matrix.
Reply
#7
(2021-09-16, 09:58)Hitcher Wrote: Sorry, meant Matrix.

Thanks. Makes sense.

I got a good way into setting up Leia 18.9 yesterday, only to sit down an hour or so later to find the shield had updated it all to 19.1. Dizam!

I think I've found the setting now (thought I had them all locked down...but obviously NOT!)

Still can't understand why Kodi is crashing back to the Android Packer! (I do have a log in my other thread)
ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION with LIVE on SSD (now updated to Nvidia Shield Pro (P2897)
Reply



Logout Mark Read Team Forum Stats Members Help
New Shield Pro -> Audio settings in Kodi - need some help0
This forum uses Lukasz Tkacz MyBB addons.