Kodi no longer opening show folders when using MariaDB
#1
During the summer I set up MariaDB on my QNAP and connected the kodi installs from both my Nvidia Shields to it. It was pretty easy and apart from the delay in getting the episode listings in the folders it worked great. Starting last week (before the kodi update with I ended up reverting because it wiped all my customizations), if I would go into TV Shows and select any of the shows, the circular waiting icon stays on the screen for several seconds as per normal, but instead of listing the season folders it just goes back to the main directory with a different show highlighted. If I go through Files under Video and then select the TV Shows source, I can view and watch things without issues.

I determined this is an issue dealing with the database on the QNAP because after I restored kodi with a backup from May (before doing the MariaDB thing) everything worked properly. As soon as I restored the connection to the database the problem returned. The only thing that changed since last week was a firmware update to the QNAP. Nothing in MariaDB or the database in myPHPadmin has been touched since setting it up.

In the below log file, it looks like the issue may start at line 4640, which is just before I tried to go into the America's Test Kitchen show folder.

http://paste.kodi.tv/ibusalojuh

If this post is in the wrong section, please let me know.
Reply
#2
(2021-10-14, 00:42)Ferkner Wrote: During the summer I set up MariaDB on my QNAP

A couple of things...
  • First remove the wizard you have installed on your Kodi setup. "Wizards" typically come with one or more banned add-ons (which can disrupt core Kodi functionality), making your setup not eligible for support as per forum rules (wiki).
  • MariaDB 5.5 was EOL some 4.5 years ago. If you can upgrade, please do.
  • A database only stores links and data, it should not affect opening SMB/NFS folders. Kodi stores full path info for every video, so any change or deviation in those paths can present a problem.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#3
So I fussed with this all afternoon. I removed that wizard thing because I don't even know what it was or where it came from. It was out of date anyhow. I think it may have been a thumbnail wizard to export the thumbnails for everything out of kodi. Anyhow, that doesn't matter.

there is MariaDB 10 for the QNAP but I cannot get it to work. When it's enabled I cannot log into phpMyAdmin. I changed the config settigns for phpMyAdmin like the MariaDB 10 app says to and it still refused to work. I uninstalled very 5.5 and 10, reinstalled 10 on it's own with no luck. I uninstalled phpMyAdmin and reinstalled. Nothing.

After hours of fiddling with the two versions of Maria DB and phpMyAdmin, I rollback the QNAP firmware from 5.0 back to 4.5.4.1800. Guess what? Everything is working again. The darn firmware borked something. So now it's working and I have let them know there is a problem. I have no idea what the problem is or what causes it since you said not accessing the database shouldn't prevent opening SMB/NFS folders.
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi no longer opening show folders when using MariaDB0
This forum uses Lukasz Tkacz MyBB addons.