Bug Report: Unchecking "Use Zero Padding Between Consecutive Recordings"
#1
Hi everyone,

On the "PrimeTime" tab, at the bottom, there is an option entitled "Use Zero Padding Between Consecutive Recordings."  If checked, then PTR timers will have no padding, which is expected.

However, if I uncheck this option, I would expect that recordings WILL HAVE padding, usually 2-3 minutes beforehand.  But, instead, the recordings starting 2-3 minute LATE.  I presume that when you coded this option, you should have included a minus (or not included a minus), but didn't.

You should be able to duplicate this yourself quite easily just by unchecking the option and then letting it run for a few days, but if you need anything else, please let me know.
I welcome comments and suggestions for the Kodi (XBMC) Set-up Guide that I wrote.
You can read it here:  http://forum.kodi.tv/showthread.php?tid=193310
Reply
#2
Hi advocate,

Good guess about the minus sign, but that's not the case, in this mode swmc is just letting wmc record the shows with its default padding.  This is the way wmc does consecutive recordings on the same channel: it absolutely refuses to use additional tuners in order to give the user the padding they request between the shows.  You can verify this yourself by scheduling the consecutive/same channel recordings with wmc - it will ignore the padding you set in wmc so that it only uses one tuner.  This annoyed me too, that's why I coded the zero padding option for PT figuring it was at least better then the default behavior.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#3
(2021-10-20, 00:11)krustyreturns Wrote: Hi advocate,

Good guess about the minus sign, but that's not the case, in this mode swmc is just letting wmc record the shows with its default padding.  This is the way wmc does consecutive recordings on the same channel: it absolutely refuses to use additional tuners in order to give the user the padding they request between the shows.  You can verify this yourself by scheduling the consecutive/same channel recordings with wmc - it will ignore the padding you set in wmc so that it only uses one tuner.  This annoyed me too, that's why I coded the zero padding option for PT figuring it was at least better then the default behavior.

I think you've misunderstood my concern.  The issue is NOT that WMC isn't using padding.  The issue is that, even when there are NO CONSECUTIVE SHOWS, the recording starts 2-3 minutes LATE (after the show has started) if I uncheck this option.
I welcome comments and suggestions for the Kodi (XBMC) Set-up Guide that I wrote.
You can read it here:  http://forum.kodi.tv/showthread.php?tid=193310
Reply
#4
I don't understand what's going on then.  I use PT to record niners games every week (it finds whatever time and channel the game is on and auto records it), so its not a consecutive episode, and they always have the padding they are supposed to have.  I'll take a look at the code this weekend to see if I can spot anything.  Also the serverwmc logs should show when the PT recordings will start so if you could check the log file, or post that part of the log file, that would be helpful too.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#5
(2021-10-21, 16:55)krustyreturns Wrote: I don't understand what's going on then.  I use PT to record niners games every week (it finds whatever time and channel the game is on and auto records it), so its not a consecutive episode, and they always have the padding they are supposed to have.  I'll take a look at the code this weekend to see if I can spot anything.  Also the serverwmc logs should show when the PT recordings will start so if you could check the log file, or post that part of the log file, that would be helpful too.
Okay, try this:

1.  Set a PT to record ABC, CBS, and NBC from 8pm to 11pm each night.
2.  Uncheck "Use Zero Padding Between Consecutive Recordings."
3.  Look at the guide and set as many blacklist entries are needed so that only one show records during that period of time on each channel.

What I'm finding is that programs start 2-3 minutes LATE.  In other words, instead of padding (starting 2-3 minutes EARLY), WMC does the opposite and starts 2-3 minutes LATE.
I welcome comments and suggestions for the Kodi (XBMC) Set-up Guide that I wrote.
You can read it here:  http://forum.kodi.tv/showthread.php?tid=193310
Reply



Logout Mark Read Team Forum Stats Members Help
Bug Report: Unchecking "Use Zero Padding Between Consecutive Recordings"0
This forum uses Lukasz Tkacz MyBB addons.