Fan full throttle when playing Video on a MacBook Pro 16
#1
Occasionally I am using Kodi to play back videos recorded by PVR on my MacBook Pro 16.
This causes a massive battery drain and fans start spinning noticable.

It seems as if Kodi is not using any hardware acceleration on this machine and is execution everything on the CPU.
Is this correct or am I missing a "secret" setting somewhere?
Reply
#2
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.
4.Upload the log to Kodi Paste Site manually or use the Kodi Logfile Uploader. (wiki) With either method post the link to the log back here.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file (wiki)

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Use the Kodi Paste Site. Post the link to your pasted log in the forum
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#3
On my 15.4-inch macbook late 2018
I have the same problem
I think it's something with graphics.
when I start playing the video, the fps climbs up to 1200 to 1300

but on my other imac late 2012, where is kodi 18.5 is installed it goes normally, around 40 60 fps
Reply
#4
I found a temporary solution

fps drops when you use the software built-in magnifier from mac os

in mac settings / accessibility / zoom / turn on

if you start playing the video in the code, slightly enlarge the image, just one shift is enough. fps drops and the fan stops.
Reply
#5
not code, but kodi
Reply
#6
Why would you need the OS magnifier to watch a video via Kodi?
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#7
are you using Monterey? FPS issue has already been reported for it, currently there's no ETA on the fix.
Reply



Logout Mark Read Team Forum Stats Members Help
Fan full throttle when playing Video on a MacBook Pro 160
This forum uses Lukasz Tkacz MyBB addons.