Help with vfs.libarchive issue
#1
Hello I am running Kodi 19.3 on ubuntu (Please note - I am not great at Linux!)

I have tried to install IAGL which has a dependency called vfs.libarchive
When I try to install from the repository or zip - I get the error "vfs.libarchive 0.0.0 could not be satisfied"

I have spent a few hours trying to fix it.  In terminal if I
"sudo apt install kodi-vfs-libarchive" it says:

The following packages have unmet dependencies.
kodi-vfs-libarchive : Depends: kodi-api-vfs (>= 3.0.0)
                             Depends: kodi-api-vfs (< 3.1.0)
E: Unable to correct problems, you have held broken packages.

When I try "sudo apt install kodi-api-vfs" I get
Package kodi-api-vfs is a virtual package provided by:
 kodi 2:19.1+dfsg2-2 [Not candiate version]

E: Package 'kodi-api-vfs' has no installation candidate.


Truthfully I have no idea what I'm doing but I have tried, my hunch is this should have been compiled in my kodi version which i installed through terminal following instructions online. 
I understand libarchive seems to be a unzipping thing which IAGL uses, but I don't know what to do from here.
Help would be appreciated, step by step instructions would be perfect.
Thank you Chris
Reply
#2
Hi for anyone with the same issue, in the future - the solution for me -

sudo apt install software-properties-common
sudo add-apt-repository -y ppa:team-xbmc/ppa
sudo apt install kodi

then sudo apt-get install kodi-vfs-libarchive

this worked! unbelievable I don't know how i installed the latest version, but it worked Smile
Reply
#3
I having the same issue. Could you give me a few steps on how exactly you solved the issue please? Thanks
Reply
#4
Which of the mentioned steps above are not clear?

Obviously the op wasn't using the packages from our PPA (so I somehow doubt it was Kodi 19.3 which he was using, but that doesn't matter anymore), which he added afterwards. Is that somehow unclear?
Reply
#5
Following Smokeycoles instructions, I installed the software-properties-common. But I received an error on attempting to add the repository.
    
Quote:$ lsb_release -a
No LSB modules are available.
Distributor ID:    Raspbian
Description:    Raspbian GNU/Linux 11 (bullseye)
Release:    11
Codename:    bullseye

$ uname -a
Linux raspberrypi 5.10.103-v7l+ #1530 SMP Tue Mar 8 13:05:01 GMT 2022 armv7l GNU/Linux

$ sudo add-apt-repository -y ppa:team-xbmc/ppa
Traceback (most recent call last):
 File "/usr/bin/add-apt-repository", line 95, in <module>
   sp = SoftwareProperties(options=options)
 File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
   self.reload_sourceslist()
 File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
   self.distro.get_sources(self.sourceslist)    
 File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 91, in get_sources
   raise NoDistroTemplateException(
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Raspbian/bullseye
Reply
#6
Ubuntu and Debian are not 100% identical, so perhaps @basilgello can have a look.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#7
@Smokeycoles Did you resolve the issue?
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#8
No, I do not know how.
Reply
#9
@larzeb First you should remove doftware-properties-common with

apt-get --purge autoremove software-properties-common

and then post outputs of

apt policy kodi kodi-api-vfs
apt policy kodi-vfs-libarchive

to https://paste.kodi.tv
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#10
Hope I did it correctly.

https://paste.kodi.tv/uhejovonuz.kodi
Reply
#11
Yes, you did. Raspberry maintainers did not package the addon. I can try building one for you if I get access to build hardware in 1-2 days.
Maintainer of Kodi from Debian | Got an issue with Kodi from Debian? Report it here: Kodi from Debian - Support Thread
Reply
#12
If he doesn't need it, I do. I, too, am using Raspberry OS Bullseye, so 👍
Reply
#13
It's been about a week. Is there something else that I need to do? Because
sudo add-apt-repository -y ppa:team-xbmc/ppa
still gives me that error.
Reply



Logout Mark Read Team Forum Stats Members Help
Help with vfs.libarchive issue0
This forum uses Lukasz Tkacz MyBB addons.