• 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 18
Advanced Kodi Launcher - Game and Emulators frontend for Kodi
#61
(2022-11-23, 14:53)larsete Wrote: Ok I just realized that the skin is trying to load a different image. So while AKL loads "boxfront" for icon and thumbnail, Estuary tries to load "icon" which in the jsons is set to "DefaultProgram.png":
json:

  {
   "art":{
    "3dbox":"D:/Emulators/Kodi/Arcade/Assets/3d boxes/hharry.png",
    "banner":"D:/Emulators/Kodi/Arcade/Assets/banners/hharry.png",
    "boxback":"D:/Emulators/Kodi/Arcade/Assets/boxbacks/hharry.png",
    "boxfront":"D:/Emulators/Kodi/Arcade/Assets/boxfronts/hharry.png",
    "cartridge":"",
    "clearlogo":"D:/Emulators/Kodi/Arcade/Assets/clearlogos/hharry.png",
    "fanart":"",
    "icon":"DefaultProgram.png",
    "manual":"",
    "map":"",
    "poster":"",
    "snap":"D:/Emulators/Kodi/Arcade/Assets/snaps/hharry.png",
    "title":"",
    "trailer":""
   },
   "id":"05c0291c33b3a57db95b65d014630d26",
   "info":{
    "genre":"Platform / Fighter Scrolling",
    "overlay":4,
    "plot":"This was released in Japanese Arcade's in 1990, and for the NES on November 15th 1991 and sometime in 1992 in Europe.",
    "rating":"",
    "studio":"Irem",
    "title":"Hammerin' Harry",
    "trailer":"",
    "year":"1990"
   },

Is there a way around this without having to edit the json files?

Thanks!!
I'll have to check on the icon field with Estuary. In the Arctic Zephyr skin I made it so that the boxfront is the default image when showing games. But that only applies to that skin.
On collection level, opening up the context menu, you can go to 'Choose defaulty Asset/artwork..' which gives you the option to select the asset you want for Icon etc. However, you can not do this on a virtual collection like 'Most played'.
I think that I do not copy the settings for Icon etc when adding the game to the most played. Could be because of boxfronts between systems are not all the same size, like between SNES boxes and Megadrive boxes. I will have to rethink that part and fix it with the next release.
Reply
#62
(2022-11-23, 16:03)chrisism Wrote:
(2022-11-23, 14:53)larsete Wrote: Ok I just realized that the skin is trying to load a different image. So while AKL loads "boxfront" for icon and thumbnail, Estuary tries to load "icon" which in the jsons is set to "DefaultProgram.png":
json:

  {
   "art":{
    "3dbox":"D:/Emulators/Kodi/Arcade/Assets/3d boxes/hharry.png",
    "banner":"D:/Emulators/Kodi/Arcade/Assets/banners/hharry.png",
    "boxback":"D:/Emulators/Kodi/Arcade/Assets/boxbacks/hharry.png",
    "boxfront":"D:/Emulators/Kodi/Arcade/Assets/boxfronts/hharry.png",
    "cartridge":"",
    "clearlogo":"D:/Emulators/Kodi/Arcade/Assets/clearlogos/hharry.png",
    "fanart":"",
    "icon":"DefaultProgram.png",
    "manual":"",
    "map":"",
    "poster":"",
    "snap":"D:/Emulators/Kodi/Arcade/Assets/snaps/hharry.png",
    "title":"",
    "trailer":""
   },
   "id":"05c0291c33b3a57db95b65d014630d26",
   "info":{
    "genre":"Platform / Fighter Scrolling",
    "overlay":4,
    "plot":"This was released in Japanese Arcade's in 1990, and for the NES on November 15th 1991 and sometime in 1992 in Europe.",
    "rating":"",
    "studio":"Irem",
    "title":"Hammerin' Harry",
    "trailer":"",
    "year":"1990"
   },

Is there a way around this without having to edit the json files?

Thanks!!
I'll have to check on the icon field with Estuary. In the Arctic Zephyr skin I made it so that the boxfront is the default image when showing games. But that only applies to that skin.
On collection level, opening up the context menu, you can go to 'Choose defaulty Asset/artwork..' which gives you the option to select the asset you want for Icon etc. However, you can not do this on a virtual collection like 'Most played'.
I think that I do not copy the settings for Icon etc when adding the game to the most played. Could be because of boxfronts between systems are not all the same size, like between SNES boxes and Megadrive boxes. I will have to rethink that part and fix it with the next release.
Really appreciated your quick answer and insights  Nerd
Reply
#63
Now that I'm reporting things, I've also seen these errors in the log:
Code:

2022-11-24 01:14:49.014 T:16436 ERROR <general>: [plugin.program.akl] resources.lib.views: vw_misc_set_AEL_Content() Invalid AEL_Content_Value "VIRTUAL_COLLECTION"
2022-11-24 01:14:49.024 T:16436 INFO <general>: CPythonInvoker(19, C:\Users\Kodi\AppData\Roaming\Kodi\addons\plugin.program.akl\addon.py): script successfully run
2022-11-24 01:14:49.036 T:4348 INFO <general>: RetroPlayer[PLAYER]: No compatible game client selected, aborting playback
2022-11-24 01:14:49.087 T:16436 INFO <general>: Python interpreter stopped
2022-11-24 01:14:49.597 T:17768 INFO <general>: initializing python engine.
2022-11-24 01:14:50.003 T:17768 ERROR <general>: [plugin.program.akl] resources.lib.views: vw_misc_set_AEL_Content() Invalid AEL_Content_Value "CATEGORY"
2022-11-24 01:14:50.008 T:17768 INFO <general>: CPythonInvoker(20, C:\Users\Kodi\AppData\Roaming\Kodi\addons\plugin.program.akl\addon.py): script successfully run
2022-11-24 01:14:50.077 T:17768 INFO <general>: Python interpreter stopped
2022-11-24 01:14:51.193 T:2100 INFO <general>: initializing python engine.
2022-11-24 01:14:51.621 T:2100 ERROR <general>: [plugin.program.akl] resources.lib.views: vw_misc_set_AEL_Content() Invalid AEL_Content_Value "VIRTUAL_COLLECTION"
2022-11-24 01:14:51.625 T:2100 INFO <general>: CPythonInvoker(21, C:\Users\Kodi\AppData\Roaming\Kodi\addons\plugin.program.akl\addon.py): script successfully run
2022-11-24 01:14:51.690 T:2100 INFO <general>: Python interpreter stopped

Might not be relevant, as I couldn't tie any problem to it, but just in case Smile
Reply
#64
You mean the "Invalid AEL_Content_Value" etc? That is just some AEL legacy I have to correctly fix. Not blocking though.

So, I have fixed the add to favourites issue. Will continue on the rest. If you want to keep track of the progress you can use my Beta Repository and download AKL 1.2.0rc. I'll update progress here also. If you want to get the full package, wait until I release 1.2.0 stable.
Reply
#65
Sure! thank you again for your effort Smile
Reply
#66
Updated the RC in the beta repository again.
Solved the delete collection issue and also fixed the mismapping of icon with boxfronts for the virtual collections. Currently busy adding PEGI rating support, once that is done I will release 1.2.0.
Reply
#67
UPDATE: Release 1.2.0

Version 1.2.0 of AKL has been released and is now available on the stable repository.
Changelog:
  • Added support for PEGI rating
  • Fixed bug deleting collections
  • Proper icon/thumb mapping for virtual collections
  • Fix adding to favourites

FOR ANDROID USERS:
Launching external apps with Android is now possible again if you switch to Kodi Nexus. I have submitted changes to the Android API in Kodi for the Nexus release which enables the possibility to execute Android apps through the StartActivity Kodi method. AKL now makes full use of this functionality. This means:
  • Retroarch launching on Android working with Kodi Nexus
  • Nvidia Gamestream launching (Nvidia Shield) working with Kodi Nexus
Reply
#68
I'd like to try it but I've never been able to launch this - I get this error
Quote:Error Type: <class 'SyntaxError'>
Error Contents: future feature annotations is not defined (io.py, line 35)
Reply
#69
(2022-11-27, 07:36)yawningapples Wrote: I'd like to try it but I've never been able to launch this - I get this error
Quote:Error Type: <class 'SyntaxError'>
Error Contents: future feature annotations is not defined (io.py, line 35)
Looks like some python version issues. It should be no problem if you have > Python 3.7. 
Can you give me some system specs (OS, kodi version etc.). If you have access to a shell/bash/cmd try to type in "python --version" or "python3 --version" and see what it says.
If you are able, see if you can upgrade to a newer version of Python.
Reply
#70
(2022-11-27, 22:59)chrisism Wrote:
(2022-11-27, 07:36)yawningapples Wrote: I'd like to try it but I've never been able to launch this - I get this error
Quote:Error Type: <class 'SyntaxError'>
Error Contents: future feature annotations is not defined (io.py, line 35)
Looks like some python version issues. It should be no problem if you have > Python 3.7. 
Can you give me some system specs (OS, kodi version etc.). If you have access to a shell/bash/cmd try to type in "python --version" or "python3 --version" and see what it says.
If you are able, see if you can upgrade to a newer version of Python.
Hey, thanks a lot. Upgraded first to 3.7 and then to 3.10 and got the same issue after both upgrades (3.10 is now set as default). I'm using Kodi Matrix running on Ubuntu bionic. AEL works well.
Reply
#71
(2022-11-28, 14:15)yawningapples Wrote:
(2022-11-27, 22:59)chrisism Wrote:
(2022-11-27, 07:36)yawningapples Wrote: I'd like to try it but I've never been able to launch this - I get this error
Looks like some python version issues. It should be no problem if you have > Python 3.7. 
Can you give me some system specs (OS, kodi version etc.). If you have access to a shell/bash/cmd try to type in "python --version" or "python3 --version" and see what it says.
If you are able, see if you can upgrade to a newer version of Python.
Hey, thanks a lot. Upgraded first to 3.7 and then to 3.10 and got the same issue after both upgrades (3.10 is now set as default). I'm using Kodi Matrix running on Ubuntu bionic. AEL works well.
And do you get the exact same error message? It looks like Kodi is then still not using the newer versions of Python. I need to check how Kodi actually uses Python on Ubuntu. It is common to have multiple Python versions on a OS/system, also it is common to create virtual environments for each python application. So perhaps that your Kodi instance is still using a old version of Python in its virtual env. Anybody else with some background knowledge here on the forum? I dont have a Ubuntu system with Kodi running here, so I will need to set it up to test it myself.

Some background about the error you get:
https://stackoverflow.com/questions/7051...ot-defined
https://docs.python.org/3/library/__future__.html

Here some background about python versions and kodi on linux/ubuntu:
https://forum.kodi.tv/showthread.php?tid=368069
https://github.com/xbmc/xbmc/issues/21243

I will see if I can find out more myself. If you or anybody else has some more input, please let us know.
Reply
#72
Sorry to bother you, but I am well stumped on how to get to those views for the addon. I have installed the RC version of Zephyr Reloaded as well as the AKL version fro the beta repository, but the views are nowhere to be seen. The library is populated and the metadata is all there to be shown. I tried to add the views as a new menu entry but they are not available. Either I am too dense or something is not working as it should. Hope someone can help me here with that :/
AMD Ryzen 5 2700 | Asus ROG Strix B350 ITX | Geforce RTX 2060 
Ubuntu 22.04 LTS | Kernel 6.1 | Nvidia blob drivers | Kodi v20
Reply
#73
(2022-11-28, 21:22)Juppstein Wrote: Sorry to bother you, but I am well stumped on how to get to those views for the addon. I have installed the RC version of Zephyr Reloaded as well as the AKL version fro the beta repository, but the views are nowhere to be seen. The library is populated and the metadata is all there to be shown. I tried to add the views as a new menu entry but they are not available. Either I am too dense or something is not working as it should. Hope someone can help me here with that :/
No problem and I think it is probably an easy fix. I bet you open up AKL through the programs menu/source type. If you open it up through the Game menu/source type it will give you all the desired options.
So add the menu item from the games addons and not from the program addons.
Reply
#74
(2022-11-28, 14:59)chrisism Wrote:
(2022-11-28, 14:15)yawningapples Wrote:
(2022-11-27, 22:59)chrisism Wrote:
(2022-11-28, 14:59)chrisism Wrote:
(2022-11-28, 14:15)yawningapples Wrote:
(2022-11-27, 22:59)chrisism Wrote: Looks like some python version issues. It should be no problem if you have > Python 3.7. 
Can you give me some system specs (OS, kodi version etc.). If you have access to a shell/bash/cmd try to type in "python --version" or "python3 --version" and see what it says.
If you are able, see if you can upgrade to a newer version of Python.
Hey, thanks a lot. Upgraded first to 3.7 and then to 3.10 and got the same issue after both upgrades (3.10 is now set as default). I'm using Kodi Matrix running on Ubuntu bionic. AEL works well.
And do you get the exact same error message? It looks like Kodi is then still not using the newer versions of Python. I need to check how Kodi actually uses Python on Ubuntu. It is common to have multiple Python versions on a OS/system, also it is common to create virtual environments for each python application. So perhaps that your Kodi instance is still using a old version of Python in its virtual env. Anybody else with some background knowledge here on the forum? I dont have a Ubuntu system with Kodi running here, so I will need to set it up to test it myself.

Some background about the error you get:
https://stackoverflow.com/questions/7051...ot-defined
https://docs.python.org/3/library/__future__.html

Here some background about python versions and kodi on linux/ubuntu:
https://forum.kodi.tv/showthread.php?tid=368069
https://github.com/xbmc/xbmc/issues/21243

I will see if I can find out more myself. If you or anybody else has some more input, please let us know.
Thanks, I'll look into those when I have some time. I vaguely remember reading that Kodi ships with its own version of Python? 
 Looks like some python version issues. It should be no problem if you have > Python 3.7. 
Can you give me some system specs (OS, kodi version etc.). If you have access to a shell/bash/cmd try to type in "python --version" or "python3 --version" and see what it says.
If you are able, see if you can upgrade to a newer version of Python.
Hey, thanks a lot. Upgraded first to 3.7 and then to 3.10 and got the same issue after both upgrades (3.10 is now set as default). I'm using Kodi Matrix running on Ubuntu bionic. AEL works well.
And do you get the exact same error message? It looks like Kodi is then still not using the newer versions of Python. I need to check how Kodi actually uses Python on Ubuntu. It is common to have multiple Python versions on a OS/system, also it is common to create virtual environments for each python application. So perhaps that your Kodi instance is still using a old version of Python in its virtual env. Anybody else with some background knowledge here on the forum? I dont have a Ubuntu system with Kodi running here, so I will need to set it up to test it myself.

Some background about the error you get:
https://stackoverflow.com/questions/7051...ot-defined
https://docs.python.org/3/library/__future__.html

Here some background about python versions and kodi on linux/ubuntu:
https://forum.kodi.tv/showthread.php?tid=368069
https://github.com/xbmc/xbmc/issues/21243

I will see if I can find out more myself. If you or anybody else has some more input, please let us know.
That will get me started. I'll have a look once I have some time.
Reply
#75
(2022-11-28, 23:48)chrisism Wrote:
(2022-11-28, 21:22)Juppstein Wrote: Sorry to bother you, but I am well stumped on how to get to those views for the addon. I have installed the RC version of Zephyr Reloaded as well as the AKL version fro the beta repository, but the views are nowhere to be seen. The library is populated and the metadata is all there to be shown. I tried to add the views as a new menu entry but they are not available. Either I am too dense or something is not working as it should. Hope someone can help me here with that :/
No problem and I think it is probably an easy fix. I bet you open up AKL through the programs menu/source type. If you open it up through the Game menu/source type it will give you all the desired options.
So add the menu item from the games addons and not from the program addons.
Oh thanks a bunch for that tip, yes I indeed went through the wrong door to enter the addon.
AMD Ryzen 5 2700 | Asus ROG Strix B350 ITX | Geforce RTX 2060 
Ubuntu 22.04 LTS | Kernel 6.1 | Nvidia blob drivers | Kodi v20
Reply
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 18

Logout Mark Read Team Forum Stats Members Help
Advanced Kodi Launcher - Game and Emulators frontend for Kodi0
This forum uses Lukasz Tkacz MyBB addons.