I can not figure out how to add this movie - nfo file was created
#1
I have a movie its called Florence and The Machine Bestival   Its a concert video.

On windows, it doesn't show the .mkv suffix but it is a mkv file

I made an nfo file. Wierd thing is in windows it shows up as a notepad document icon vs the icon I get for "sysytem file" (looks like a lcd monitor icon)

When I try to scan the movie into my movie library, I have it set for local file only. It asks if I want to ignore and scan movie data base and I say no and then Iit brings up the name of the file again, with the .mkv suffix and then I select OK, and I get stuck in an endless loop without the movie ever getting added.

here is my nfo file data and I saved it as: Florence and The Machine Bestival.nfo

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<movie>
    <title>Florence and The Machine Bestival.mkv</title>
    <originaltitle></originaltitle>
    <userrating>0</userrating>
    <plot></plot>
    <mpaa></mpaa>
    <uniqueid type="movie" default="true">con000008<
    <genre></genre>
    <tag></tag>
    <country></country>
    <credits></credits>
    <director></director>
    <premiered></premiered> <!-- yyyy-mm-dd -->
    <studio></studio>
    <actor>
        <name></name>
        <role></role>
        <order></order>
    </actor>
</movie>


What am I doing wrong?
Reply
#2
(2022-01-15, 05:13)Diamond Dog Wrote: When I try to scan the movie into my movie library, I have it set for local file only. It asks if I want to ignore and scan movie data base and I say no and then Iit brings up the name of the file again, with the .mkv suffix and then I select OK, and I get stuck in an endless loop without the movie ever getting added.
It means there is something wrong with the nfo file.

I can see an error in the tags. You haven't closed off the <uniqueid> tag
Also add a date the Premiered tag. Sometimes Kodi throws a tantrum if it is missing. More a problem with episodes.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2022-01-15, 05:25)Karellen Wrote:
(2022-01-15, 05:13)Diamond Dog Wrote: When I try to scan the movie into my movie library, I have it set for local file only. It asks if I want to ignore and scan movie data base and I say no and then Iit brings up the name of the file again, with the .mkv suffix and then I select OK, and I get stuck in an endless loop without the movie ever getting added.
It means there is something wrong with the nfo file.

I can see an error in the tags. You haven't closed off the <uniqueid> tag
Also add a date the Premiered tag. Sometimes Kodi throws a tantrum if it is missing. More a problem with episodes.

I may not be understanding what you mean by closed off . I made these changes and am still can not add

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<movie>
    <title>Florence and The Machine Bestival</title>
    <originaltitle></originaltitle>
    <userrating>0</userrating>
    <plot></plot>
    <mpaa></mpaa>
    <uniqueid type="movie">con000008</uniqueid>
    <genre></genre>
    <tag></tag>
    <country></country>
    <credits></credits>
    <director></director>
    <premiered>2012-01-15</premiered>
    <studio></studio>
    <actor>
        <name></name>
        <role></role>
        <order></order>
    </actor>
</movie>
Reply
#4
(2022-01-15, 07:30)Diamond Dog Wrote: I may not be understanding what you mean by closed off
<uniqueid type="movie"> - Incomplete tag
<uniqueid type="movie"></uniqueid> - Complete (closed) tag

I copied your tags and it worked ok for me here.

If it is still not scanning, a few issues may be causing it.
1. The nfo file is incorrectly named. Provide a screenshot so I can see the contents of the folder
2. You may be hitting a hash limit. Kodi does not see any changes, so it ignores it. Try renaming the folder. Maybe add the (year) to the folder or remove it if it is already there.
3. The actual nfo file is not in UTF-8 format. Less likely, but can be caused by whichever editor you are using.

If its none of those, provide the screenshot and a Debug Log that captures you trying to scrape that concert.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
(2022-01-15, 07:50)Karellen Wrote:
(2022-01-15, 07:30)Diamond Dog Wrote: I may not be understanding what you mean by closed off
<uniqueid type="movie"> - Incomplete tag
<uniqueid type="movie"></uniqueid> - Complete (closed) tag

I copied your tags and it worked ok for me here.

If it is still not scanning, a few issues may be causing it.
1. The nfo file is incorrectly named. Provide a screenshot so I can see the contents of the folder
2. You may be hitting a hash limit. Kodi does not see any changes, so it ignores it. Try renaming the folder. Maybe add the (year) to the folder or remove it if it is already there.
3. The actual nfo file is not in UTF-8 format. Less likely, but can be caused by whichever editor you are using.

If its none of those, provide the screenshot and a Debug Log that captures you trying to scrape that concert.

1. see attached

Image

2. I am not quite understanding this - Folder is Named Florence and The Machine Bestival

3. When I open in wordpad it says text document and I do a save as it says UTF-8, I saved and replaced the orginal file
Reply
#6
(2022-01-15, 07:59)Diamond Dog Wrote: see attached
I think the problem is your naming.
You need to enable Show file extensions on your pc. Then you will spot your error.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#7
(2022-01-15, 07:59)Diamond Dog Wrote: 3. When I open in wordpad it says text document and I do a save as it says UTF-8, I saved and replaced the orginal file
Oh, no don't use that. You may not create clean nfo files and it is what has caused your error in this case.
Install Notepad++ and use it for anything where you are using tags or code.... https://notepad-plus-plus.org/
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#8
(2022-01-15, 08:21)Karellen Wrote:
(2022-01-15, 07:59)Diamond Dog Wrote: 3. When I open in wordpad it says text document and I do a save as it says UTF-8, I saved and replaced the orginal file
Oh, no don't use that. You may not create clean nfo files and it is what has caused your error in this case.
Install Notepad++ and use it for anything where you are using tags or code.... https://notepad-plus-plus.org/
Worked thank you
Reply



Logout Mark Read Team Forum Stats Members Help
I can not figure out how to add this movie - nfo file was created0
This forum uses Lukasz Tkacz MyBB addons.