Videos won't play on kodi 19.4, but VLC will play them fine
#1
Hi,
I'm having a problem with kodi 19.4 playing videos (from youtube, or locally) where all I get is flashing colors.   The same local video played from vlc looks fine.
I've tried setting the "render method" to software, and also disabling "hardware acceleration-dxva" but there is no difference.
I've also tried full screen mode, and windowed mode with no difference.   Does kodi play things back in a different way than vlc or any other player?  It seems odd that only kodi can't play the file.  I've tried multiple files including avi, and mp4.  No luck.

The only other thing I noticed is that there is graphical glitch at the last letter of the words like the picture below shows.  The 2nd picture is what I see during playback which are flashing colors only.

Its an intel integrated graphics chip, core 2 duo processor if that helps.  I'm just surprised because all the videos play fine outside kodi.

Any advice how to fix this would be appreciated.    Alternatively, is there a way to get Kodi to use vlc for playback instead? 


ImageImage
Reply
#2
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.
4.Upload the log to Kodi Paste Site manually or use the Kodi Logfile Uploader. (wiki) With either method post the link to the log back here.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file (wiki)

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Use the Kodi Paste Site. Post the link to your pasted log in the forum
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#3
Thanks for the instructions, I had never done that before.  Hope I did it right.

The link is

https://paste.kodi.tv/owojawuyep.kodi

Any help is appreciated.
Reply
#4
Jherb,
I have the same problem, no viideo and the last letter is scrambled, or strange character
Audio is fine.
If you've found a solution please let me know
robby10
Reply
#5
@robby10  please see post #2 in the thread.
Always read the Wiki, FAQ and search the forum before posting.
Read/follow the forum rules.
Reply



Logout Mark Read Team Forum Stats Members Help
Videos won't play on kodi 19.4, but VLC will play them fine0
This forum uses Lukasz Tkacz MyBB addons.