Build error on current SVN
#1
When compiling the latest SVN i get the following build error:

Quote:g++ -MD -c -g -D_DEBUG -Wall -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/hal -I/usr/include/lzo -DUSE_SDL -D_LINUX -D_FILE_DEFINED -D_REENTRANT -D_LARGEFILE64_SOU
RCE -D_FILE_OFFSET_BITS=64 -DHAS_SDL_JOYSTICK -DHAS_XRANDR -DHAS_PCRE -D'SVN_REV="15422M"' -DINSTALL_PATH="\"/usr/local/share/xbmc\"" -DDLL_PATH_LIBCURL="\"/usr/lib/libcurl.so.4\"" -I../../xbmc/linux -I../../guil
ib -I../../xbmc/ SurfaceSDL.cpp -o SurfaceSDL.o
SurfaceSDL.cpp: In member function 'bool CSurface::CreateFromFile(const char*, CSurface::FORMAT)':
SurfaceSDL.cpp:90: error: 'ClampToEdge' was not declared in this scope
make[1]: *** [SurfaceSDL.o] Error 1
make[1]: Leaving directory `/home/hans/dev/xbmc/XBMC/tools/XBMCTex'
make: *** [tools/XBMCTex/XBMCTex] Error 2

Seems related to http://trac.xbmc.org/browser/branches/li...?rev=15413
XBMC on Gentoo Linux on a Shuttle SG33G6 with Intel C2D E6750, 2GB RAM, Asus EN8500GT
Reply
#2
http://forum.xbmc.org/showthread.php?tid=34655
Reply
#3
Quote:[email protected]mediacenter ~/dev/xbmc/XBMC $ ./build.sh
Local source revision : 15422

On a 32-bit Gentoo system as stated in my subtitle. I use the build.sh method, and i have tried make distclean; ./build.sh to no avail.
XBMC on Gentoo Linux on a Shuttle SG33G6 with Intel C2D E6750, 2GB RAM, Asus EN8500GT
Reply
#4
Just compiled on Ubuntu 8.04 SVN 15430 and also errors out but a completely different error so not sure it's of much help. This failed while compiling Python for some reason. I am cleaning with distclean now and recompiling - didn't realize you could chain commands like that!

Quote:Compiling ../Python/Lib/xml/sax/xmlreader.pyo
pushd ../Python/build/lib.linux-i686-2.4/ && \
zip -0guq ../../../../../../system/python/python24.zip *.so; \
popd
~/XBMC/xbmc/lib/libPython/Python/build/lib.linux-i686-2.4 ~/XBMC/xbmc/lib/libPython/linux
~/XBMC/xbmc/lib/libPython/linux
pushd ../Python/Lib/ && \
zip -0gurq ../../../../../system/python/python24.zip *.py* bsddb compiler curses distutils email encodings hotshot idlelib lib-old lib-tk logging site-packages xml plat-linux2 -x *.svn* *test*; \
popd
~/XBMC/xbmc/lib/libPython/Python/Lib ~/XBMC/xbmc/lib/libPython/linux
~/XBMC/xbmc/lib/libPython/linux
make[2]: Leaving directory `/home/blkmgk/XBMC/xbmc/lib/libPython/linux'
make[1]: Leaving directory `/home/blkmgk/XBMC/xbmc/lib/libPython/linux'
make: Leaving directory `/home/blkmgk/XBMC'

Errors have occurred!

Will investigate and post logs if necessary.

Edit: Okay here's the pastebin log of the compile failure. Very strange I think. http://pastebin.com/m73128603 This is 8.04, from SVN, is version 15430, 32bit, think that's all ya' need.
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#5
BLKMGK: It's exactly the same error. Look at lines 2281 and 2284-2289 of your pastebin post.
XBMC on Gentoo Linux on a Shuttle SG33G6 with Intel C2D E6750, 2GB RAM, Asus EN8500GT
Reply
#6
Thumbs Up 
hrak Wrote:BLKMGK: It's exactly the same error. Look at lines 2281 and 2284-2289 of your pastebin post.

ah! Duh, I hadn't looked that far back, good catch! Nod
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#7
Funny, builds fine here...

I linked to that post not for more info, but so that you would hopefully read the section on compile errors.
Reply
#8
Sorry, apparently XBMCTex is only built if texture.xpr needs rebuilt. Fixed in r15433.
Reply
#9
Yup, works fine now. Thanks for your time!
XBMC on Gentoo Linux on a Shuttle SG33G6 with Intel C2D E6750, 2GB RAM, Asus EN8500GT
Reply
#10
althekiller Wrote:Sorry, apparently XBMCTex is only built if texture.xpr needs rebuilt. Fixed in r15433.

Thanks,
XBMC compiles now fine but has problems to generate the texture.xpr file. I'm not sure, but i think this is the reason, why XBMC hardlocks after the splashscreen for me.

Quote:make[1]: Leaving directory `/root/xbmc/tools/XBMCTex'
tools/XBMCTex/XBMCTex -input \"skin/Project\ Mayhem\ III/media\" -output \"skin/Project\ Mayhem\ III/media/Textures.xpr\"
voulume-panel-bg.png: Error creating surface size 0 by 0
video-pause.png: Error creating surface size 0 by 0
video-info-button-nofocus.png: Error creating surface size 0 by 0
video-info-button-focus.png: Error creating surface size 0 by 0
video-8xr.png: Error creating surface size 0 by 0
video-8x.png: Error creating surface size 0 by 0
video-4xr.png: Error creating surface size 0 by 0
video-4x.png: Error creating surface size 0 by 0

...

DefaultFile.png: Error creating surface size 0 by 0
DefaultArtistBig.png: Error creating surface size 0 by 0
DefaultAddSource.png: Error creating surface size 0 by 0
DefaultActorBig.png: Error creating surface size 0 by 0
Content_Panel_Diffuse.png: Error creating surface size 0 by 0

Writing bundle: skin/Project Mayhem III/media/Textures.xpr
Uncompressed texture size: 1412kB
Compressed texture size: 816kB
Bundle size: 165kB

Wasted Pixels: 318208/1445376 (22.02%)
make: Leaving directory `/root/xbmc'

Full Output:
http://nopaste.php-q.net/45493
Reply
#11
Forgot to say, that it only happens on PNG files. So why is XBMCTex failing to convert the PNG files?
Reply
#12
May want to do a new thread since this is a new issue...
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#13
Need more info, see http://forum.xbmc.org/showthread.php?tid=34655 . I did bother to test that xbmctex actually worked before I committed the change.
Reply
#14
althekiller Wrote:Need more info, see http://forum.xbmc.org/showthread.php?tid=34655 . I did bother to test that xbmctex actually worked before I committed the change.

System: Gentoo x86_64 with Linux 2.6.26

Unfortunately is the build.log to big to be posted on pastebin. But i already copied the error part. The error came on rev15434. Since this is the first time i tried to compile xbmc, i can't tell you, if this happened on older builds.

emerge --info
Reply
#15
XBMC Buildlog
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Build error on current SVN00
This forum uses Lukasz Tkacz MyBB addons.