Kodi on a Steam Deck!
#1
Obviously not much of a 'Build Log' here as it's an entire preassembled device, but no one had posted before.  This is Kodi, installed from a Flatpak on the Steam Deck, then added as a Non-Steam Game through Steam itself to allow all the controls to work easily.  I copied in all the settings and thumbs from my Windows machines, so it has access to my full SQL library as well.  An odd downside is that while in 'Desktop Mode' VAAPI is exposed, if you're running in Game Mode, VAAPI isn't exposed, so the Steam Deck is using software decoding only.  Though it's CPU does have the performance to software decode HEVC 4K at 24fps.  Hopefully Valve fixes this.

Image

Someone on Reddit found a solution for VA-API for Chrome and it seems to apply to Kodi and probably anything else in the Steam Deck's Game Mode. The default launch options are like this:
Quote:run --branch=stable --arch=x86_64 --command=kodi tv.kodi.Kodi

But adding --env=LIBVA_DRIVER_NAME=radeonsi gives it access to VA-API. This is how I wrote it out and it works.

Quote:run --branch=stable --arch=x86_64 --env=LIBVA_DRIVER_NAME=radeonsi --command=kodi tv.kodi.Kodi
Reply
#2
I can only manage to control it via the touchscreen, both in game mode and desktop mode, is that different for you?
Reply
#3
(2022-04-26, 23:53)Razze Wrote: I can only manage to control it via the touchscreen, both in game mode and desktop mode, is that different for you?

In Game Mode I just started mapping various buttons to keyboard presses I wanted the same way I would any game.  Like the D-pad to keyboard arrows , A & B to Enter and Escape, then whatever other hot keys I needed for my use.
Reply
#4
I've added default controller bindings to the beta flatpak, so it should work out of the box now.
Reply
#5
(2022-05-02, 11:01)Razze Wrote: I've added default controller bindings to the beta flatpak, so it should work out of the box now.
Excellent! I had to bind the buttons when I got my deck. It hangs on exit 95% of the time which is kind of annoying, anyone else experience this?
TetradUI                EllipsisUI
Reply
#6
Updated first post with instructions on accessing VA-API in the Steam Deck's gaming mode.
Reply
#7
Hi. Kodi on my steam deck has no sound in game mode (wayland/gamescope). It does have sound in desktop (xorg/kde) so it's not a kodi configuration problem.

I would like to use kodi in steam deck game mode because in desktop mode I'm unable to make steam pass the gamepad to kodi, no matter what I do it always forces desktop controls (not only for kodi, but for everything), whereas in game mode the gamepad works perfect but sound is silent, although kodi shows all the pulseaudio devices as it should (the default, the speakers and headphone jack with the long name, and any bluetooth headphones when I have them connected).

I don't know if it's a kodi problem, I would instead suspect it's something in gamescope, however I have no sound issues whatsoever with any other app or game, linux native or with proton, be it a steam or non-steam app, so it's definitely something weird only in the kodi/gamescope combination that's causing the issue.

I tried kodi flatpak versions (stable and beta), cleared the kodi config in var/flatpak directory every time, to no avail, also tried arch's package (in that case sound worked the first time then in subsequent runs got silent like the flatpak). All with fresh configs and no addons, configs that as I said work fine in desktop mode as to what sound in concerned.

I also tried asking for help about this on steam forums and the steamdeck subreddit but got 0 replies for weeks, which drove me crazy, so (even though I'm not convinced it's Kodi's "fault") I'm asking here since people here are more friendly and knowledgeable in hope that someone helps solving this.

Did anyone here with a steam deck had any similar issue trying to use kodi in game mode (adding kodi as a non-steam game)? Or does anyone have any advice? Many thanks in advance.
Reply
#8
Well it started working (not the GUI sounds, but the movies sounds do work). Not sure what I did, but I think at some point I moved the right stick and turned the internal volume down (which is separated from the master volume) and ended up muting it. Or maybe started working after some SD updates, I don't know, and since the kodi GUI sounds don't work in when run from gamescope I assumed the movies sound wouldn't too, but alas. Should this info be useful to anyone, here it is.
Reply
#9
I dunno what to tell you, I just installed the stable build flatpack from the Discover program and it 'just worked' other than the above mention of what I needed to do to add hardware acceleration working in Gamemode.
Reply
#10
(2022-07-26, 13:45)ogremalfeitor Wrote: Well it started working (not the GUI sounds, but the movies sounds do work). Not sure what I did, but I think at some point I moved the right stick and turned the internal volume down (which is separated from the master volume) and ended up muting it. Or maybe started working after some SD updates, I don't know, and since the kodi GUI sounds don't work in when run from gamescope I assumed the movies sound wouldn't too, but alas. Should this info be useful to anyone, here it is.

Mute is the secret killer of sound in Kodi. Way way back in the XBMC days, I unplugged an entire room's worth of speakers trying to figure out the problem, until I realized I'd just somehow accidentally muted. Since then, in support, it's probably the single most common cause of "sound errors" reported!
Reply
#11
I installed kodi through the package manager and it's super buggy for me. I added my advanced config file. The movie library seemed to download but only one fan art came through. It freezes all the time. If i'm in desktop mode I have to hard shut off the thing. If I'm in steam game mode it allows me to shut the app down through the steam overlay menu. (Which is cool)

Just saying, don't expect the kodi experience to be great yet. This could actually be a really nice box for kodi if you bought the low end one and a dock. It supports 4k 60 out over usb c. But the one that they offer in the package manager doesn't work well for me.
Reply
#12
I finished putting together the "Hackendeck" and I put Kodi on there and installed TetradUI... currently watching a movie. It's actually holoiso, ya know because valve hasn't released steamos 3 yet.
Kodi runs great! No issues. No hanging on exit or freezing or anything.

Figured I'd share for whatever it's worth.
TetradUI                EllipsisUI
Reply
#13
(2022-08-13, 03:24)Ch3dd4rGoblin Wrote: I finished putting together the "Hackendeck" and I put Kodi on there and installed TetradUI... currently watching a movie. It's actually holoiso, ya know because valve hasn't released steamos 3 yet.
Kodi runs great! No issues. No hanging on exit or freezing or anything.

Figured I'd share for whatever it's worth.

Do you have any network shares hooked up? Shared library? My deck seems to be buggy when connecting to the internet. I have three web browsers installed and like only one would connect to amazon.com. It just acts weird connecting to the internet. I figure the bugs i'm experiencing are because kodi is trying to access my local network.
Reply
#14
All my media is from local network NFS shares from a unraid server.
Compared to the steam deck itself, i've actually had less issues with holoiso (unofficial steamos3).
The deck likes to pretend that my wifi has no internet access when all the other connected devices are using internet without issues. I have no idea why connectivity is so spotty on the Deck but it happens on my wifes steam deck too. I'd bet thats what you're dealing with. For me, usually the tried and true "have you tried turning it off and on?" seems to solve the connection issues but not every time either. 

Is it possible your connected through a VPN and trying to access amazon from blacklisted IP addresses? Amazon tends to block VPN connections.
TetradUI                EllipsisUI
Reply
#15
I also still see connecting to steam issues daily on my deck. The 5ghz wifi fix improved it, but still.

So if  your running into problems, you might want to check, if your on 5ghz wifi and try 2,4ghz for now I guess?
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi on a Steam Deck!0
This forum uses Lukasz Tkacz MyBB addons.