Linux Python 3.10 Problem
#1
Hi! I've installed Ubuntu 22.04 LTS and latest Kodi version but a lot of plugins doesn't work, I think the problem is Python 3.10.4. When I click on some plugin menu, Kodi crash and goes back to linux system.
In final line of log there's "INFO <general>: Python interpreter stopped" error.
I know is a known issue but I'd want to know if there's some fix or workaround. Thanks in advance.
Reply
#2
As far as we can tell, this is an upstream bug in Python
Kodi bug report
There doesn't seem to be a working patch or workaround yet.
Reply
#3
(2022-04-28, 20:56)TheJezstarr Wrote: As far as we can tell, this is an upstream bug in Python
Kodi bug report
There doesn't seem to be a working patch or workaround yet.

Can I downgrade to a previous working version? If yes, wich one?
Reply
#4
(2022-04-29, 19:27)Karakalla Wrote:
(2022-04-28, 20:56)TheJezstarr Wrote: As far as we can tell, this is an upstream bug in Python
Kodi bug report
There doesn't seem to be a working patch or workaround yet.

Can I downgrade to a previous working version? If yes, wich one?
I don't know, I have seen some suggestions that is is a regression in 3.10, so downgrading to any 3.9 version would work, but I think it was a problem in some of the later versions of 3.9, too.
Reply
#5
(2022-04-29, 20:11)TheJezstarr Wrote:
(2022-04-29, 19:27)Karakalla Wrote:
(2022-04-28, 20:56)TheJezstarr Wrote: As far as we can tell, this is an upstream bug in Python
Kodi bug report
There doesn't seem to be a working patch or workaround yet.

Can I downgrade to a previous working version? If yes, wich one?
I don't know, I have seen some suggestions that is is a regression in 3.10, so downgrading to any 3.9 version would work, but I think it was a problem in some of the later versions of 3.9, too.
I've tried with 3.9, same error
Reply
#6
Try 3.10.2-1. If I go to 3.10.4-1, many addons don't work.

There was a problem with one rev of 3.9 but I can't remember which one.
Reply
#7
Working okay on python-3.9.9 (gentoo), anything above seems broke here. This bit me about a week ago, was hoping it'd come up
Reply
#8
There are two possible python bugs fingered for this, but one will be fixed in the next versions:
3.10.5
3.9.13
Reply
#9
have the same issue on arch, so i switched to the flatpak version of kodi, kodi wiki flatpak. it comes bundled with the necessary libraries. you .kodi folder will move to (at least on arch) ~/.var/app/tv.kodi.Kodi/data that's the only big difference Ive noticed, but don't quote me on that.

seems to work much better now.
Reply
#10
Does anyone have a good guide how to get to python 3.9.9 (ubuntu 22.04) ?
I compiled 3.9.9 from what I found on google but not sure not sure if it's actually used.
Asrock J5040 powered by Ubuntu 23.10 and KODI
Reply
#11
I'm not smart enough in python and how it works with kodi.  Is installing a newer or older python a valid option for jammy/v22.04? 
https://launchpad.net/~deadsnakes/+archive/ubuntu/ppa
Reply
#12
I've never tried but I would think one would end up in dependency hell.   Make a Timeshift before you try anything. 

Personally I have not upgraded as yet, but had I then i would probably just make a Timeshift for 22.04 then revert to my 20.04 Timeshift.  Once this gets patched Timeshift back to 22.04 and install the fixed python.
Reply
#13
Looks like 3.10.5 is released today  

Python 3.10.5

I haven't been able to update yet, curious if this is a fix...?
Reply
#14
3.9.13 seems okay!
Reply
#15
Hi,

For Ubuntu 22.04, there is a simple workaround.

Download this files :
https://ppa.launchpadcontent.net/team-xb..._amd64.deb
https://ppa.launchpadcontent.net/team-xb...sh_all.deb
http://archive.ubuntu.com/ubuntu/pool/un..._amd64.deb

Add deadsnakes ppa for python 3.9:
https://launchpad.net/~deadsnakes/+archi...lter=jammy

Install libpython3.9

install the previously downloaded packages.

A this time, I have not yet had a segfault error with the python3.10 lib

Regards.
Reply

Logout Mark Read Team Forum Stats Members Help
Python 3.10 Problem0
This forum uses Lukasz Tkacz MyBB addons.