samba speed abnormal
#1
Hi, guys,
I just bought an android tv(sony 75x85j), so I'm quite new to Kodi.
I installed the 20.0 alpha3, also tried the stable 19.4. current test is done on 20.0 alpha3.

I'm experiencing abnormal samba speed:
I tried to copy file with a file manager(X-plore), the speed is about 20MB/s.
The same file copied at about 3.1MB/s inside Kodi under the same network condition.
Here are some screen shots:

Image

Image

This eliminates some high quality video to be played inside kodi.

Any way to improve this? Are there any options that the user can try out ?

Thanks!
Reply
#2
Hi, I also tried kodi on my MacBook Air, the speed is also about 3.1MB/s , but file copies at about 50MB/s using Finder app.

Is this speed limit a preference setup ? 

Here are the screenshots:
Finder on MacBook Air :
Image

Kodi on MacBook Air :
Image
Reply
#3
you can try adjusting the cache settings: https://kodi.wiki/view/HOW-TO:Modify_the_video_cache
Reply
#4
Quote:you can try adjusting the cache settings: https://kodi.wiki/view/HOW-TO:Modify_the_video_cache

Thanks,
the advancedsettings.xml does not exist, so I guess it is currently using the default settings.
so for the 
<buffermode> </buffermode> , should 0 or 4 be used ?
Quote:0 Buffer all internet filesystems (like "2" but additionally also ftp, webdav, etc.) (default)
1 Buffer all filesystems, both internet and local
2 Only buffer true internet filesystems (streams) (http, etc.)
3 No buffer
4 All network filesystems (incl. smb, nfs, etc.)
Or I only change the <memorysize> </memorysize> ?

I don't see a default value for this,
how much memory should be there to surpass the default ?
Reply
#5
You'll want to try buffermode 4, so SMB is buffered as well.
Quote:The number is the buffer size in bytes (20971520 is the default, which is 20MB, which requires 60MB of free RAM). Kodi will not buffer ahead more than this. Note: For the memory size set here, Kodi will require 3x the amount of RAM to be free. Setting this too high might cause Kodi to crash if it can't get enough RAM.
The optimal size depends on your hardware. On a 2GB Ram device you probably shouldn't set this higher than 100MB.

don't forget <readfactor>10</readfactor>
Reply
#6
Hi,
I have done some tests on the same macbook today, include buffermode 4, or memorysize 100MB, the speed goes up to 8 MB/s, and then down to 3.1 MB/s.
At first I thought it was the advancedsettings.xml taking effect, but then I tried the buffermode 0(default) and readfactor 4, or simply delete the advancedsettings.xml and restart kodi,
the speed keeps at 8MB/s, or less, like 7MB/s.

seems the old 3.1MB/s have nothing todo with this advancedsettings.xml.

Then, just as I do the "exit kodi, modify xml, reopen kodi, test copy file " loop, the speed dropped to 3.1MB/s during these loops, and now, the speed keeps it's 3.1MB/s even when memorysize set to 100MB.

I'm having a hard time finding the correlation between the advancedsettings.xml and the copy speed.

Here is the file, I don't think there is a spelling mistake or something like that:

Image
Any idea?
Reply
#7
Finally, seems rebooting the android TV brings the speed up.
Now it can copy at about 15MB/s, and high bitrate video up to 100mbps plays very well.
I will keep an eye on this.
Reply
#8
Thread marked solved.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#9
Hi, @Klojum 
Seems not completely solved by the rebooting .
It started again with low speed 3.x MB/s today. and this time rebooting is not working for the android TV, I also tried rebooting the samba server, not working either.
Since I've done nothing to the config files (including advancedsettings.xml) of the android TV,  
I guess this is a highly reproducible random case on sony android tv (x85j series).
Is there any specific log that I can grab for this case?

(the previous advancedsettings.xml related tests was done on an m2 macbook air on MacOS 12.4 because I don't have root access for the TV).
Reply
#10
And It seems not a video cache problem because play back performance and copy speed is highly correlated.
It seems like a problem of samba itself, or playing back/copying shared problem.
Reply
#11
(2022-11-07, 06:47)whyisnotforwhat Wrote: I guess this is a highly reproducible random case on sony android tv (x85j series).

Well, Kodi has had its fair share of shenanigans with Sony devices over the years, so I guess we can add yours to the list.

(2022-11-07, 06:47)whyisnotforwhat Wrote: Is there any specific log that I can grab for this case?

Kodi basically has only one log file, but will rename the previous session log file into "kodi.old.log" which can be helpful with crashing/freezing Kodi sessions.

The only Android device I have experience with is the Nvidia Shield, which has an onboard SMB server that makes log grabbing pretty simple. Installing your preferred File Manager tool in Android, and have it connect to your 'normal PC', should be one way of getting to the full Kodi log file. Uploading bigger log files could work to https://paste.ubuntu.com, or your could simply cut the big log into smaller pieces and upload/link them separately.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#12
Hi, @Klojum 

I found the log file and logged the debug information with verbose enabled for samba.
The Log is here.

I also found out the userdata folder in android TV, which is accessible by non root.
So I also logged the case with advancedsettings.xml
here and here, whith different settings and same slow speed.

At first time I tried the advancedsettings.xml , kodi's samba copy speed increased to 13MB/s. and I thought it was the advancedsettings.xml taking effect, so I deleted the file, and test again, and strange thing is that the speed is even faster, around 15MB/s.

I though maybe the xml file is related. so I rebooted the android TV, and redo what I did. but the speed went back to 3.2MB/s, and never changed again.
I guess it's a coincident. I missed the log for the fast case. So pasted the slow log above.

Anything unusual ?
Reply
#13
Also, by shenanigans,
it is possible that Sony is doing some stuff here to "accidentally" interfere with kodi ?
Reply
#14
Also tried NFS
When first mounted, seems plays smoothly for a 100Mbps test video file.
After reboot the tv, copy speed is also about 3.1MB/s, and video playback started to stutter.
Looks like not only samba.
Reply



Logout Mark Read Team Forum Stats Members Help
samba speed abnormal0
This forum uses Lukasz Tkacz MyBB addons.