v20 pcsx-rearmed unable to locate BIOS
Sorry to pester, but I'm having some trouble getting the pcsx-rearmed add-on to detect the BIOS file.

I have followed the instructions on the wiki for placing the BIOS file:

However, despite this, pcsx-rearmed still fails to find the file.

I have tried a few other locations according to various sources (forums/Reddit/etc):
  1. ~/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/resources/system/
  2. ~/games/ps1/ (Next to the game I was trying to run.)
Under the "Why isn’t my BIOS working?"

Just to verify the file location, you can see it here.
  • It's in the correct location.
  • It is named correctly.
  • It's the US BIOS, which I'm trying to run a US game.
  • The checksum matches the BIOS requirement table.

LibreELEC:~/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/system # pwd
LibreELEC:~/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/system # ls
LibreELEC:~/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/system # md5sum scph5501.bin
490f666e1afb15b7362b406ed1cea246  scph5501.bin

Can anyone confirm if the documentation is up-to-date regarding the BIOS file location? Or alternative if they have a similar experience with my setup?

Debug Log

The Debug Log can be found here: https://paste.kodi.tv/ebabuvejap


Operating system version/name: LibreELEC 11.0.1
Kodi version: 20.1.0 Git:20.1-Nexus / 2023-03-18
Hardware: RockPro64 (ARM)
{{Merged into post above.}}
Did you try to change the permissions.
For me a first try with
chmod a+rwx scph101.bin
did the job
Correct path should be ~/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/resources/system, the wiki looks to be outdated.
Quote:Did you try to change the permissions.
Just tried it now, that resolves the problem.
Though instead of doing a+rwx, I opted for 544, which was fine for me.

chmod 544 scph5501.bin
Quote:Correct path should be ~/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/resources/system, the wiki looks to be outdated.
Indeed, this is the correct path.
Unfortunately, I'm unable to edit the wiki or create an account to address that. ^-^'
(2023-09-05, 15:25)OmniBlade Wrote: Correct path should be ~/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/resources/system, the wiki looks to be outdated.

I've updated the wiki. Can you confirm it's correct now?
Looks correct to me now.

Logout Mark Read Team Forum Stats Members Help
pcsx-rearmed unable to locate BIOS0
This forum uses Lukasz Tkacz MyBB addons.