Solved Could not connect to repo
Unable to install any third party add-on. Adding repo from zip works fine but install from any of these repos throws error.
log file-

I hope logs are sufficient to find the issue.

PS- I have tried reinstalling kodi, same error.
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
I was trying with multiple repos.
new logs here-
Still have banned repos installed.
sorry, I am new to Kodi.. could you pls help me with names?
I found Crew in banned list so removed it, are there more to be removed?
took logs after removing and restarting Kodi-
Still one left:
CAddonMgr::FindAddons: repository.openwizard v2.0 installed
It's colored orange in the log.
here are new logs-
line 449-471 shows network unreachable, this is a network problem

the ip address it shows to have resolved to is incorrect therefor will not connect

the correct ip addresses you can see here -

this post shows the same problem for github unrelated to kodi, the resolution will not likely work on your sony tv but it gives credence and context -

in short your proxy or network or some other network configuration is incorrect and this cannot be resolved from kodi
I had similar thought looking at connection error. So, I installed Kodi on my Mac connected to same network as TV and to my surprise it worked fine.
IP lookup resolved to correct IP and connection was established successfully.

I don't understand how 2 devices behave differently on same network, technically following same protocol? Weird!
For anyone else facing this issue, error was due to ISP blocking traffic from Kodi. Used mobile hotspot and problem was resolved.
Thread marked solved.

Logout Mark Read Team Forum Stats Members Help
Could not connect to repo0
This forum uses Lukasz Tkacz MyBB addons.