• 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 145
Alpha Arctic Fuse
Hello.

The studio name that appears in my NFO is "<studio>Voltage Pictures</studio>", but it does not appear in the bottom right of the skin. However, I have checked that the studio icon exists in "resources.images.studios.coloured", and it exists in the list.

What is the reason for not appearing in the skin?

Another question. The flags in the movie information (4K, Bluray, Web-DL, HDR10, Dolby Vision...) do not appear. I only see FHD and 4K (1080p and 2160p), the audio channels and the audio type. The other flags I have not managed to appear. Do I have to rename them in any particular way?

Thanks for the great work done on this skin.

Best regards.
Reply
(2023-11-08, 19:37)malvatov Wrote: Hello.

The studio name that appears in my NFO is "<studio>Voltage Pictures</studio>", but it does not appear in the bottom right of the skin. However, I have checked that the studio icon exists in "resources.images.studios.coloured", and it exists in the list.

What is the reason for not appearing in the skin?

Another question. The flags in the movie information (4K, Bluray, Web-DL, HDR10, Dolby Vision...) do not appear. I only see FHD and 4K (1080p and 2160p), the audio channels and the audio type. The other flags I have not managed to appear. Do I have to rename them in any particular way?

Thanks for the great work done on this skin.

Best regards.
I too have been having the same problem for months in Kodi and never been able to solve it. Tried editing the studio name in Metadata Editor and it wont change. Had the exact same problem in other themes too, was using Titan Bingie Mod theme and was unable to change studio logos no matter what i did - tried deleting NFO files etc. However, if you change back to Estuary (Kodi's default them) white logos show up just fine. Wish i could figure it out. Seems to be a problem with the coloured logos. I Just ended up uninstalling the coloured logos and just have the MPAA certification in Arctic Fuse now.
Reply
(2023-11-08, 19:37)malvatov Wrote: Hello.

The studio name that appears in my NFO is "<studio>Voltage Pictures</studio>", but it does not appear in the bottom right of the skin. However, I have checked that the studio icon exists in "resources.images.studios.coloured", and it exists in the list.

What is the reason for not appearing in the skin?

Another question. The flags in the movie information (4K, Bluray, Web-DL, HDR10, Dolby Vision...) do not appear. I only see FHD and 4K (1080p and 2160p), the audio channels and the audio type. The other flags I have not managed to appear. Do I have to rename them in any particular way?

Thanks for the great work done on this skin.

Best regards.

Studio names for the logos are pulled from TMDbHelper online info, so that's why what's in the nfo won't change the logo. It's not ideal but is necessary as a workaround for multiple studio names.

The main issue with local info is that when there are multiple studios the image will always fail because there isn't going to be a logo png with all the studio names combined. Ideally, Kodi would have a way for a skin to get only the first studio from the nfo but unfortunately that's not possible. So the workaround is to use the online info from TMDbHelper since that already splits the studios into individual properties.

EDIT: I might add a toggle for this to prefer local nfo for studio logo first, that way get best of both worlds -- if your library is setup with single studios then can enable that to have more control.

RE: Filename flags. I stopped using these because I'm really not a fan of basing codec info on a filename. I only get codec info which is retrieved from the actual streamdetails (e.g. ListItem.VideoCodec)

For HDR: This isn't currently working simply because I haven't implemented support for the HDRType flag yet. That will be coming.

For Bluray/DVD etc. based on filename tags: I won't be implementing these because these won't be necessary once the new Movies Versions feature is added (see the forum banner).

Once the Versions feature makes it into Kodi main it will be possible to manage multiple versions of a movie from a single library entry -- e.g. if you have bluray and a dvd version, these will now be one entry where you can pick the version to watch rather than having separate library entries for each version (which is the main reason for the flags -- to differentiate them).
Arctic Fuse - Alpha now available. Support me on Ko-fi.
Reply
(2023-11-10, 07:48)jurialmunkey Wrote:
(2023-11-08, 19:37)malvatov Wrote: Hello.

The studio name that appears in my NFO is "<studio>Voltage Pictures</studio>", but it does not appear in the bottom right of the skin. However, I have checked that the studio icon exists in "resources.images.studios.coloured", and it exists in the list.

What is the reason for not appearing in the skin?

Another question. The flags in the movie information (4K, Bluray, Web-DL, HDR10, Dolby Vision...) do not appear. I only see FHD and 4K (1080p and 2160p), the audio channels and the audio type. The other flags I have not managed to appear. Do I have to rename them in any particular way?

Thanks for the great work done on this skin.

Best regards.

Studio names for the logos are pulled from TMDbHelper online info, so that's why what's in the nfo won't change the logo. It's not ideal but is necessary as a workaround for multiple studio names.

The main issue with local info is that when there are multiple studios the image will always fail because there isn't going to be a logo png with all the studio names combined. Ideally, Kodi would have a way for a skin to get only the first studio from the nfo but unfortunately that's not possible. So the workaround is to use the online info from TMDbHelper since that already splits the studios into individual properties.

EDIT: I might add a toggle for this to prefer local nfo for studio logo first, that way get best of both worlds -- if your library is setup with single studios then can enable that to have more control.

RE: Filename flags. I stopped using these because I'm really not a fan of basing codec info on a filename. I only get codec info which is retrieved from the actual streamdetails (e.g. ListItem.VideoCodec)

For HDR: This isn't currently working simply because I haven't implemented support for the HDRType flag yet. That will be coming.

For Bluray/DVD etc. based on filename tags: I won't be implementing these because these won't be necessary once the new Movies Versions feature is added (see the forum banner).

Once the Versions feature makes it into Kodi main it will be possible to manage multiple versions of a movie from a single library entry -- e.g. if you have bluray and a dvd version, these will now be one entry where you can pick the version to watch rather than having separate library entries for each version (which is the main reason for the flags -- to differentiate them).
Thanks. Youve answered a mystery that ive been trying to solve for months - regarding studio logos. I knew it wasnt the theme because ive had the same problem in Titan Bingie Mod. Tried rewriting NFO files, made sure all my scraper settings were correct, downloaded the zip of coloured logos from github just to make sure i had the studios correctly named but still couldnt get them to change. Even tried a fresh new install of Kodi with just Arctic Fuse installed. White Logos work perfectly fine in Kodi's default them so figured it was something to do with TMDBhelper.

'EDIT: I might add a toggle for this to prefer local nfo for studio logo first, that way get best of both worlds -- if your library is setup with single studios then can enable that to have more control.'

This would be great. I dont need a bunch of Studio logos to show up, just one is enough. But i appreciate you cant cater to everybodys needs.
Reply
(2023-11-10, 12:52)loki00 Wrote: Thanks. Youve answered a mystery that ive been trying to solve for months - regarding studio logos. I knew it wasnt the theme because ive had the same problem in Titan Bingie Mod.

I can't say for certain about Titan Bingie mod, but yeah, if they use the same method I'm using here then that'd be the reason why.

(2023-11-10, 12:52)loki00 Wrote: 'EDIT: I might add a toggle for this to prefer local nfo for studio logo first, that way get best of both worlds -- if your library is setup with single studios then can enable that to have more control.'
This would be great. I dont need a bunch of Studio logos to show up, just one is enough. But i appreciate you cant cater to everybodys needs.

It's not so much that I don't want multiple logos; it's that Kodi joins multiple studios for a film into a single string with a "/" separator and there won't be a matching logo with that name.

e.g. The Avengers might list two studios: "Marvel" and "Disney" but Kodi will display that as "Marvel / Disney" which doesn't match up with any file (there's no "Marvel / Disney.png"). Skinning engine has no way to split it back into individual strings, so whenever there's a movie with more than one studio listed it won't work (unless we use an external tool like TMDbHelper where we can script it).

Anyway, it should be working in latest version of the skin because I'm now using TMDbHelper to split the studios from the nfo.
Arctic Fuse - Alpha now available. Support me on Ko-fi.
Reply
In AH2 there was an option for widgets to show information or not, I couldn’t find something similar in fuse. I am using a widgets only view and two of my rows are just text button widgets, and these end up taking about half the screen, any help on how to do this, would really clean up my UI
Reply
(2023-11-10, 15:13)jurialmunkey Wrote: Anyway, it should be working in latest version of the skin because I'm now using TMDbHelper to split the studios from the nfo.

It does work! Finally! Ive been trying to change logos for months! lol Can finally add missing studio logos. Thanks so much
Reply
Has the ratings disappeared (kodi, trakt, imdb etc)? It's not showing up for me. Can't seem to find any toggle options to enable or disable it.

Also the spotlight area doesn't change to show the movie/tv show info I've selected on. It's ok in the home section. But doesn't show on the movies/TV shows section. Spotlight shows but won't change info when scrolling other movies/shows. Hope you get what I mean.

Peace out and love the theme. Been using it for months now and loving the additional options added.
Reply
Hello, first time poster here.

Just wanted to say thank you for this skin and other great skins before.

Having grown attached to AH2 I was initially frustrated that I couldn't get Fuse to behave similarly.

Once I just allowed Fuse to be what it is and work with that, I found myself really enjoying it.

I do have an issue with ratings though. I don't need them.

I've found a way to disable them so they don't show but quitting Kodi and then opening it again brings the ratings back.

Presumably, this is just a bug and I thought I should let you know about it.

One other thing is a large notification that pops up asking me to use/update/ download Trakt.

I don't use Trakt. Is there any way to disable Trakt in the skin settings?

Thanks again
Reply
(2023-11-11, 13:39)derpferd Wrote: Hello, first time poster here.

Just wanted to say thank you for this skin and other great skins before.

Having grown attached to AH2 I was initially frustrated that I couldn't get Fuse to behave similarly.

Once I just allowed Fuse to be what it is and work with that, I found myself really enjoying it.

I do have an issue with ratings though. I don't need them.

I've found a way to disable them so they don't show but quitting Kodi and then opening it again brings the ratings back.

Presumably, this is just a bug and I thought I should let you know about it.

One other thing is a large notification that pops up asking me to use/update/ download Trakt.

I don't use Trakt. Is there any way to disable Trakt in the skin settings?

Thanks again

I'm actually having the opposite issue. The ratings seem to have gone in my case lol. See my post just above yours.
Reply
(2023-11-11, 06:11)TrojanZ Wrote: Has the ratings disappeared (kodi, trakt, imdb etc)? It's not showing up for me. Can't seem to find any toggle options to enable or disable it.

Are you still having this issue with latest version? I did notice a random issue popping up with ratings but I think it is fixed now.

Might also be worth resetting TMDbHelper's ItemBuilder cache from its expert settings if you're still having this issue on latest version.

(2023-11-11, 06:11)TrojanZ Wrote: Also the spotlight area doesn't change to show the movie/tv show info I've selected on. It's ok in the home section. But doesn't show on the movies/TV shows section. Spotlight shows but won't change info when scrolling other movies/shows. Hope you get what I mean.

It seems to be working fine for me. Anything more specific about setup that I might be able to recreate the problem?
Arctic Fuse - Alpha now available. Support me on Ko-fi.
Reply
(2023-11-11, 13:39)derpferd Wrote: I do have an issue with ratings though. I don't need them.
I've found a way to disable them so they don't show but quitting Kodi and then opening it again brings the ratings back.

Not sure how you're disabling the ratings because the skin doesn't support that -- which is why they are being reset to the default values when you restart.

No issue for me to add an option to disable them though. Will be in next update (0.3.24)


(2023-11-11, 13:39)derpferd Wrote: One other thing is a large notification that pops up asking me to use/update/ download Trakt.
I don't use Trakt. Is there any way to disable Trakt in the skin settings?

If you don't have library content, the setup fallsback to using several TMDbHelper widgets, some of which rely on Trakt.

I've actually removed these from the default setup on the current version but since you installed before that, you'll still have the old configuration.

You'll need to go into home customisation and remove the Trakt widgets which require authorization -- most of these will be in the inprogress category. It will be the "Still to Watch" and "Recently Watched" widgets because those use Trakt data.
Arctic Fuse - Alpha now available. Support me on Ko-fi.
Reply
This is by far the greatest skin you've ever come up with! I have used and enjoyed every skin you've released at one point or another. I have a few questions and I apologize if they've been asked already.
  1. What is a dynamic submenu and how do I use it?
  2. When in Category mode and using a submenu, it appears I need to have at least one widget for the category otherwise the submenu widget doesn't show (even with "use as widget" checked off). I have found a way around this by choosing a random widget for the category and setting it to disabled so it doesn't show. That way my submenu widget shows up by itself. Is this okay?
  3. I am using a Live TV page/hub and have it set to widgets only. However when I enter the hub, pressing back doesn't allow me to go back by pressing the back button on my remote. I have to use the left d-pad to get back to the main menu and then click Home. Is it just me or is that a thing?
  4. What is the best way to incorporate genres into the Home hub such that you can move from genre to genre and the row below populates the list on the fly? I can't seem to figure it out! RIght now I have a Movies category, then a Genres submenu item, and the submenu is "used as widget" and then I have the TMDB genres as a widget using the square widget type. Then I can click on a genre and it opens the list. How can I make it so highlighting the genre makes the widget below populate automatically based on what genre is highlighted?
  5. In spotlight, is it possible to change the text label from Open (when it's showing a TV show) to something like "Watch"? "Play" works well for movies.
Once again, thank you so much for this skin! It's truly the best.
Reply
(2023-11-11, 16:34)jurialmunkey Wrote: You'll need to go into home customisation and remove the Trakt widgets which require authorization -- most of these will be in the inprogress category. It will be the "Still to Watch" and "Recently Watched" widgets because those use Trakt data.

I have the same issue but I do have library data. Problem I found is the tmdb track widgets don't show up in my widget list. I had to go into skinshortcuts xml and delete them.
Reply
(2023-11-11, 19:49)ambulancePilot Wrote: This is by far the greatest skin you've ever come up with! I have used and enjoyed every skin you've released at one point or another. I have a few questions and I apologize if they've been asked already.

Thanks Big Grin

Really nice to know that some people are enjoying it as much as I am -- because I know the setup process isn't the most user-friendly in its current alpha development state and some of the defaults are a little janky to say the least, but put in the effort to understand it and it can be really rewarding.

Also, no issues with repeat questions! I know forum threads aren't exactly easy to search. Much prefer people be engaged and asking questions as the feedback about how people are using things and where they are getting stuck definitely helps me to improve things.

(2023-11-11, 19:49)ambulancePilot Wrote: [*]What is a dynamic submenu and how do I use it?

Dynamic submenu basically allows a widget to be used as the submenu.

Example: You have a category called "Genres" which opens the genres section of the library. With a dynamic submenu, you can add that genres section as the submenu.


(2023-11-11, 19:49)ambulancePilot Wrote: [*]When in Category mode and using a submenu, it appears I need to have at least one widget for the category otherwise the submenu widget doesn't show (even with "use as widget" checked off). I have found a way around this by choosing a random widget for the category and setting it to disabled so it doesn't show. That way my submenu widget shows up by itself. Is this okay?

Yeah this is a frustrating limitation of skinshortcuts. It will only build the mainmenu subsections if there's at least one item.

Your approach is basically what I do. Also I found you don't actually need to choose a widget; simply disabling the blank entry will be enough to trick skinshortcuts to build.

Issue thread is here: https://github.com/jurialmunkey/skin.arc...issues/173

(2023-11-11, 19:49)ambulancePilot Wrote: [*]I am using a Live TV page/hub and have it set to widgets only. However when I enter the hub, pressing back doesn't allow me to go back by pressing the back button on my remote. I have to use the left d-pad to get back to the main menu and then click Home. Is it just me or is that a thing?

This is a bug with widgets only layout. I noticed the same problem the other day. Will fix it soon.

(2023-11-11, 19:49)ambulancePilot Wrote: [*]What is the best way to incorporate genres into the Home hub such that you can move from genre to genre and the row below populates the list on the fly? I can't seem to figure it out! RIght now I have a Movies category, then a Genres submenu item, and the submenu is "used as widget" and then I have the TMDB genres as a widget using the square widget type. Then I can click on a genre and it opens the list. How can I make it so highlighting the genre makes the widget below populate automatically based on what genre is highlighted?

What you're looking for a is stacked folder widget but stacking currently that won't work with the adaptive submenu widget due to some technical limits. I'd definitely like to get it working but might be a while off until I figure a good solution.

The alternative is what I mentioned above about dynamic submenus -- add a *category* called genres, then a dynamic submenu with the genres, then enable use as widget.

The other possibility is to add a normal widget with genres using Apps or Text style to get a smaller widget, then add a stacked folder widget underneath for the genre.

(2023-11-11, 19:49)ambulancePilot Wrote: [*]In spotlight, is it possible to change the text label from Open (when it's showing a TV show) to something like "Watch"? "Play" works well for movies.

Yeah I agree, "open" is not exactly best choice. I think originally I was trying to find a word with a similar width but it's kind of a moot point once translations are factored in anyway. I'll change it to "Browse" (I like "watch" but think some people might confused it for "play").
Arctic Fuse - Alpha now available. Support me on Ko-fi.
Reply
  • 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 145

Logout Mark Read Team Forum Stats Members Help
Arctic Fuse0
This forum uses Lukasz Tkacz MyBB addons.