Wired PS4 controller?
Hi I have v20+LibreELEC running on a Raspberry Pi 2 can you use a USB wired PS4 controller with this setup? I don't have a BT dongle so no wireless.
I've confirmed the controller and USB cable are OK with a controller test app on my old Macbook Air.

When I plug the controller into the Pi2 nothing happens (charges for a few seconds).  Pressing PS button does nothing, no buttons or sticks have any effect.

I've read https://kodi.wiki/view/HOW-TO:Configure_controllers but when I select a button to map it just times out.

When I had it connected to the Mac the controller had a blue light, connected to the Pi2 no blue light.

I've tried unplugging and resetting the controller and it's not paired to anything else.

Seems to be connected:
# lsusb
Bus 001 Device 005: ID 054c:05c4 Sony Corp. DualShock 4 [CUH-ZCT1x]

Any help appreciated
This is maybe a clue? Not finding much in search for "failed to claim input"

Kodi:~ # dmesg | grep -i sony
[    5.200536] usb 1-1.4: Manufacturer: Sony Computer Entertainment
[   10.300341] sony 0003:054C:05C4.0001: failed to retrieve feature report 0x81 with the DualShock 4 MAC address
[   10.301067] sony 0003:054C:05C4.0001: hidraw0: USB HID v81.11 Gamepad [Sony Computer Entertainment Wireless Controller] on usb-3f980000.usb-1.4/input0
[   10.301133] sony 0003:054C:05C4.0001: failed to claim input
Doing some more poking around and this might be the issue.  I suspect this controller might also be counterfeit, and that is causing the kernel to not recognize it.

Quote:A friend has since lent me a DualShock 4 controller (which came with his console) and this worked immediately without the below error (A DualShock 3 controller worked too).

I suspect the controller I bought was not a genuine Sony product and have now returned it (it works in Windows, but I guess people cloning the product didn't think about Linux).
Good find with the arch linux forum thread. It looks like the compatibility with knockoff controllers is fixed in Linux 6.2. LibreELEC 11.0.3 is on 6.1. LibreELEC 12 is on 6.4, but still 6.1 for RPi and Amlogic. If you hang onto the controller for another 6 months or so we should see a LE version with >=6.2.
Great, thanks for the info! I'll keep any eye out for the 6.2 update.

Logout Mark Read Team Forum Stats Members Help
Wired PS4 controller?0
This forum uses Lukasz Tkacz MyBB addons.