v20 No metadata artwork is showing
#1
Like a few others, I was running into the odd case where a few of my movies and TV shows were not showing artwork, but others were. I wiped the DB completely, and started fresh and re-scanned everything however I'm still not seeing any artwork. The logs show lots of the following:

2024-03-31 10:38:25.557 T:403961   error <general>: DoWork - Direct texture file loading failed for special://masterprofile/Thumbnails/4/4ced3ab5.jpg

I've run the texturecache.py script, both to delete the cruft but also to try and do a QAX on it, but no joy. I'm not sure what i can do to try and fix this, as it seems like my system is just refusing to load any metadata images. The text is fine, however.

Running MySQL DB, Kodi 20.2 from the Ubuntu PPA with sshfs mounting the folder directly to the system. I've got a debug log, as well, but I don't remember where to paste it. What other info would you like?
Reply
#2
(2024-03-31, 11:52)Offsprin Wrote: I've got a debug log, as well, but I don't remember where to paste it.
Paste here... Kodi Paste Site
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
Done: https://paste.kodi.tv/dihobomome.kodi
Reply
#4
(2024-03-31, 12:02)Offsprin Wrote: Done: https://paste.kodi.tv/dihobomome.kodi
Easy issue first...
All those <...extraart> entries in your advancedsettings.xml are obsolete in v21 and later. The code for that was removed... https://github.com/xbmc/xbmc/pull/22748

As for the images, seems to be a problem creating the thumbnail cache folder on Lines 138-175
error <general>: Create - Error creating /home/offspring/.kodi/userdata/Thumbnails
Permissions problem?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
Welp, thank you. The Thumbnails folder is symlinked to a folder that seems to have been moved at some point, but I didn't even see that error. Thanks for the note on the advancedSettings extraart entries, as well. I'll remove them.
Reply

Logout Mark Read Team Forum Stats Members Help
No metadata artwork is showing0
This forum uses Lukasz Tkacz MyBB addons.