v21 Since version 21.0.1, some videos stop playing after 30 seconds.
#1
I run Kodi on Formular Z10 Pro MAX 4K Android.
Last week, Kodi was automatically updated to version 21.0.1. Since then, some videos (not all) will stop playing after about 30 seconds and Kodi will return to the overview of videos. This also happens with videos that could previously be played.
I haven't been able to find anything that solves this.
Reply
#2
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.
4.Upload the log to Kodi Paste Site manually or use the Kodi Logfile Uploader. (wiki) With either method post the link to the log back here.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file (wiki)

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Use the Kodi Paste Site. Post the link to your pasted log in the forum
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
#3
Created a debug log. Only I can't get to it on Formular (Android).
Reply
#4
I found and used the handy add-on "Kodi logfile uploader". Here the URL https://paste.kodi.tv/xavuxisuzi
I hope you can do something with this.
Reply
#5
What are you actually trying to play?

All I can see in that log is some stuff relating to YouTube - is that your source?
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
#6
Strange, I haven't used YouTube. The films that stop are in MKV op de NAS. I noticed that as soon as subtitles (contained in an SRT file) should appear, playback stops. After I changed the extension of the SRT file, the movie plays as before.
Reply
#7
There have been reports elsewhere about subtitles potentially having issues.

Looks like this may be another case of that - will make a note for that wider discussion.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
#8
This looks to me a problem Android users are having where their system is set up with a Samba app that runs SMBv1.  v1 has serious security issues and is NOT recommended.  Better to use v2 and preferred is v3.  If for some reason you need to remain on v1 please go to settings / Services / SMB Client and set "SMB Chunk Size" to 64 kb.  SMB v1 does not support the default 128 kb chunk size.

scott s.
.
Reply
#9
Thanks for the quick response.
SMBv3 was already listed in the settings with chunk size 128kb. After I set the chunk size to 64kb the problem was solved.
Doesn't a chunk size of 64kb cause other problems?
Reply
#10
Same problem here
I upgraded Kodi to version 21.0 on my NVIDIA Shield TV Pro. 
The video crashes when I choose a subtitle text file after around 10 to 20 seconds. In fact, it crashes each time Kodi finds a sub file having the same name as the video in the movie directory.

You mention Samba but I have no idea how to set these Samba thingy parameters on my NVIDIA Shield TV Pro. Could you be more precise in my case?
Reply
#11
I have a Formuler, but on an NVidea it will probably be the same: go to Settings choose Services and then SMB client. Here you can change the SMB Chunk Size to 64 kb.
Reply
#12
Just logged in to say that this solution worked for me (changing smb chunk size to 64KB).
I have an SMB 2 server running on an old NAS, I don't think this is going to be updated either.
Reply
#13
I have this priblem on nexus and matrix using pluto. around 30sec and it stops playing. changing chunk did not help.
if any have further suggestons am all ears
Reply

Logout Mark Read Team Forum Stats Members Help
Since version 21.0.1, some videos stop playing after 30 seconds.0
This forum uses Lukasz Tkacz MyBB addons.