v21 Black screen on HEVC 10-bits video
#1
Kodi v21 is showing a black screen on one of my MKV movie file. I need to disable hardware DXVA2 to play it properly but then the CPU will be 100% utilized.

The same file can be played on VLC or PotPlayer + LAV with hardware decoding no problem. My media PC is using 10th gen Intel UHD (Celeron N5105) which supports HEVC 10-bit 4:2:0.

Movie file spec:
Format                         : HEVC
Format/Info                    : High Efficiency Video Coding
Format profile                 : Main [email protected]@high
HDR format                     : SMPTE ST 2086, HDR10 compatible
Codec ID                       : V_MPEGH/ISO/HEVC
Duration                       : 2 h 20 min
Width                          : 3 840 pixels
Height                         : 1 600 pixels
Display aspect ratio           : 2.40:1
Frame rate mode                : Constant
Frame rate                     : 23.976 (24000/1001) FPS
Color space                    : YUV
Chroma subsampling             : 4:2:0 (Type 2)
Bit depth                      : 10 bits
Writing library                : x265 2.5+28-7aeabaa92b85:[Windows][GCC 6.2.1][64 bit] 10bit
Language                       : English
Default                        : Yes
Forced                         : No
Color range                    : Limited
Color primaries                : BT.2020
Transfer characteristics       : PQ
Matrix coefficients            : BT.2020 non-constant
Mastering display color primar : Display P3
Mastering display luminance    : min: 0.0050 cd/m2, max: 1000 cd/m2
Reply
#2
Thread moved to video support
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
#3
This is likely a Windows specific issue. Please turn on debug logging, restart Kodi, play the video and provide the kodi.log through paste.kodi.tv
Always read the Kodi online-manual, the FAQ and search the forum before posting.
Do not e-mail Kodi Team members directly asking for support. Read/follow the forum rules (wiki).
For troubleshooting and bug reporting please make sure you read this first.
Reply
#4
Just pasted the log. Thanks in advance!

https://paste.kodi.tv/efuyuyewug.kodi
Reply

Logout Mark Read Team Forum Stats Members Help
Black screen on HEVC 10-bits video0
This forum uses Lukasz Tkacz MyBB addons.