Ugly mouse click and move
Hi all,

I'm french and just tried the new Atlantis XBMC LiveCD.
I found this version pretty stable for a beta, many options are already there, hardware perfectly detected on my two PC, etc. I'm very pleased to found on PC what was perfect on my old xbox (still in use for xbmc !).
That's a GREAT media player, keep on the good the good work.

Nevertheless, i have a strange behaviour with mouse on this version. The cursor move is not smooth (sometimes late behind action, sometimes speed), and the left click sometimes works, sometimes not.
I searched in the forum but found nothing about this issue, so i post here.

The issue is not linked to my PC because it does exactly the same on two diffrent config :
Conf 1 : DS3 965P, 8800GT, E2160, basic MS mouse
Conf 2 : Abit IN73HD, Nvidia IGP, E2180, logitech cordless mouse (vx650)

I saw a bug track system ("trac"), but i didn't find it clear where to find the list of already rported bugs. So apologize if this one already spotted.

Long life XBMC !
I just search "edit post" function for 15 minutes and just see i can't Laugh

Usefull precision on mouse used :
Conf 1 : Microsoft Basic Optical Mouse 1.0A
Conf 2 : Logitech MX620 (and not vx650 that does not exist Blush )
Essentially we like to wait until another user verifies before it hits trac. If the mouse is moving slow, then it indicates that perhaps the framerate is low or CPU usage is very high. Enable debug logging in the system settings menu and see whether this is the case.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Hello jmarshall.

Just tested with debug mode on [email protected]stock + logitech mx620 :

Navigating through menus uses CPU from 0% to 10%
Memory used is 542mb/900mb

So cpu CPU overload.

After this new test, i can split my issue in three ones :

- When accessing a new menu, not previously navigated, there's a lag, but it seems that it's because it is dynamically loading data on the CD (which need to re-speedup after slowdown), so i don't take this as a mouse issue

- Quick mouse move over screen when all is loaded (dvd slowed down and not reading anymore) :
CPU goes up to 25%, mouse move is "smooth", but is not as quick as it should. In fact it is as if the pointer had inertia / is on ice. If i move quickly, i cleary see that the mouse starts moving slightly after my hand moves, and stops sligthy after i stop moving.
=> I think there is no "smooth" issue, but a "move delay" issue on basic menus

- Clicking :
Here is a real issue, not all click seems to be taken into account, but the major point is that nearly every click is, like mouse moves, delayed. But here the delay can be as high as 2 seconds (sometimes linked to dvd loading delay)

- When navigating in menu (browsing video directories of a source, or browsing directories to add a video source path) :
The mouve move is weird : in addition to the delay move, there an other effect :
I move up the nstop, the cursor moves up.
Then i move down : the cursor moves UP for a few pixels then moves down !
This does the same for every direction, when i move the mouse, prior to moving in the asked direction, it seems it finishes the previous move before doing the new one :o

During all those tests, the CPU is not overwhelmed. The mouse moves is there also during a sample 720P video running (each core used @35%), so it is not a P performance issue.

Hope this helps, i try to explain as clearly as i can in english Wink
Hmm, this could be explained by the "trap" we have on the mouse of 2 pixels before triggering a movement. This is to make sure that the mouse cursor doesn't pop up when you bump it. I'll see if it occurs here and whether there's anything that can be done.

Delayed "click" actions, and delays when you move over items is simply due to the framerate dropping slightly as it has to load new textures or load new information in. XBMC uses a gameloop input system - we have to wait for the render/process loop to finish before we can do the next step.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

For what it's worth, I'm having exactly the same issue as lolotwingo (+1 for all the symptoms he is describing).

It happens on two different mice that I'm using--one wireless, one wired. It seems to get progressively worse as I'm using XBMC, especially after I've started playing a video (getting the video to pause is hell!) so I though it might have something to do with the CPU usage...but when I pause the video and go to the hardware specs, the CPU is not pinned at all (well under 20%) and the mouse is still laggy and unresponsive.

Rebooting XBMC seems to fix the problem, but only for a short time.

Scrolling the mouse wheel seems to greatly exacerbate things. If I browse over to a directory with a long list of video files, and then use the mousewheel to go up and down the list, the problem instantly gets quite bad.
Same problem: I get good video playback but the mouse gets progressively more choppy over a short period of time. Clicking sometimes works, sometimes doesn't. I thought for a moment that my mouse was going bad before I swapped it out with another and saw the same behavior.
Yeah, this is still happening in Atlantis beta 2.

I think the easiest way for a developer to reproduce this (if this hasn't already been tried) is to try to use XBMC with a mouse for a while to do some non-trivial task--like rebuilding the entries in your library using the UI or something like that.

If you don't work in the XBMC UI with the mouse for a while, you WON'T see this problem. It comes on slowly at first, but it becomes unmistakable after a while.
There's a bug report for this issue in trac, in case anyone wants to set a watch on it:
Just to let you know: i do face the same problem with the mouse.

AMD64 X2 6000
Nvidia 8600 GTS
nforce 570
Logitech wireless-mouse (+keyboard) via USB

brgrds Fredo
Same problem here...Sad
I have XBMC installed on Ubuntu 8.10 also, but there is no mouse audio SPDIF Smile

Athlon X2 4600+
Asus M2N-X Plus
2 GB ram
Nvidia 7900 GT
Same here. Extremly annoying.

Intel® Celeron® D CPU 3.20GHz
1.5 gb memory
Cheap 3dcard
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Ugly mouse click and move00
This forum uses Lukasz Tkacz MyBB addons.