Fast video playback
#1
I'm running Ubuntu Hardy. XBMC Atlantis installed just fine, and looks fantastic, but when I go to play a flick, the video plays in fast forward with no sound.
Reply
#2
I've experienced the same thing with video files containing a mono MP3 track. I never bothered to troubleshoot as I just sourced an alternative to the video. So basically this is just a "+1" to your problem.
Reply
#3
I tried to get xbmc to play avi, mpg, mov and other files, both mono and stereo audio tracks. They all play in fast forward with no sound.
Reply
#4
don dada Wrote:I tried to get xbmc to play avi, mpg, mov and other files, both mono and stereo audio tracks. They all play in fast forward with no sound.

I've got the same problem, on every plattform i tried, on different hardware.
Reply
#5
"with no sound" -> That's the real problem. We sync to the audio track, and if there's no audio track playing, that's a bit tricky.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#6
I had the same problem with the onboard sound on one of my installs that had a M2N-E SLI board. Disabling pulseaudio fixed my sound, and that fixed the video speed as well.
Reply
#7
Have the same issue. Need to stop the movie, and restart it. Usally it's starts ok the second or third time.....

The reason it has no sound is because it is fastforwarding.

Will post a debug file when I come home.
XBMC Live 9.11
Intel core duo 2,E7400 2.80GHz
P5N7A-VM
1 GB DDR2 667MHz
Reply
#8
I have the same problem as of a few days ago. I run ubuntu 8.10 LTS.

I did an apt-get upgrade recently, dunno if that's connected to this problem somehow?
Reply
#9
Please uninstall or disable PulseAudio.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#10
I had this issue when i first installed XBMC on a fresh 8.04 install of ubuntu.
The problem has to do with the audio not the video. When there is no audio, the video will play at the max frame-rate it can. A strange symptom to be sure, but it's the audio that is at fault.

To fix it, for my soundcard, I had to install the latest alsa drivers to get support (ICHR9 chipset). Once I did that, and verified I could play sound in other applications, i then made sure to set XBMC to use the analog out, and the default device.

Everything worked a charm after that.
Reply
#11
All, I'm experiencing this same problem but with the XBMC Live install off of a CD. I haven't really changed anything...did an apt-get a while ago.

Some of my videos play fine, others play in this "fast forward" mode with no sound. I realize that the problem is with the sound not being parsed correctly, but can anyone shed some light how I can fix or diagnose it?

I've tried playing with the audio hardware settings, changing both devices to iec958 and both to default, neither seems to help.

Thanks for any help.
Reply
#12
Smile 
I can confirm that this issue is caused by PulseAudio.

Remove the package, and you should be all set. Thanks to all who suggested this.
Reply
#13
The XBMC Live installation does not have pulse audio installed.

I've found that using analog versus digital for my audio hardware setting seems to work for right now, but I was pretty sure that I was experiencing the problem even with analog earlier.
Reply
#14
Hi,

I have a question before uninstalling PulseAudio. W
When uninstalling PulseAudio ubuntu-desktop is uninstalled to. Can I avoid this?

Thanks
Martin
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Fast video playback51
This forum uses Lukasz Tkacz MyBB addons.