Periodic jerkyness
#31
BLKMGK:
How do you load your nvidia settings? I had to do it in session or else it wouldn't load.

Are you on IRC? I am on #xbmc-linux on freenode. Please drop by so we can discuss this at a faster pace. Waiting for forum responses drives me mad! Smile
Reply
#32
i am having similar issues here. I originally was using the PPA's from the SVN repo then switched to the beta when it was released and the issue seems to coincide with that switch. MPlayer mostly plays things fine with slight tearing, in XBMC the stuttering is practically unbearable. Not seeing much of anything in the logs but will do a better test when I get home tonight and try and time the stutters and match any log activity.
Antec Fusion
Intel E2160 (1.8GHz)
4GB Patriot DDR2 800
Auztech X-Mystique Sound Card
300GB + 500GB + 750GB + 1TB
Ubuntu 9.10
Reply
#33
Sorry, not been home much at all of late so I work on this in spurts.

Tonight I MIGHT have found a possible solution on my end. It was driving me CRAZY that the build from July was giving me fits. I'm not home much so troubleshooting has been slow. I know that there for awhile the upscaling hosed me on SD DVD but I've turned that off. So tonight in frustration I was watching normal HD cable. Mind you I've recently moved and bought a new 120HZ LCD.... so while watching some cable stuff I swear I saw some jitter! Huh?!

I went into the settings for my TV and turned off the 120HZ stuff, cable now looks better! I played the Killa Sample - smooth! I am not YET prepared to call this potentially solved but in my case it MIGHT be - I'll check tomorrow when\if I've got time on some BD rips. What may have happened was the upscaling setting was dorking me on old TV and then when I moved to new one and turned it off the 120HZ setting may have been messing with me. <sigh> I think I need to mess with it more to see though and I will post more when I'm sure. I suppose it could also be my HDMI\upscaling receiver except I'm pretty darned sure I turned off it's upscaling. I will test more and rule these things out and report back... Hopefully it's this simple for me and the older code will run smoothly again, I will then move to current and see if it's jittering. If so I can go back and step forward to narrow this down...

As for my NVIDIA settings - I use the GUI NVIDIA applet and sometime manually tweak xorg.conf myself. The EDID on this set is probably better than on the last one so hopefully it is setting up better - will check the logs to be sure when I have time.
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#34
Sorry, not been home much at all of late so I work on this in spurts.

Tonight I MIGHT have found a possible solution on my end. It was driving me CRAZY that the build from July was giving me fits. I'm not home much so troubleshooting has been slow. I know that there for awhile the upscaling hosed me on SD DVD but I've turned that off. So tonight in frustration I was watching normal HD cable. Mind you I've recently moved and bought a new 120HZ LCD.... so while watching some cable stuff I swear I saw some jitter! Huh?!

I went into the settings for my TV and turned off the 120HZ stuff, cable now looks better! I played the Killa Sample - smooth! I am not YET prepared to call this potentially solved but in my case it MIGHT be - I'll check tomorrow when\if I've got time on some BD rips. What may have happened was the upscaling setting was dorking me on old TV and then when I moved to new one and turned it off the 120HZ setting may have been messing with me. <sigh> I think I need to mess with it more to see though and I will post more when I'm sure. I suppose it could also be my HDMI\upscaling receiver except I'm pretty darned sure I turned off it's upscaling. I will test more and rule these things out and report back... Hopefully it's this simple for me and the older code will run smoothly again, I will then move to current and see if it's jittering. If so I can go back and step forward to narrow this down...

As for my NVIDIA settings - I use the GUI NVIDIA applet and sometime manually tweak xorg.conf myself. The EDID on this set is probably better than on the last one so hopefully it is setting up better - will check the logs to be sure when I have time.
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#35
Cool! What is your current refresh rate? Shouldn't XBMC just relate to what refresh rate you have?

I have a Sony Bravia W4500, and it's "true" 100Hz but the max refresh rate reported is 60.
XBMC Info as I mentioned before displays 59.94 and 60 Hz. I don't have constant jitter, jus every 10 secs or so.
Reply
#36
Exclamation 
I noticed that on a 30 FPS video, it goes supersmooth, which makes sense when my refresh rate is 60Hz. Kind of solved

XBMC needs pulldown / framerate conversion! I tried this patch http://trac.xbmc.org/ticket/4902 but I get odd results like it doesn't change to the right display mode.
Reply
#37
Right now I'm not sure what my refresh is set to, not sure hwo to display that. I can tell you that since turning off ALL corrections on my TV set I've stopped seeing funky shuddering - grr! No more noise filtering, smoothing, or 120HZ B.S. for now. If I can figure out a good way to get my refresh rate while a movie is up I'll post it - I do not think it's displayed in the information screen.
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#38
In XBMC: Shut down -> System info (the leftmost one).

What FPS are you videos in? The ones that run in 30 FPS are fine. Everything else is kind of jerky.
Reply
#39
I have solved it by setting my desktop refresh rate to 50Hz, then I can survive stuff. The minor part of my collection runs in 30FPS anyway.

Pulldown would be nice though Wink
Reply
#40
Will check my refresh tonight. My movies, the ones I encode, have an AVS script that simply consists of this:

Code:
DirectShowSource("sample.grf", fps=23.976, framecount=137784, audio=false)

I do no filtering or anything and this script is pumped into meGUI for the H.264 encoding afterward. High bitrate so I lose little quality. <shrug> Will update with system info in a bit...
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#41
I have found out that setting the refresh rate to 24p works fine on 24 FPS movies.

But 25 FPS Will judder /Stutter /skip / drop /whatever every minute, while 30 FPS will jerk more often. This happens even if framerate matches the refresh rate.
Reply
#42
Interestingly enough I eliminated tearing using the ATI 8.9 proprietary drivers and setting the slider in Catalyst control centre all the way to the right for quality and then setting XBMC to use driver settings in system/screen

Kryspy
Reply
#43
Sad 
Still having periodic jerkyness with a brand new 8400 GS and running intrepid 8.10.

Running XBMC @ rev 16744


Angry
Reply
#44
Did you set adjust refresh rate in settings/videos/player
Reply
#45
Yes, they are in sync. 60 Hz on 30 FPS.

That's not the problem I think. It's just some issue with the flow of things.. Seems like something has a hard time every 30 secs. Tried xubuntu with FCE, normal ubuntu with and without compiz, killed pulseaudio etc.

It lags for a period of 2-5 secs after every 30 secs or so. Different kind of period on 25 FPS video. 24 FPS seems OK, not noticable.

Might this be a buffer problem? (I am running it off 1 GB lan, and I have tried locally too...)
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Periodic jerkyness51
This forum uses Lukasz Tkacz MyBB addons.