•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   
Linux HOW-TO make XBMC for Linux auto start on Ubuntu
#61
I've followed the instructions to make XBMC autostart but I now cannot get any sound and video is playing at an amazing speed. It all works fine if launched in gnome.

Any ideas where I should start looking to fix this?
Reply
#62
timecmdr Wrote:I've followed the instructions to make XBMC autostart but I now cannot get any sound and video is playing at an amazing speed. It all works fine if launched in gnome.

Any ideas where I should start looking to fix this?

There was an earlier post in this thread in regards to adding your user to the audio section so that could be it BUT I have also found a direct relation what you set in system preferences for audio.

IE I use hdmi audio and set the system audio preferences to

Digitial
dd on
dts on
hdmi
hdmi

Now if I do this before I have alsa setup to passthrough the hdmi line then I get fast fowarding or like wrong speed play on all movies and music, as soon as alsa is setup and recognizes the hdmi device it is fine.

I have fixed this prior as well when using Spdif but changing to

Digital
dd on
dts on
default
default

Just a thought hope it helps.

Dave
Reply
#63
delneet Wrote:Has anybody found a solution to this problem yet?
I am also using the --standalone way explained in the howto...

Excellent howto for a n00b like me btw.

I'm using a pcmcia-card (SMC) which is autodetected by KDE4, but when I boot up in standalone mode, I have no wireless anymore...

Nobody?
Reply
#64
Hi,
thanks for that infos. I have an additional question. Additional to the autostart XBMC I would like to login via vnc to gnome for running torrent, ftpclient etc. Ho can this be achieved.

Do I have to change GDM or xorg.conf or both. As noob it is hard to understand the dependencies of all that modules.

Thanks
Martin
Reply
#65
I did every step that MrCerulean list on this post. It worked! MY only problem is that I am not getting sound since I have done all the steps. If I turm on GDM back again and it will start Ubuntu normally, then Open XBMC, at this point in time I have sound. What is the problem. Anyone can help please?
Reply
#66
Is your user in the group sound ?
What about alsamixer ? How is it set?
Reply
#67
MP3HiFi Wrote:Is your user in the group sound ?
What about alsamixer ? How is it set?

Yes I have added the user to sound group, What is alsamixer, as far as I know my options are set as analog
Reply
#68
morph3u5 Wrote:Yes I have added the user to sound group, What is alsamixer, as far as I know my options are set as analog

I have managed with alsamixer via CLI and it work, but after I restart my pc the sound is not working again. I have to manually to go to Cli again type alsamixer and use the arrow keys to achieve sound.

Can someone help me? Thanks
Reply
#69
morph3u5 Wrote:I have managed with alsamixer via CLI and it work, but after I restart my pc the sound is not working again. I have to manually to go to Cli again type alsamixer and use the arrow keys to achieve sound.

Can someone help me? Thanks

You might be running into the same bug that I did. There's a problem some people are having where the master audio channel gets muted and set to 0% volume on every boot.

Here's the bug in launchpad:
https://bugs.launchpad.net/ubuntu/+sourc...bug/352732

One of the responses links to a guide on uninstalling PulseAudio. It worked for me.
Reply
#70
guys, going back to original topic...........

I followed the MrCerulean instruction (along with the "shut-down" option) and it works pretty well. The only minor issue I have, when shutting down it shuts down in text mode rather than the USplash mode, like when it boots up. any idea how to fix that? Cheers!!!
Reply
#71
nice guide Wink
Reply
#72
Thanks for this HOW-TO. I tried it but encounter problems. XBMC does not load and gives me the following message:


"XBMC needs hardware accelerated opengl rendering.
Install an appropriate graphics driver.

Please consult xbmc wiki for supported hardware
http://wiki.xbmc.org/?title=supported_hardware"


I assume the proprietary FGLRX graphics driver does not load automatically. However, I am still very new to all this linux stuff, so no success doing this manually.

Any help would be much appreciated.
Reply
#73
Great tutorial - i got this working and it looks beautiful!

However, my processor is running at 99 percent...which I have run into everytime i have installed xbmc. I need to run this command

Quote:nvidia-settings --assign="SyncToVBlank=1"

But i have to give nvidia-settings a display, which i cannot seem to figure out. Anyone have any idea how i can tweak my nvidia settings via a command line using this configuration?

EDIT: RESOLVED... added line
Quote:Option "NoFlip" "1"
to nvidia device block in xorg.conf and ignored the original nvidia-settings attempt
Reply
#74
With this setting - how do you launch another application with the launcher plugin!?

I was able to start and control Firefox on the same tty1 but switch back to XBMC was the problem.

Maybe it's better to start another program in tty2 and when i close the program switch back to tty1 (where XBMC is running).

Or has someone a better idea?!

Cheers,
David
Reply
#75
My understanding is that you need a window manager to switch between programs without killing Xorg or switching ttys. I use fluxbox as a WM, but I'd like to use this auto-login process to start fluxbox rather than just xbmc, since I switch between xbmc, wahcade, and boxee (for when my nightly xbmc builds mess up)
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   
 
Thread Rating:
  • 5 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
HOW-TO make XBMC for Linux auto start on Ubuntu55