•   
  • 1
  • 6
  • 7
  • 8(current)
  • 9
  • 10
  • 11
  •   
[WINDOWS] HOW-TO easily get MCE Remote working flawlessly in XBMC with EventGhost
I have configured the plugin and EG and all works well.

Only one question: can I change the meaning of the action associated to a button depending on the state of XBMC?

For example I want Ok to select a menu when I'm navigating but to show the cross menu when watching a video.

Is it possible? can you help me how?

Mf
If you think I'm useful please use the +/- button to raise my reputation
Reply
Was wondering if anyone in this thread could help with the eventghost problem that I posted here: http://forum.xbmc.org/showthread.php?tid=48667
Have also posted in eventghost and green button forums but have had no response and have googled it to death . Would really appreciate any input on how I might troubleshoot this.
Thanks
Reply
Hi All,

I am from Germany, so sorry for my bad english.

I still try to figure out one thing. I really would like to use xmbc, but I can not do the tutorial because eventghost does not reconise my remote commands.

I installed exactly how it is descibed in the tutorial but if I am pressing a key no command appears. It also says that not X10 was found.

Hope You can help.

Thanks,
Regards,
Reply
ptipton:

Did you try the xml I posted in the other thread where we corresponded? I've been using that one for a while and it works fine for both VMC and XBMC. Maybe the MCE 2005 behavior is different, but I suspect it isn't.

PM me if you need more help.
Reply
nchall Wrote:ptipton:

Did you try the xml I posted in the other thread where we corresponded? I've been using that one for a while and it works fine for both VMC and XBMC. Maybe the MCE 2005 behavior is different, but I suspect it isn't.

PM me if you need more help.

Yep have tried your XML file and both it and the alternative one from the other thread work great until I want to watch Livetv in MCE when I get a blue screen with the "the remote sensor is not connected " error. Very frustrating, I've googled and posted in every forum I can think of ( Eventghost, Aus Media Center etc) but no response and I cant figure out how to troubleshoot.
I've tried various remote solutions on this machine, Intellimote, IRsuite etc and am wondering if there is something that these changed which is left after uninstalling.
I have a gyration wireless keyboard and remote also connected to the machine and have tried removing these but makes no difference.
Having looked at all the various remote options I'm convinced Evenghost is the best and your XML file is perfect for my needs just need to get past this last hurdle.
Reply
Hi

Sorry if this qustion is asked before, but I could not find it.

I try to use the XBMC for windows, with my remtoe that comes with Hauppauge HVR-1100 MCE kit.

The remote is working with the mce and the xbmc plugin added.

But it don`t work like I want.

So how do I make my own buttons to do what I want. Like the xbmc that you can load that are maked finish.

I could have alterd that one, but I only get that message that this is predefined. You can`t do anything with this. So I guess this is locked down so no one can do somthing.

So is it possible to make one for my self. And add the key from the keyboard that i nessecerry to work in xbmc. And add the greenbutton to open xbmc and things...

Sorry for my bad english.

Hope some one can help me.


Kindly

Petter
Petter :-)
Many thanks for all the effort YOU all do! THANKS! :-)
nVidia Shield TV (2015), Samsung QE75Q70R and Yamaha RX-V767
Reply
F3d0r,
Can you please explain this step in a little more detail. I'm stuck here:

4 Connect the XBMC actions with the events from your MCE remote

Not sure how to do the connect.

I also have this remote like another user who is having trouble
http://www.newegg.com/Product/Product.as...6880121003

Best Regards



afail Wrote:Here is my Eventghost XML file for the MCE remote

http://pastebin.com/f1af9b728

I used all KB commands to map

OMG! I just used your xml and replaced mine and everything friggin works.

I think this goes back to my question about how to tie the actions of XBMC to the remote.
You somehow did it, so I know it can be done.
Can you please elaborate on how, for example, you made \XBCM Commands\Play\MceRemote.Play ? did you do it manually or was there a EG specific procedure?

Cheers
Reply
afail Wrote:Here is my Eventghost XML file for the MCE remote

http://pastebin.com/f1af9b728

I used all KB commands to map

I'm currently using this xml setup - anyone know how to make this work properly with a Harmony One remote? Right now, the arrows, OK button, back button, etc, all work. But not play/fastforward/etc.. Seems like when I hit those on the remote, it doesn't send the "F" command.

I am using an Imon IR receiver which works seemingly fine - but I think I've programmed the harmony remote incorrectly. It's set to a MCE "computer" - any way to just add a remote as a device to mimic?

Any help would be much appreciated.
Reply
Quote:4 Connect the XBMC actions with the events from your MCE remote

Not sure how to do the connect.

In EventGhost, there are 2 panes. The left is the event log and the right is the configuration/actions. To connect events to actions, you have to trigger them (cause them to show up in the log) by clicking the button on your remote control. It should then show up in the log at the bottom as long as it's a remote that EventGhost can communicate with. To connect the event just DRAG it over to the right configuration pane and drop it on the action that you want it to execute.

Quote:I'm currently using this xml setup - anyone know how to make this work properly with a Harmony One remote? Right now, the arrows, OK button, back button, etc, all work. But not play/fastforward/etc.. Seems like when I hit those on the remote, it doesn't send the "F" command.

I am using an Imon IR receiver which works seemingly fine - but I think I've programmed the harmony remote incorrectly. It's set to a MCE "computer" - any way to just add a remote as a device to mimic?

Any help would be much appreciated.

I'm also using a Harmony One remote. If you are having a problem with a button executing what you want, it's really simple to connect events to buttons. On the right configuration pane for XBMC you'll see all the actions available. Just click the button on the remote and drag it to the action you want. You can even do things where multiple button presses = an action. Meaning, you can actually assign more than one action to a button based on how many times you press it.
Reply
psypher Wrote:In EventGhost, there are 2 panes. The left is the event log and the right is the configuration/actions. To connect events to actions, you have to trigger them (cause them to show up in the log) by clicking the button on your remote control. It should then show up in the log at the bottom as long as it's a remote that EventGhost can communicate with. To connect the event just DRAG it over to the right configuration pane and drop it on the action that you want it to execute.



I'm also using a Harmony One remote. If you are having a problem with a button executing what you want, it's really simple to connect events to buttons. On the right configuration pane for XBMC you'll see all the actions available. Just click the button on the remote and drag it to the action you want. You can even do things where multiple button presses = an action. Meaning, you can actually assign more than one action to a button based on how many times you press it.

Yeah I got that - but the ones that don't work, don't show any events happening either. Which makes me think theres another way to setup my remote via Logitech's software. When I add a device, it only lets you add computers, not mimic a remote. Unless I'm missing something so completely simple...
Reply
psypher Wrote:In EventGhost, there are 2 panes. The left is the event log and the right is the configuration/actions. To connect events to actions, you have to trigger them (cause them to show up in the log) by clicking the button on your remote control. It should then show up in the log at the bottom as long as it's a remote that EventGhost can communicate with. To connect the event just DRAG it over to the right configuration pane and drop it on the action that you want it to execute.



I'm also using a Harmony One remote. If you are having a problem with a button executing what you want, it's really simple to connect events to buttons. On the right configuration pane for XBMC you'll see all the actions available. Just click the button on the remote and drag it to the action you want. You can even do things where multiple button presses = an action. Meaning, you can actually assign more than one action to a button based on how many times you press it.

Would you mind showing me all your XML config pages, as well as a screenshot of how your Logitech Software is configured?

I'm not an idiot, I swear. Smile
Reply
When HID is disabled (windows promts for a restart for the changes to take effect) But before restarting All my settings and events work perfectly. But when I restart my pc VMC or xbmc wont even respond to the remote.

So I when enable HID the remote works somwhat (xbmc only directional & enter buttons work). But xbmc does not respond to any of the settings or events saved in ghost event.




afail Wrote:Here is my Eventghost XML file for the MCE remote

http://pastebin.com/f1af9b728

I used all KB commands to map

Ths works great, but as ive staed above, the saved setting only work when hid is disabled. But once I restat my pc, the remote stops responding to anything.

Im using a Mediagate remote and Windows 7 64bit
Reply
kymira Wrote:Ths works great, but as ive staed above, the saved setting only work when hid is disabled. But once I restat my pc, the remote stops responding to anything.

Im using a Mediagate remote and Windows 7 64bit

Do you have eventghost auto-starting? I think you have to run eventghost as Administrator in order to pick any signals.
Reply
Quote:Which makes me think theres another way to setup my remote via Logitech's software. When I add a device, it only lets you add computers, not mimic a remote. Unless I'm missing something so completely simple...

Well, on my remote I have the device set up as an XBOX 360. I'll see if I can upload my config.
Reply
psypher Wrote:Well, on my remote I have the device set up as an XBOX 360. I'll see if I can upload my config.

So your remote thinks it's sending commands to an xbox 360, but you have EG translating them into keystrokes? If this works, I'd happily use that method. Just as long as it wouldn't turn on my xbox when I'm in PC mode Smile
Reply
  •   
  • 1
  • 6
  • 7
  • 8(current)
  • 9
  • 10
  • 11
  •   



Logout Mark Read Team Forum Stats Members Help
[WINDOWS] HOW-TO easily get MCE Remote working flawlessly in XBMC with EventGhost1
This forum uses Lukasz Tkacz MyBB addons.