IR / RF Remote Controls for Windows: Links to Explanations, Tutorials, and Guides

  Thread Rating:
  • 7 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Van G Offline
Posts: 60
Joined: Mar 2012
Reputation: 0
Post: #151
(2013-07-17 12:48)baijuxavior Wrote:  ^^ What exactly are the problems? Are buttons not working?

Not able to power on HTPC
Not able to scroll through Win 8 tiles or launch XBMC
Few buttons once XBMC open are broken but general use works.
find quote
wpbpete Offline
Senior Member
Posts: 179
Joined: Feb 2013
Reputation: 2
Post: #152
I thot I'd post this in here, hopefully it'll help somebody.
I have a Vizio VUR10 and a Vizio tv. While playing around with the device setup I changed the XBMC input device to DVR and Hewlett Packard, confirmed the connection, and now the VUR10 works XBMC using IR Smile
btw, the pc is hooked up with RGB not HDMI and I'm using a usb IR with XBMCCustomRegis installed
find quote
Astrapowerrr Offline
Junior Member
Posts: 7
Joined: Jul 2013
Reputation: 0
Post: #153
hi there

im having trouble with your installation program.

I use for many years mediaportal but I wanted to have a look at xbmc.
there I found out that my mce remote just wasn't working like I wanted/used to.
I installed mce remote plugin but that didn't change anything.
actually it messed up my mediaportal because a few days later i noticed that when I remotely sleep the computer is doesn't sleep.
the power button isn't working anymore. lots of reading and searching on the web got me to a solution.. there had to be a conflict with software.
uninstalled the remote plugin in xbmc and the problem was solved.

but still my remote wasn't working like I wanted to in xbmc!
started searching the web again and I found your program.
but that just gave me more problems I wanted... greenbutton worked finaly in xbmc! but it also started mediaportal. and counterwise....
so that wasn't the solution for me either...
I uninstalled your program and used the option set back old mce settings!
everything was removed but now again my powerbutton wont work anymore...

I think my register or keymapping is confused by some uninstalled items from your program?
can you help me with this?
because I just don't know what your program installed and readjusted??

edit: uninstalled the ehome receiver driver and rebooted while typing this and power button work fine again... sorry for that...
but now I am here... is there a solution to get the green button working in xbmc without starting mediaportal or kinda problems?

greets marco
(This post was last modified: 2013-08-15 10:49 by Astrapowerrr.)
find quote
baijuxavior Offline
Posting Freak
Posts: 1,836
Joined: Jan 2012
Reputation: 46
Location: India
Post: #154
(2013-08-15 10:36)Astrapowerrr Wrote:  edit: uninstalled the ehome receiver driver and rebooted while typing this and power button work fine again... sorry for that...
but now I am here... is there a solution to get the green button working in xbmc without starting mediaportal or kinda problems?

greets marco

1. Change the green button code to a combination of your choice. It is Win+Alt+Enter by default which will start WMC. Change it to say Ctrl+H. You can use the mce app link in my signature.

2. Edit the XBMC keyboard.xml file to include <h mod="ctrl">XBMC.ActivateWindow(Home)</h>

Now when you press ctrl+h within xbmc, it will show the home menu. If you want to start xbmc then set ctrl+h as shortcut key in the xbmc desktop icon.
find quote
ABuNeNe Offline
Junior Member
Posts: 9
Joined: Dec 2013
Reputation: 0
Post: #155
Hi guys, I've this Hauppage remote control and the IR sensor (mine is black in color) which comes together with my old PCI TV card that has been dead for quite sometime.

I've recently just installed XBMC on my IBM Thinkpad T43 notebook running on Win7, is it possible to make this remote control works using program like WinLIRC?

I tried connecting the IR sensor using a 2.5 to 3.5 mm audio jack adapter to the microphone port of my notebook. Under WinLIRC, selected the audiocapture.dll plugin (tried the hauppage plugin too) and used the configuration found here but was not able to use the remote control successfully.

Anyone have any idea what's went wrong? Please advise.
(This post was last modified: 2013-12-29 08:52 by ABuNeNe.)
find quote
Franckybleu Offline
Junior Member
Posts: 1
Joined: Nov 2015
Reputation: 0
Post: #156
hello, I apologize for my English
I have a Samsung TV UE55F6500 (2013)
Kodi 15.2
kodi works over Wi-Fi with my PC (Windows 8.1)
My remote ( Samsung tv) is not fully functional
play = ok
Pause = ok
Stop = ok
StepForward = ok
StepBack = ok

FastForward = nonfunctional Sad
Rewind = nonfunctional Sad

An idea for this to work?
(This post was last modified: 2015-11-16 21:13 by Franckybleu.)
find quote
elfnino Offline
Junior Member
Posts: 1
Joined: Feb 2016
Reputation: 0
Post: #157
I have a so called "OSMC remote" which is a RF / HID device (seen as a keyboard + mouse) most buttons do work or are recognized as regular keyboard buttons but I have two buttons which are not recognized at all by Kodi (not seen in kodi debug log) as they do not represent a standard keyboard codes.

Only thing I could found is the code recognized by SimpleHIDWrite.exe

I tried EventGhost with HID plugin but it is not recognizing that key presses.

Is it posiible to MAP in KODI that missing codes from the SimpleHIDWrite.exe to some regular key presses ?
(This post was last modified: 2016-02-21 13:03 by elfnino.)
find quote
Derek Offline
Posting Freak
Posts: 1,710
Joined: Aug 2009
Reputation: 23
Location: Bonnie Scotland
Post: #158
Eventghost has worked for me for years with a cheap MS remote, ive had expensive remotes, android remotes, iphone remotes but nothing beats the Eventghost MS Remote Smile
find quote
Post Reply