Getting XBMC working on Apple TV (using only windows)
I wish I knew why it wasn't working - looks exactly like mine did.

Have you tried using a laptop (or long network cable) and getting all items in the same hub?

Also I'm assuming that the machine you're connecting from is in he same IP range (not all are if you;re using home wireless/bridging etc)
I'll give you a big hint, messages that say "failed", "no such file or directory" mean that this patchstick has a serious problem and will never work without some effort in understand it's operation and fixing it.

Since it can't find "stuff/installer.d/*" nothing has been installed and that's why ssh does not work Wink

Windows version of atvusb-creator is maybe a week out depending how much time I can spend working on it.
MediaInfo :
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
KevinSartori Wrote:When I launch PuTTY, I type in the IP address of the AppleTV, in this case Connection type is set to SSH by default. I hit the Open button and a PuTTY Fatal Error window pops up that says Network error: Connection refused. Which, actually, is the same exact error I get if I do a factory restore back to 2.0 and try to connect without using the patchstick.

My understanding of this is pretty limited, but it sure seems like the patchstick isn't installing whatever's required to make an SSH connection.
It could be that the patchstick in question messes up Kerberos. Without Kerberos you will need to use SSH v1.
  1. Start putty
  2. Enter IP address of ATV
  3. In the left hand side select Connection - SSH
  4. Under "preferred SSH protocol versions" select 1 or 1 only
Give it a try

Since I don't have a Mac, I did a similar thing to get my ATV accessible. The first time I did the DD on a 1GB usbstick and it was too small to fit the ~1GB file. I noticed the in / out bytes summary at the end of the using DD didn't match up. I tried the stick anyway and it booted and looked just like that screenshot however it didn't work.

I did the dd on the image again this time to a 2GB usbdrive and presto, ssh was working. So, lesson learned was make sure you usbstick is big enough.
Nuts. Tyche, it looks like you're correct and that my problems stem from the USB stick I bought being slightly too small. I decided to recreate the patchstick and here's what I got at the end. I noticed this the first time, but promptly forgot about it because the patchstick appeared to boot okay:

rawwrite dd for windows version 0.5.
Written by John Newbigin <[email protected]>
This program is covered by the GPL. See copying.txt for details
999,292,928Error writing file: 27 The drive cannot find the sector requested
954+0 records in
953+0 records out

If I realized all the trouble that darn USB stick would cause me, I would have spent a few bucks more and bought 2GB instead! I'll have to head over to Best Buy tomorrow.

Oh, Mikkeland, I did try your advice with PuTTY but unfortunately I still got the dreaded Network error: Connection refused. Thanks anyway! A bigger stick should do the job.

That's what she said!

Sorry, I couldn't resist...

I'll report my results here tomorrow. Thanks again for all the help, guys!
Quick update for anyone interested. Lumpsack's directions work perfectly! I got a larger USB stick and everything works fine! There's one thing I'd like to mention here that I found in another thread that's very important:

davilla Wrote:The root partition on the AppleTV is read only by default, "sudo mount -uw /" will make it read/write. "touch /.readwrite" will make it permanent.

I couldn't for the life of me figure out why I couldn't add an additional skin (Horizonz, FTW!). WinSCP just wouldn't let me create a folder or file! To correct this, open up PuTTY and type:

sudo mount -uw /

hit enter, then type:

touch /.readwrite

and hit enter again. This will allow you to transfer files over to the AppleTV.

Thanks again for the help, Lumpsack! You da man!
Wonderful, I'm glad you got it going and thanks for the tip on root - I'll just fire mine up and do that too Smile

Wonderful skin by the way - downloading that now Smile

Thanks, Lumpsack. I am also able to use your method to get XBMC up and running on Apple TV.

Just to point out that the issue I encountered was not being able to SCP files into Apple TV. WinSCP pops out an error code 126. My solution is to SSH into the box and modify the permission for 'scp' in /usr/bin.

# sudo chmod 755 /usr/bin/scp
You're welcome, I'm glad the guide helped - I wish it had been here when I started Wink
Another thank you for this guide. Got everything up and running this weekend without a hitch.
My pleasure Smile
I can't even get past the mountvol command. I get an "Access Denied" response. I have tried reformatting the USB drive, I shared it with "Everyone", I have administrator rights in this Vista user account. Sad
jhauer Wrote:I can't even get past the mountvol command. I get an "Access Denied" response. I have tried reformatting the USB drive, I shared it with "Everyone", I have administrator rights in this Vista user account. Sad

I had this exact same issue, it seems to be related to attempting to install on partition0 of the device. I have had success installing instead to partition1 (and looking at the device after install, all partitions appear to have been created correctly by dd). I've not been able to get any install to work using the removable filter though, it always stops and says the usb device doesn't match the filter, so I've just been using dd.exe.

I haven't had success actually getting it installed on the atv though, both of my flash drives boot and load the kernel, but then sit at "waiting for boot device" or some such error, rather than continuing the install. I'm assuming this is because they're incompatible and I need to get my hands on a known working flash drive, can anybody confirm?
Theres a thread on here somewhere going over compatible USB devices - I had the same issue with mu first one, but a Transcend JetFlash V30 2GB did the job for me.
Well I ran out and picked up a Sandisk 2gb Cruzer since it was listed as a working drive, and I'm still running into the same problem. After boot where it says "Caused Wake Up Event" it just repeats "Waiting for Root Device" and won't go any farther. I am unable to follow the instructions exactly since I can't use dd-removable (it always says that the device does not match the filter removable), so I'm using dd which allows it to format. However, I also can't run it on partition0 since it always says access is denied, I have to run it on partition1.

I'm not sure what else to try at this point!
Thread Rating:
  • 2 Vote(s) - 5 Average

Logout Mark Read Team Forum Stats Members Help
Getting XBMC working on Apple TV (using only windows)52