Videos all play at 60fps, except when they don't
#1
This has just started happening with beta 2.

Basically everything seems to be playing at 60fps, SD and 720p, the GUI seems faster too somehow.

I've tried setting vsync to all of the available settings in XBMC and I've tried with and without vsync and page flipping enabled in nvidia settings (combined with the various xbmc vsync options).

The weird thing is sometimes it'll work, then I'll quit XBMC, start it again the same way I did before and it'll be back to playing everything at 60fps. The vsync setting in XBMC hasn't reset or anything.

I use the following to set the GL sync to my projector instead of the screen on my HTPC

export set __GL_SYNC_DISPLAY_DEVICE=DFP-0
export set __GL_SYNC_TO_VBLANK=1

I've also tried with and without having these env variables set in the console before launching XBMC, again no difference.

Any ideas?
Reply
#2
Heh.. OK I found the issue, XBMC couldn't connect to my iec958 for passthrough and as a result freaked out.

(If anyone else is having the same issue, I worked around it by just having a little launcher script to shutdown pulseaudio before launching XBMC, and restart it once XBMC is finished:


Quote:#!/bin/bash
pulseaudio -k
sleep 2
xbmc
pulseaudio -D
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Videos all play at 60fps, except when they don't00
This forum uses Lukasz Tkacz MyBB addons.