Can xbmc-eventclients-wiiremote be updated to use libbluetooth3 on Ubuntu Intrepid?
#1
Trying to get the Wii Remote to work with XBMC using Ubuntu Intrepid (8.10).

Looks like all of the xbmc-common parts have been updated to use the libbluetooth3 package, but the xbmc-eventclients-wiiremote still has a dependency on libbluetooth2 (which I'll have to get from somewhere else for it to work).
Reply
#2
I think you should be able to install this http://packages.ubuntu.com/sv/hardy/libbluetooth2

and try again.
Although wiiremote should work with the new libbluetooth3 but the dependencies havent been bumped, so you could svn down the source and compile it yourself.

Cheers, Tobias
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
#3
I installed the Hardy libbluetooth2 package last night and that worked fine.

Mainly posted to see if the package dependency can be resolved so it's a bit easier for anyone else that runs into that problem.

Thanks for the reply back.

Cheers,
David
Reply
#4
Makefile must be modifier to compile right :


Code:
CXX ?= g++
CFLAGS = -Wall -pipe -fPIC -funroll-loops
OBJ_DIR = release-$(shell $(CC) -v 2>&1|grep ^Target:|cut -d' ' -f2)
OBJS = wiiuse_v0.12/src/$(OBJ_DIR)/libwiiuse.so
BIN = WiiUse_WiiRemote
VERSION = v0.12

all:
        @$(MAKE) -C wiiuse_$(VERSION)/src $@
        $(CXX) $(CFLAGS) -I./wiiuse_$(VERSION)/src WiiUse_WiiRemote.cpp $(OBJS) -o $(BIN) -l bluetooth
wiiuse:
        @$(MAKE) -C wiiuse_$(VERSION)/src
clean:
        rm $(OBJS) $(BIN)

i have just add the -l bluetooth

Cheers
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Can xbmc-eventclients-wiiremote be updated to use libbluetooth3 on Ubuntu Intrepid?00
This forum uses Lukasz Tkacz MyBB addons.