First off I'd like to say THANKS FRAIN for this awesome EventClient, IMO XBMC without an Xbox-like controller just isn't the same. I don't mind at all starting it up before XBMC Windows, and it works wonderfully. Also THANKS TEAM XBMC for making the awesomesauce media center for free.
I'm using Vista64 and the Microsoft USB Xbox360 wireless dongle with XBMC Atlanis. I'm using Visual Studio 2008 Pro and not Express, so I don't currently have the ability to make my own builds, but I can at very least compile this EventClient.
I have no complaints! One very minor difference from XBMC on the Xbox seems to be with the speed of the acceleration/repeat of the shoulder triggers, which is significantly slower than XBMC Xbox. I have noticed that there are timing knobs in the EventClient config menu, so perhaps I will try tuning that and post the values which feel "Xbox-like".
The other more significant difference is that the original patch does not map anything to the "white" and "black" buttons on the Xbox controller, so there is no way to enqueue playlist items or see the playlist. Fortunately the Xbox 360 Wireless controller has two remaining unmapped buttons, the left and right shoulder buttons.
Here's a small patch which makes the left and right shoulder buttons behave like "white" and "black", respectively. I have tested it, and it works as expected.
I'm not sure what arguments I should give diff to create a .patch, so here's the diff.
< checkButton(cont, client, 12, "lefttrigger");
< checkButton(cont, client, 13, "righttrigger");
> // these buttons are not yet mapped in XBMC/xbmc/ButtonTranslator.cpp
> // and therefore are used as "white" and "black" respectively, as white
> // is left of black on the original xbox controller.
> // checkButton(cont, client, 12, "leftshoulderbutton");
> // checkButton(cont, client, 13, "rightshoulderbutton");
> checkButton(cont, client, 12, "white");
> checkButton(cont, client, 13, "black");
I'm don't know why things are defined the way they are in ButtonTranslator.cpp, so I'm not sure whether it's more "correct" to do the above commented "leftshoulderbutton" "rightshoulderbutton" names, and define them in ButtonTranslator.cpp to be equivalent in the UI to "white" and "black?"