• 1
  • 17
  • 18
  • 19
  • 20(current)
  • 21
XBMC HTTP-R, Remote Control Web App for PDA, PPC, or Smartphone (developers wanted)
I have a large library of movies and TV shows. HTTP-R is not very quick, even though I have indexed the system. Also, for the TV shows, only around 5% 0f the banners are displayed, so this is not usable as it is not possible to see the actual Series.

However, the controls work well.
Please delete this message.
Ok, I have installed and uninstalled a couple of times and I can't get it to work. To be honest I really don't know what I am trying to do either.

So, is there a kind soul out there who can write an "idiotguide" and point with the whole hand on what to do? There are probably a lot more people out there with the same problem.

Perhaps something in the line with:
1: Install this program here on the PC.
2: this one here on the handheld.
3: Change this for that.
4: type this there.

and so on?

I have a Asus AT3ion running windows7 x86 and a HP Ipaq RX3700 PDA
Ok, i uninstalled and tried again and this is what I have done.

1: Installed Apache webserver
and set (IPv4 gotten from IPconfig)

2: Installed gd-2.0.33-1

3: Installed xampplite-win32-1.7.3

4: Created the folder "PDAremote" in HTDOCS and unzipped
XBMC_HTTP-R_v0.5a2 into it.

5: Ran XBMC with "allow control via HTTP" enabled, port set to 80 and Username XBMC. Internet access enabled on port 8080 (nothing else checked or filled in)In config.php I have set name to "PDAremote" and IP to the above mentioned one. MAC is changed to the one I got from running "getmac" in the cmd-window.

If I open in IE on the PC running XBMC I get the notification "it works!".
If I do the same on my PDA running opera the connection gets timed out.

If I open or I get the "HTTP 404 not found" (on PC running XBMC)

So, where do I go from now?

Uninstalled xampplite and used the zip-file instead of the installer. Changed both ports in XBMC to 8080 and it seems to be working on my xbmc-pc.

Still no-go on PDA.
It now works with movies. When it comes to TV shows I get the banners for each show but nothing happends when I clock on them. I can not access "setting" or "remote" either. gives me the XAMP Lite:
You have successfully installed XAMPP on this system!" gives me
"select your media center" but none of them can be selected.

"Error 403
10/28/10 20:34:22
Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1"
Gets me to the remote.

If I change user no shows or albums show up.
In indexing.php:

Progress: 4 Notice: Undefined offset: 0 in /www/xbmc/includes/classes/modules/xbmc/video/movie.php on line 42

Progress: 3

Progress: 5

A php error (PHP Version 5.2.12)

How to set the mysql database created? Where in the script is the host, database,user and password?
I'm trying to setup http-r on a gentoo linux server with apache + php.
I wonder if any of you could help me with the following issue: when I open the webpage (i.e. http://myserver/xbmc) I get a page with some PHP notices/warnings about undefined indexes and nothing more.

I've found a post of a user claiming that was a problem with XAMPP installation but I'm on Linux Smile

I followed the instructions in the readme.txt, so I have apache with PHP 5 module loaded (php test page works properly) compiled with GD library support. I've also configured the xbmc server address and port.

I'm sorry to post for assistance but I have no clues about how to debug the problem at this point.

Thank you in advance!
I just tried to install it tonight and had the same problems. Mine was because for some reason PHP was trying to include config.php from the PEAR directory rather than from the XBMC remote folder.

This worked for me (well, it did something and got rid of the errors): either edit php.ini (find / -name "*php.ini*" should find it on linux) and check your include path is:


or if your configuration allows it put this on the second line of index.php:


good luck!
when i open localhost it gives me "xampp welcome screen"
and when i open localhost/xbmc than it gives this following error

Deprecated: Assigning the return value of new by reference is deprecated in D:\xampp\php\PEAR\Config.php on line 80

Deprecated: Assigning the return value of new by reference is deprecated in D:\xampp\php\PEAR\Config.php on line 166

Deprecated: Assigning the return value of new by reference is deprecated in D:\xampp\php\PEAR\Config\Container.php on line 111

Notice: Undefined index: version in D:\xampp\htdocs\xbmc\index.php on line 44

Notice: Undefined index: info in D:\xampp\htdocs\xbmc\index.php on line 46

Warning: include(interface/ppc//index.php) [function.include]: failed to open stream: No such file or directory in D:\xampp\htdocs\xbmc\index.php on line 55

Warning: include() [function.include]: Failed opening 'interface/ppc//index.php' for inclusion (include_path='.;D:\xampp\php\PEAR') in D:\xampp\htdocs\xbmc\index.php on line 55

procedure i followed for installation:
i just fully installed xampp with all services including apache, php filezilla etc and checked that gd lib was enabled in php.in and than extracted all the files of "XBMC_HTTP-R_v0.4.zip" to a folder named "xbmc"
and than copied that "xbmc" folder to all htdocs folder and htdocs/xampp folders found on my computer

and when i open localhost/xbmc/indexing.php it shows all that php scriptings....
help me out plzz and consider me as a total noob and explain me in detail.....

thanks in advance
PS: apache,php and gdlib all enabled and all ports are also open
Ok, I got this to work on my Asrock ION box and my blackberry curve 8520. Sweet!

Despite this success, a few things don't work as hoped:

1) Touch doesn't work at all, just a nice black screen with the little back/home icons on the bottom. I am not a great programmer, but where would one start looking for a solution? The log file tells me little more than that a Python interpreter has been started and {'Limit':'4'}, whatever that may mean.

2) Is it possible to just put an entire album into the playlist? Right now, I can only listen to one song, or manually add the others to the playlist (which sucks, especially on a phone).

3) Sometimes the interface seems to hang... nothing specific, no errors, just takes a minute or so to really go anywhere. I can live with it, but maybe there is something wrong?



EDIT: It seems touch is working on both opera and blackberry now. The reason (on a post hoc basis) seems to be a change in skin, from Confluence to PC3.HD (from memory, can't check now). The only problem is that the connection to the blackberry seems to be too slow to effectively do anything (it respond with a lag, and by the time I click somewhere, the screen has moved on). I will try to improve my connection before anything else though.

I've been trying for 2 days now, but nothing seems to help.
I've installed xampp: apache, mysql, filezilla and mercury are running as service.
XBMC is up and running (webservice activated on port 987) user: xbmc paswoord is blank.

I've changed the config.php file to the correct ip adres and port.

When I go to localhost:987 (<- configured port in xbmc) I've got a webpage but with the message: 'connection to host lost'.
When I try sometimes he says 'location is offline' but at the moment of speaking he's working but is giving al the time errors like these:

"Strict Standards: Non-static method image::build_image() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\xbmc\includes\classes\modules\image.php on line 42
Deprecated: Function split() is deprecated in C:\xampp\htdocs\xbmc\includes\classes\module.php on line 17

But my biggest problem: When I try I just get a navigation menu and that's it, you can see the result over here: http://www.webvibes.be/xbmc.JPG

Can anyone help? It seems like the xbmc webservice sometimes doesn't work.
ok now i think ive made progress but i get a blank screen @ "localhost/xbmc"
anyone know how to fix this?

nevermind got it working had to enable "short open tag"
for ipad how do you scroll throught "movies" it only shows first 20 or so movies and i cant scroll down. also the volume bar is not set up properly i think its touch sensing is still set to the old width if you touch the low side it turns the volume up and down but the high side wont do anything
ok i found out that to scroll up and down you have to use 2 fingers on ipad/iphone. for 1 finger scroll on ipad we need to add a scroll bar to the app does anyone know how/if this can be added?

and anyone using this from ipad try downloading the "atomic" web browser from the app store.
with this you can make it run in full screen, disable the address bars, disable full screen buttons, lock the rotation, and adjust the font size. with this it looks and feels like http-r is its own app for ipad instead of a web version.
and if we can fix the scrolling issues we would be set with the best xbmc remote app out there
  • 1
  • 17
  • 18
  • 19
  • 20(current)
  • 21

Logout Mark Read Team Forum Stats Members Help
XBMC HTTP-R, Remote Control Web App for PDA, PPC, or Smartphone (developers wanted)0
This forum uses Lukasz Tkacz MyBB addons.