•   
  • 1
  • 17
  • 18
  • 19(current)
  • 20
  • 21
  •   
XBMC HTTP-R, Remote Control Web App for PDA, PPC, or Smartphone (developers wanted)
OK v0.5a2 of HTTP-R works and has the added feature of stretching to fill the browser window, and indexing throws NO errors and appears to scan all my TV shows fine but doesn't cache all thumbs, so in the interface only a couple of banners show. but even on episode view some thumbs show that arnt cached and it takes a while to load any section of the app which leads me to believe its not even using the cache and just scraping off the internet on the fly.

reading some posts around 216+, theres mention of this and it was to be fixed shortly after but i cant find anymore releases. this was back in december (6 months ago). Could this app be dead? I hope not. iv only just got it working after all this time.

A little pointer to the developer on this one, but could the cache not just copy the xbmc databases and thumbs from the media centres cache and work from them. at least you'd know that all your thumbs and info could be found and correct. (if you correctly maintain your meda, Tagging/Creating covers etc, you dont want it all to go to wast with miss scanned info which there is no way of adjusting.)

Anyway, thats anough of a rant. This App has great potential and i'll keep trouble shooting and contributing until im 100% working.

Laterz
RBX
Reply
Portrait view:
BodyElementWidth: 345
BodyElementHidth: 409

BodyWidth: 345
BodyHeight: 409

Element ClientWidth: 345
Element ClientHeight: 409

Element OffsetWidth: 345
Element OffsetHeight: 409

Element2 ClientWidth: 345
Element2 ClientHeight: 0

OnResize function: Waiting for rotation... (or not working)

Landscape view:
BodyElementWidth: 465
BodyElementHidth: 343

BodyWidth: 465
BodyHeight: 343

Element ClientWidth: 465
Element ClientHeight: 343

Element OffsetWidth: 465
Element OffsetHeight: 343

Element2 ClientWidth: 465
Element2 ClientHeight: 0

OnResize function: Waiting for rotation... (or not working)

Strange cause I would think that the values would just be reversed or switched. I am using a BlackBerry Storm 9550
Reply
Hey everybody,

I got http-r set up, running smoothly, and I'm able to connect via my wife's samsung saga. Awesome. However, when I try to access with my samsung sch-i760 i have no luck. Both are winmo pro 6.1 . Thank you for any suggestions.
Reply
Is this app only for Windows? as I use Element OS a flavour of Ubuntu and everywhere I have looked it says XAMPP Lite is Windows only. Tried the read me and followed the Linux entries and nothing worked until at all until I install full version of XAMPP. Got the same errors as the other users with full version.
Reply
A quick thought a lot of people are setting up XBMC using Ubuntu either from LiveCD or Element OS. Maybe a step by step instruction sheet for noobs like me from someone who has got this working would be useful or even an offshoot thread.
Reply
XiniX88 Wrote:Tnx, btw, next release will have a new wvga skin (tnx to tamago_quin). Hope to finish it this week (which will also fix the images).

By the way, can everyone test (with your phone):

http://m.denhaas.info/test.html

And give the following information:
- Resolution (of your phone)
- Device (HTC Touch, etc)
- Browser (Opera mobile, etc)

And the results of all the tests, please also check (if you can rotate your phone/browser) if the onresize function works (it will say: "working!" if it's working, else it is waiting for rotation).

Resolution - 480 X 800 WVGA
Device - HTC HD2
Browser - Opera Mobile for touch version 9.7 build 35627

Width / Height test
BodyElementWidth: 274
Body elementHidth ; 457

bodywidth: 274
bodyheight: 457

Element clientwidth: 274
Elementclientheight: 457

Element2 client width: 274
elemenr 2 client height: 0

doesn't detect that the phone has been rotated and the orientation of opera changed
Reply
this is such a great app!!! I've been using it on my iPad with v0.5a2 and the screen stretch works fine, except for the touch page, where the screen is still small and 90 degrees rotated. Below are the data

Width / Height test
BodyElementWidth: 1024
BodyElementHidth: 690

BodyWidth: 1024
BodyHeight: 690

Element ClientWidth: 1024
Element ClientHeight: 690

Element OffsetWidth: 1024
Element OffsetHeight: 690

Element2 ClientWidth: 1024
Element2 ClientHeight: 0

OnResize function: Working!
Reply
hi,
so this is my first post.
i've read the full thread but i still have problems.sorry for that
what i did:
installed xbmc (no username and password)

installed xampp lite (1.7.3)

installed xbmc http r v 0.5 2 in the ...htdocs/xbmc

changed config: to xbmc and my ip (and port 8080; both xampp and xbmc are running
on 8080; no change in mac!)
test.php is working

localhost is working

standard interface is working (myip:8080)

safe_mode is off; short_tag is on

if i got to:
http://192.168.xxx.xxx/xbmc/indexing.php: => progress 0 overall, can't index zolder, can't index kamer

http://192.169.xxx.xxx/xbmc/index.php?__id=4: =>blank screen

http://192.168.xxx.xxx/xbmc/interface/: => index with 3 chooses (mobile, pc, ppc; just errors when i open the subfolders)

thanks for helping

cheers
Reply
Hello, I just wrestled with this remote trying to get it work, and I finally did, so I thought I would post here to help out others.

The problem was that the XBMC-R page was blank. The indexing.php page worked fine, and so did my default XBMC webserver page. I am hosting both websites on the machine. I have the XBMC page set to port 80 and the XBMC-R page set to port 81.

I checked the Apache error logs and I was getting an error that said:
[Wed Sep 15 12:22:26 2010] [error] [client ::1] (20024)The given path is misformatted or contained invalid characters: Cannot map GET /%3C?=$template->path?>style.css HTTP/1.1 to file, referer: http://localhost:81/
[Wed Sep 15 12:22:26 2010] [error] [client ::1] (20024)The given path is misformatted or contained invalid characters: Cannot map GET /%3C?=$template->path?>script.js HTTP/1.1 to file, referer: http://localhost:81/

I was pretty sure this is because I was using a URL that had a ":" in it since I had to specify the port. Anyways I did a bunch of googling and finally came up with a solution that works.

If you have this problem (blank index.php page and these errors in your log), then go to the XAMPP folder and go to /php/php.ini.

Now in the php.ini file, find change short_open_tag to be On

Restart Apache and enjoy! I'm using the latest version of xampp lite and Dharma Beta 2.
Reply
I have been trying to get this to work for a few hours now with now luck.
I am using OS X Snow Leopard
I have installed everything that should be installed and have extracted the contents to ~User/Sites/xbmc. I have activated apache and php. I have tested this with a test.php file and can confirm that php is working. I have correctly configured the config.php file. However, when I try to access index.php (or any other php file like indexer.php) it only shows up as text. I have tried the numerous commands throughout this thread including the one in the readme but terminal always says "command not found".

please help!

Thanks
Reply
minor progress over night. It not longer displays the text of the php doc but I get a ton of errors when I try indexing.php. It goes on for much longer than i pasted...

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/module.php on line 17

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/modules/database/xbmc.php on line 20

Deprecated: Function split() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/xbmc/includes/classes/modules/database/xbmc.php on line 20
Reply
Hi,

I am running the beta 2 of Dharma, and would like to set up HTTP-R but the homepage only has versions up to V0.4. From reading this thread, I understand that V0.5 alpha is needed?

If so, where can I download this,

Thanks
Reply
^^what he said
Reply
seems to be here: http://xbmc.denhaas.info/XBMC_HTTP-R_v0.5a2.zip
Reply
Thanks,

It all works fine, except that the screenshot (accessed by the Touch button) is rotated 90 degrees on my HD2. It stays rotated when the screen is rotated.

I am currently running the indexing script, so cannot fully test the library function yet, but will do.
Reply
  •   
  • 1
  • 17
  • 18
  • 19(current)
  • 20
  • 21
  •   



Logout Mark Read Team Forum Stats Members Help
XBMC HTTP-R, Remote Control Web App for PDA, PPC, or Smartphone (developers wanted)0
This forum uses Lukasz Tkacz MyBB addons.