Intel dg45fc with e8400 dropping frames on 1080p video playback
#1
Hi,

Just purchased intel dg45fc MB (g45 chipset with x4500hd graphics) with intel c2d e8400, 250GB 2.5" WD hdd.

I've installed Intrepid and xbmc without problem, however on testing the killa sample it jitters on playback and i get about 50-60 dropped frames with a Frame rate of about 19fps.

I've disabled speedstep in bios as ubuntu & xbmc was registering my CPU at 2GHz, it is now recognised at 3GHz. This did not solve the problem.

My Xorg.conf is as per default install.

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


Are there any tweaks i should be doing to my xorg.conf to get this work smoothly. I believe e8400 cpu is definately capable of playing the killasample.

Cheers for your help in advance
Reply
#2
Try adding

Code:
Option    "TripleBuffer"    "true"

to your device section in xorg.conf
Reply
#3
thanks for your quick reply,

It still seems to be dropping frames unfortunately.

video information says cpu0 100%, cpu1 10% - is that expected?

i'll keep playing for now, if there any more suggestions please let me know.
Reply
#4
same problem as this?

http://forum.xbmc.org/showthread.php?tid=42668
Reply
#5
think i'm blind or dumb today.

Yep seems very simular to that problem. I've tried your other "useevent" suggestion from that thread and it hasn't sorted the issue unfortunately.

I may try compiling the intel driver from source and see if that sorts it.

cheers for your help
Reply
#6
ticket raised for intel g45 on intrepid

http://trac.xbmc.org/ticket/5556

found a simular issue using nvidia drivers

http://trac.xbmc.org/ticket/5423
Reply
#7
Try setting XBMC to use 1080i as a resolution, It won't actually make it output 1080i (oddly but what they hey) but it fixed a similar issue for me on windows.
Reply
#8
@adix
What Video and Audio connections have you got running with your DG45FC board? I'm curious as I've not seem many positive comments about the DG45FC + Linux + G45 IGP.
Reply
#9
There are a few issues with dg45fc and linux - but in general it works quite well depends how picky you want to be.

Sound drivers - either get analog or optical (depending on driver), don't get both - haven't managed to get hdmi audio working yet (this involves upgrading xorg and intel driver but then causes some problems with xbmc).

issues with xbmc because i have to use intrepid because of G45 - there is a problem with uneven core utilisation if you want to run 1080p content. Results in dropping frames with high bit rate vidoes (not dg45fc fault). however 720p works great though.

HDMI video works great, optical sound works (or analog jacks depends on driver) not managed to get hdmi audio working yet (still playing - but apperently is possible). DVI vdeo works fine. Haven't come across problems with other hardware yet.

Vista/XP work brilliantly OoRolleyes hdmi video/audio, optical and the other windows things you get - but i want it working on linux

here are some relavent threads you may want to follow:

http://forum.xbmc.org/showthread.php?tid=43075
http://ubuntuforums.org/showthread.php?t=1025845
https://bugtrack.alsa-project.org/alsa-b...hp?id=4324 (need login)

hope this helps
Reply
#10
Also noteworthy is that adding a heatsink on the southbridge is a good idea, I got rid of alot of weird crashes that way.
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
#11
Topfs2 - i believe hdmi sound issues maybe related to the 1.0.18a alsa driver rather than xorg or newest intel graphics drivers.

As you know through my messages - i do not get analog audio when i upgrade to 1.018a.
aplay -l lists the devices - i.e. analog hw:0,0, digital hw:0,1, hdmi hw:0,3.

however aplay -D hw:0,x file.wav always results in sound being sent via the optical jack. i think there is something wrong with the 18a codec mappings and this card. I'm looking further into it.

I tried an upgrade to latest intel 2.5.1 drivers also upgraded xorg i don't not get hdmi audio - but aplay -D hw:0,3 file.wav gives audio from optical. you may be experiencing the same problem without realising as you don't use your optical port. i'll stick this on my ubuntu thread see what people think.

others suggestions welcome
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Intel dg45fc with e8400 dropping frames on 1080p video playback00