•   
  • 1
  • 30
  • 31
  • 32(current)
  • 33
  • 34
  • 57
  •   
[RELEASE] MythBox for XBMC - a MythTV Front-end Python Script for XBMC
MikeFellows Wrote:hmmm..

I knew live TV didnt work with 0.24 but I thought recordings where working.

might try updating my 10.0 to latest svn

Thanks

edit: looks like im waiting, there are no nightly builds at the moment.

Mike,
Doesn't Mythbuntu 10.10 use Myth 0.23.1?
Reply
TugboatBill Wrote:Mike,
Doesn't Mythbuntu 10.10 use Myth 0.23.1?


yes your right it does. now that is weird as i shouldnt be having any problems

I progressed a little further this afternoon though

it now appears to try and connect to 127.0.0.1 and for a while this did appear in the myth backend greyed out part (it has mythtv/127.0.0.1)

the hostname for mythtv is mythtv but the ip address should be 192.168.0.126 which is what i added to the hosts file.

Im pretty sure my mythtv setup is working correctly as I can view and play recordings via web interface and I can also connect mythplayer on any windows box and it works.

however I do have one thought..

in my mythtvbacked all the ip addresses are set to 127.0.0.1, i tried changing these to 192.168.0.26 but everything failed then

im new to mythtv so dont know how much the above matters.
Reply
In my backend I have both my local and master backends set to the same IP. I did have the master set to 127.0.0.1 but had massive response issues (lockups, slow). I used the default ports. Security pin was also left to the default of 0000.

I didn't have channels set up properly and again had speed problems. I learned the hard way to first make sure everything is working flawlessly from a local (to the server) mythfrontend.

I still have a glacially slow guide in Mythbox but that may be due some lingering channel issues I'm clearing up now.
Reply
TugboatBill Wrote:In my backend I have both my local and master backends set to the same IP. I did have the master set to 127.0.0.1 but had massive response issues (lockups, slow). I used the default ports. Security pin was also left to the default of 0000.

I didn't have channels set up properly and again had speed problems. I learned the hard way to first make sure everything is working flawlessly from a local (to the server) mythfrontend.

I still have a glacially slow guide in Mythbox but that may be due some lingering channel issues I'm clearing up now.


front end on the machine works a charm. mythplayer on a windows box also works a charm.

might try changing the ip address again from 127.0.0.1
Reply
Dobyken Wrote:I don't think the SVN's, otherwise known as "Nightly Builds" are in place yet but from what I've read Mythbox is ready for .24 but the XBMC core has not been updated for the Myth .24 protocol. You may, however, be able to download the source from git and compile it yourself.

Cheers for that. I've seen a few sites that do unofficial compiles for ubuntu, so I might try one of those.

I don't think 10.1 is too far away from what I read on XBMCFreak. The recordings in Mythbox is working really well to my 0.24 backend, and I can see the schedules for LiveTV - just obviously cant stream yet.

Anyone using this with 0.23 care to indicate if channel changing is good enough to stop using mythfrontend ?
Reply
Hey guys, I haven't really been reading this but wanted to repost some info that may be of help to people currently having issues w myth:// . It seems that an issue with version number in the myth packages have caused myth:// to no longer play video and to show:

(cmyth)cmyth_conn_connect: asked for version X, got version XXXXX.

Here is a relevent post by PVR dev dteirney from the mythtv PVR dev thread.

Quote:As has already been covered in this thread. Myth 0.23 with fixes doesn't currently work with myth:// The tell tale part in the log is:

(cmyth)cmyth_conn_connect: asked for version 8, got version 23056.

I've created a patch for that which I will push up to github tomorrow. If you could test that would be useful. If that works I'll see if I can get that change into the 10.1 release.


I hope this helps some people having issues.
Reply
Funny, I can get Myth 023 with fixes to work on a local machine, but not a remote one. I don't get cmyth errors. I've just (about 3 hours ago) entered a bug in mythbox tracker with the logs. See: http://code.google.com/p/mythbox/issues/detail?id=154

I wonder if this fix will fix it...
Reply
davecurtains Wrote:Anyone using this with 0.23 care to indicate if channel changing is good enough to stop using mythfrontend ?

It takes about 8 seconds to load a channel in Mythbox vs about 3-4 seconds in Myth Frontend vs 1 second on the TV. To mentally prepare myself for Mythbox I stop the playing channel to get back to the guide then select the channel. I've had some problems changing channels directly in Mythbox where sometimes it locks up if I just type in a channel number. To be honest since I installed Sick Beard I don't use Mythbox much more than keeping the news on while I work.
Mythbuntu doesn't need viruses - we have Sudo
Reply
Now that XMBC is released for Apple TV2, will MythBox also run on it? If so, maybe I'll just go that route than trying to figure out why my video files stop playing after 8 seconds...

Rob
Reply
arad85 Wrote:Funny, I can get Myth 023 with fixes to work on a local machine, but not a remote one. I don't get cmyth errors. I've just (about 3 hours ago) entered a bug in mythbox tracker with the logs. See: http://code.google.com/p/mythbox/issues/detail?id=154

I wonder if this fix will fix it...
No it doesn't, but setting the IP of the backend box on the frontend box (in /etc/hosts) did.

Just recording in case anyone else comes across this problem.
Reply
I've been working on getting Mythbox running on a black Apple TV. So far the problem that I've run into is that I have to mount the tv directory on the mythtv backend using smb, and I haven't found a way to do this.

Does anyone know how I can locate and load an smbclient on the ATV2?

Thanks.
Reply
Dobyken Wrote:It takes about 8 seconds to load a channel in Mythbox vs about 3-4 seconds in Myth Frontend vs 1 second on the TV. To mentally prepare myself for Mythbox I stop the playing channel to get back to the guide then select the channel. I've had some problems changing channels directly in Mythbox where sometimes it locks up if I just type in a channel number. To be honest since I installed Sick Beard I don't use Mythbox much more than keeping the news on while I work.

Thanks :-( Its a shame to hear the channel changes are as slow as that, I was hoping it would be about the same as MythTV.

I'll wait for 10.1 in that case and see how it rolls then. In the meantime I'll ramp up my SickBeard show adding ;-)
Reply
Okay, hopefully someone might be able to help me out, here is my setup:

PC - Running Ubuntu 10.10 + MythTv backend/frontend + Xbmc 10 Dharma + MythBox

PC - Running Windows + Xbmc 10 Dharma + Mythbox

Using an HDhomerun box hooked up to the network.

I have set up the 2nd pc running windows to access the backend, and I have shared the recordings directory on the Ubuntu machine, so that it can access that too. One thing, I don't know if it is normal or not, is when I have xbmc/mythbox up on the ubuntu machine watching a tv channel, and then I go and pull up xbmc/mythbox on the windows machine, I can see that status and it says tuner 1 is watching such and such channel, but when I go to watch a channel on it, it won't load the channel I am trying to put it on. It will load a channel, and the odd thing is, it isn't necessarily the same channel the ubuntu player is on, but I can't get it to change the channel. No matter what channel I choose, it acts like it is loading it, and then keeps going back to the same channel. Almost like it can't control either tuner, and it is just pulling up the last channel the ubuntu machine had tuner 2 on. Any Ideas? I have to stop the ubuntu machine from playing any channels, and then the windows machine can change channels. Is this normal operation?

Also, when looking at the guide for the current time, how do you tell it to record something? When you go to something coming up, the recording options pop up, but when you go to something that is current, it just changes to that channel?
Reply
Are you running Myth 0.24? If so, its not fully working with Dharma/Mythbox. I can get it to work on the same box as mythtv but can't get it to work on any of my other xbmcs. In the process of installing 0.23 now

Jon
Reply
I am on 0.23.1+fixes... I do get live tv, just seems only 1 tuner is working, gonna try starting over in the mythtv setup in regards to tuners..
Reply
  •   
  • 1
  • 30
  • 31
  • 32(current)
  • 33
  • 34
  • 57
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] MythBox for XBMC - a MythTV Front-end Python Script for XBMC4
This forum uses Lukasz Tkacz MyBB addons.