• 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  • 57
[RELEASE] MythBox for XBMC - a MythTV Front-end Python Script for XBMC
Dolence Wrote:Thanks for your reply!

I would be happy if I could get 5 seconds channel changes.
Is there anything I can do to improve this performance?

Obviously faster equipment will result in faster response times.

Check out your xbmc.log and try to resolve any errors that appear there. In my experience Mythbox is sensitive to error conditions so everything you can do to fix them helps. Even not having icons for channels will slow it down.

Perhaps someone could post here where the Myth backend keeps its log files. Those would be a good place to look for problems also.
Reply
I get a couple second channel chain and that includes irsending the channel code, changing the channel on the cable box, and sending it all over FireWire. It's a slow but that's ok. If I could view the guide while watching tv, like mythtv I'd be happy though.
Nothing to see here....
Reply
TugboatBill Wrote:Obviously faster equipment will result in faster response times.

Check out your xbmc.log and try to resolve any errors that appear there. In my experience Mythbox is sensitive to error conditions so everything you can do to fix them helps. Even not having icons for channels will slow it down.

Perhaps someone could post here where the Myth backend keeps its log files. Those would be a good place to look for problems also.

I believe they're in /var/log.
Nothing to see here....
Reply
Hammi Wrote:Is it quicker for you in MythTV? Or is it a general problem? If the latter, the root cause may be in the DVB hardware and/or the driver.

Yes! In MythTV Frontend channel changes takes 2 or 3 seconds!
I will ask a friend of mine to test on his setup.

TugboatBill Wrote:Obviously faster equipment will result in faster response times.

Check out your xbmc.log and try to resolve any errors that appear there. In my experience Mythbox is sensitive to error conditions so everything you can do to fix them helps. Even not having icons for channels will slow it down.

Perhaps someone could post here where the Myth backend keeps its log files. Those would be a good place to look for problems also.

Ok, I will check my logs for errors.


Thanks for the fast reply!
Reply
Hi!

Let me thank for everyone giving some feedback here and a big thank to the coder who spent his time to make this eye candy addon avaliable to us.

Changing MythTV Backend IP from 127.0.0.1 to 192.168.1.2 I saw some speed improvement on channel changing: 7-8 secs for SD channels and 15-20 secs or more for HD, what I think is very very slow.

I'am running MythTV on the same box as XBMC + Mythbox and when using MythTV Frontend channel changes took no more then 3 secs. In Mythbox should not to be the same?
Please, can anyone report if it's normal channel changes being so slow?

Here are my specs in a more detailed way:
ASUS P7H55-M
INTEL CORE i3
8 Gb DDR3 RAM
NVIDIA GT220 1024 Mb + latest drivers from Ubuntu repositories
SKYSTAR HD 2 @ StarOne C2 70.0W

Ubuntu Maverick 10.10
XBMC 10.10 - XBMC Team PPA (not the PVR one)
MythTV 0.23.1 + fixes - Ubuntu default repositories
MythTV Backend IP 192.168.1.2
Mythbox 1.0.2 - installed from Addons menu

Another small problems I've noticed are:
- I'm brazilian and in EPG special characters like ã, õ, é, etc are not showed correctly. I know it's MythTV related, but if anyone knows how to correct this I would be grateful!
- While watching a channel, if I open EPG the small video screen is half covered by EPG info.
- When I change the channel while in EPG that green spinning loading circle appears under/covered by EPG info.

Thats all!

Sorry if my english isnt so god. And again, thanks for everyone!
Reply
I think mythbox is always going to be slower. How are you connected to your box?
Nothing to see here....
Reply
zepfan Wrote:I think mythbox is always going to be slower. How are you connected to your box?

I'am running MythTV and XBMC+Mythbox in the same box, and using a Skystar HD 2 PCI as DVB-S tuner (S2-liplianin/mantis drivers).

How slow channel changes are on your setup?
Reply
Can anyone point me to a howto on setting up mythbox on an ATV2 XBMC setup? I can't seem to address how to enter my remote backend's recording directory. I have this directory on a network share and XBMC can see it to add as a video source. I'm not sure how to mount it however. I suspect some ssh terminal work may be needed. Pointers anyone?

thx
Scott
Reply
Dolence Wrote:I'am running MythTV and XBMC+Mythbox in the same box, and using a Skystar HD 2 PCI as DVB-S tuner (S2-liplianin/mantis drivers).

How slow channel changes are on your setup?

~4 seconds both HD and SD. I'm running STB -> Firewire and a IguanaIR Channel changer.
Nothing to see here....
Reply
Dolence Wrote:Hi!

Let me thank for everyone giving some feedback here and a big thank to the coder who spent his time to make this eye candy addon avaliable to us.

Changing MythTV Backend IP from 127.0.0.1 to 192.168.1.2 I saw some speed improvement on channel changing: 7-8 secs for SD channels and 15-20 secs or more for HD, what I think is very very slow.

I'am running MythTV on the same box as XBMC + Mythbox and when using MythTV Frontend channel changes took no more then 3 secs. In Mythbox should not to be the same?
Please, can anyone report if it's normal channel changes being so slow?

Here are my specs in a more detailed way:
ASUS P7H55-M
INTEL CORE i3
8 Gb DDR3 RAM
NVIDIA GT220 1024 Mb + latest drivers from Ubuntu repositories
SKYSTAR HD 2 @ StarOne C2 70.0W

Ubuntu Maverick 10.10
XBMC 10.10 - XBMC Team PPA (not the PVR one)
MythTV 0.23.1 + fixes - Ubuntu default repositories
MythTV Backend IP 192.168.1.2
Mythbox 1.0.2 - installed from Addons menu

Another small problems I've noticed are:
- I'm brazilian and in EPG special characters like ã, õ, é, etc are not showed correctly. I know it's MythTV related, but if anyone knows how to correct this I would be grateful!
- While watching a channel, if I open EPG the small video screen is half covered by EPG info.
- When I change the channel while in EPG that green spinning loading circle appears under/covered by EPG info.

Thats all!

Sorry if my english isnt so god. And again, thanks for everyone!

I think it can be the cause of my channel change lag problem:

2011-03-24 23:24:10.001 ProgramInfo(): Updated pathname '':'' -> '1411_20110324232310.mpg'
2011-03-24 23:24:11.035 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (914 errors)
2011-03-24 23:24:11.092 MainServer::HandleAnnounce FileTransfer
2011-03-24 23:24:11.130 adding: mediacenter as a remote file transfer
2011-03-24 23:24:11.210 ProgramInfo(): Updated pathname '':'' -> '1411_20110324232313.mpg'
2011-03-24 23:24:11.272 ProgramInfo(): Updated pathname '':'' -> '1411_20110324232313.mpg'
2011-03-24 23:24:11.328 RingBuf(/var/lib/mythtv/livetv/1411_20110324232310.mpg) Error: Invalid file descriptor in 'safe_read()'
2011-03-24 23:24:11.378 ProgramInfo(): Updated pathname '':'' -> '1411_20110324232313.mpg'
2011-03-24 23:24:12.444 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (908 errors)
2011-03-24 23:24:16.417 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (908 errors)
2011-03-24 23:24:26.425 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (910 errors)
2011-03-24 23:24:36.433 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (909 errors)
2011-03-24 23:24:37.888 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
2011-03-24 23:24:37.957 Expiring 0 MBytes for 1015 @ Thu Mar 24 23:15:00 2011 => Troca de Famlia 4 Temp.
2011-03-24 23:24:38.005 ProgramInfo(): Updated pathname '':'' -> '1015_20110324232147.mpg'
2011-03-24 23:24:39.108 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (907 errors)
2011-03-24 23:24:39.157 ProgramInfo(): Updated pathname '':'' -> '1015_20110324232147.mpg'
2011-03-24 23:24:40.207 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (913 errors)
2011-03-24 23:24:41.060 ProgramInfo(): Updated pathname '':'' -> '1015_20110324232147.mpg'
2011-03-24 23:24:43.130 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (909 errors)
2011-03-24 23:24:46.442 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (910 errors)
2011-03-24 23:24:56.450 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (913 errors)
2011-03-24 23:25:06.458 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (907 errors)
2011-03-24 23:25:16.465 MythSocket(ffffffffabd06690:43): writeStringList: Error, No data written on writeBlock (914 errors)

Anyone know what is the meaning or cause of these errors, and how to correct it?
Reply
Hello,

With the last mythbox code (today), Mythbuntu 10.04, Mythtv 0.23.1, I'g got this error when I try to access to recordings:

INFO | mythbox.core | bootstrapper.py | MainThread | Line 106 | Mythbox Platform Initialized
WARNING | mythbox.ui | recordings2.py | MainThread | Line 118 | groups focus
ERROR | mythbox.core | util.py | MainThread | Line 401 | (<class exceptions.UnicodeDecodeError at 0xab634c4>, <exceptions.UnicodeDecodeError instance at 0xb362020c>, <traceback object at 0xb361ad1c>)
ERROR | mythbox.core | util.py | MainThread | Line 402 | CATCHALL_UI: Caught <type 'instance'> exception 'ascii' codec can't decode byte 0xc3 in position 15: ordinal not in range(128) on method onInit
Traceback (most recent call last):
File "/home/phil/.xbmc/addons/script.mythbox/resources/src/mythbox/util.py", line 399, in catchall_ui
return func(*args, **kw)
File "/home/phil/.xbmc/addons/script.mythbox/resources/src/mythbox/ui/recordings2.py", line 105, in onInit
self.refresh()
File "<string>", line 1, in <lambda>
File "/home/phil/.xbmc/addons/script.mythbox/resources/src/mythbox/ui/toolkit.py", line 196, in window_busy
result = func(*args, **kwargs)
File "<string>", line 1, in <lambda>
File "/home/phil/.xbmc/addons/script.mythbox/resources/src/mythbox/mythtv/conn.py", line 123, in inject_conn
result = func(*args, **kwargs)
File "/home/phil/.xbmc/addons/script.mythbox/resources/src/mythbox/ui/recordings2.py", line 229, in refresh
self.render()
File "<string>", line 1, in <lambda>
File "/home/phil/.xbmc/addons/script.mythbox/resources/src/mythbox/util.py", line 372, in ui_locked2
result = func(*args, **kw)
File "/home/phil/.xbmc/addons/script.mythbox/resources/src/mythbox/ui/recordings2.py", line 244, in render
self.renderGroups()
File "/home/phil/.xbmc/addons/script.mythbox/resources/src/mythbox/ui/recordings2.py", line 265, in renderGroups
if self.lastSelectedGroup == title:
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 15: ordinal not in range(128)


I tried to change default encoding from ascii to utf-8 in site.py included in /usr/lib/xbmc/system/python/python24.zip

So site.py now contains :

def setencoding():
"""Set the string encoding used by the Unicode implementation. The
default is 'ascii', but if you're willing to experiment, you can
change this."""
""" encoding = "ascii" # Default value set by _PyUnicode_Init() """
encoding = "utf-8"
if 0:
# Enable to support locale aware default string encodings.
import locale
loc = locale.getdefaultlocale()
if loc[1]:
encoding = loc[1]
if 0:
# Enable to switch off string to Unicode coercion and implicit
# Unicode to string conversion.
encoding = "undefined"
if encoding != "ascii":
# On Non-Unicode builds this will raise an AttributeError...
sys.setdefaultencoding(encoding) # Needs Python Unicode build !


But no chance ... any improvment ...

By the way, could someone explain to me the role of recordings2.py ?

Thanks a lot for any tips or help.

Best regards.
Reply
@ Dolence:

Hello,

It seems these mythsocket errors are solved in mythtv 0.23.1+fixes 26437
You could use the mythbuntu repos to eventually update mythtv.

Gulliver;
Reply
Gulliver Wrote:@ Dolence:

Hello,

It seems these mythsocket errors are solved in mythtv 0.23.1+fixes 26437
You could use the mythbuntu repos to eventually update mythtv.

Gulliver;

Thanks Gulliver!

Actually I'm giving TVHeadend a try and it's working...
I'm missing some unique features from MythTV bit I can live without it.
Anyway, I will test with Mythubuntu repos before make my decision.
Just to to satisfy one’s curiosity, how longer takes channel changes on your setup? Sometimes on my setup it takes 30 secs!
Reply
About 10 secs from the list of channels, and 8 secs if I use the channel up / channel down button of ir remote.
Unfortunately I can't use the numeric keys ... It send an alphanumeric number as channel number (for example: "D-ROM" for "5") to myth-backend which doesn't understand .... and takes all the cpu ressources .... (http://forum.xbmc.org/showthread.php?tid=96764).

I already think it's really high: myth-frontend takes half time.
I think your 30 secs are due to the mythsocket issue: when I've got these errors it took 30-40 secs to switch channel.

Anyone for helping me with my unicode issue ...? Perhaps a track to explore ?
Thanks.

Gulliver
Reply
i install mythbox, i all settings post of mysql.
i create db, but not create tables ?
i search any create tables script, but i not found.
mythbox return error main window table xxx not found.
how do create tables ?
thanks...
Reply
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  • 57

Logout Mark Read Team Forum Stats Members Help
[RELEASE] MythBox for XBMC - a MythTV Front-end Python Script for XBMC4
This forum uses Lukasz Tkacz MyBB addons.