•   
  • 1
  • 100
  • 101
  • 102(current)
  • 103
  • 104
  • 106
  •   
[WINDOWS] External Player Support Thread
Edit: I see this was also asked a few pages back, so it seems like it is an actual bug with Leia.

Edit2: Fixed in tonight's nightly build!

Leia alpha3 x64 w10

I have a playercorefactory setup to launch all my videos with mpc-hc, while audio is launched with the internal kodi player.

Audio and video files launch fine, but as soon as I play any video that invokes the mpc-hc rule, -ALL- subsequent plays of any media type (audio and video) are forced into this rule as well, even "play using..." and selecting the internal player does not work, everything is forced to the rule from the first video played. Only restarting Kodi fixes this, I can then play audio with the internal player as desired, but only until another video is launched.

<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\K-Lite Codec Pack\MPC-HC64\mpc-hc64.exe</filename>
<args>/fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
<playcountminimumtime>1140</playcountminimumtime>
</player>
</players>
<rules action="prepend">
<rule video="true" player="MPC-HC">
</rule>
</rules>
</playercorefactory>
Reply
(2018-08-14, 18:08)bsoriano Wrote: a) I don't think you can have a "Play Using..." as default action, only Play, Choose or Info.  I use "Choose", since it brings up the menu from where you select "Play Using...".

b) I am not sure what is going on in your environment.  In Kodi I have disabled to Adjust display refresh rate in the Player Settings, as well as Sync Playback to display.  In System Settings, Video, I have Display Mode set to Full Screen, and Use fullscreen window enabled. 
 a) Found it although "Play using..." is a bit hidden then (at least with v17.6?). First menu is only "Play", "Info" and "more". Have to choose "more" to have further options, one of them being "Play using...". But at least it's a workaround for me :-)
b) Same settings here. Switching to 1080p (playing the movie) and then switching back to 2160p (exit player) gives me a downscaled Kodi window as described. I'll check other options, maybe windows GUI scaling, maybe Kodi v18 is different...
Reply
(2018-08-15, 06:48)djc5166 Wrote: Edit: I see this was also asked a few pages back, so it seems like it is an actual bug with Leia.

Edit2: Fixed in tonight's nightly build!

Leia alpha3 x64 w10
Patience or revert to 17.6

This worked for me KodiSetup-20180815-09bff6a0-master-x64.exe
Reply
(2018-08-15, 06:48)djc5166 Wrote: Edit: I see this was also asked a few pages back, so it seems like it is an actual bug with Leia.

Edit2: Fixed in tonight's nightly build!

Leia alpha3 x64 w10

I have a playercorefactory setup to launch all my videos with mpc-hc, while audio is launched with the internal kodi player.

Audio and video files launch fine, but as soon as I play any video that invokes the mpc-hc rule, -ALL- subsequent plays of any media type (audio and video) are forced into this rule as well, even "play using..." and selecting the internal player does not work, everything is forced to the rule from the first video played. Only restarting Kodi fixes this, I can then play audio with the internal player as desired, but only until another video is launched.

<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\K-Lite Codec Pack\MPC-HC64\mpc-hc64.exe</filename>
<args>/fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
<playcountminimumtime>1140</playcountminimumtime>
</player>
</players>
<rules action="prepend">
<rule video="true" player="MPC-HC">
</rule>
</rules>
</playercorefactory>
 Nice to hear that the PR https://github.com/xbmc/xbmc/pull/14291 also fixed the issue for you.

pOpY
Reply
Hi all, 

I've always had Kodi running on my Android phone without issue and recently acquired a laptop (Win10), so I thought let's stick it on there too!

No problems there, installed fine and put my add-ons back on without a problem.  However, after configuring the playercorefactory for external players, I cannot open any streams in VLC.  Each time receiving a 403 Forbidden error (cannot open mru).  So I checked on my phone (which always worked) and have the same there.  The internal player works without issue.  I also tried MPC and have a 'Failed to render' error.  Just to test, I used a public stream from Azure to trial in VLC and that was fine.  

Allowed apps through firewall too, just in case.

I read somewhere that it's possible Kodi is appending something to the stream linksHuh?  

Can't seem to find an answer thus far so if someone has already experienced this and it's been solved I'll be happy to run along and read that.

Thanks in advance.

Andy
Reply
(2018-08-16, 12:40)popy Wrote: Nice to hear that the PR https://github.com/xbmc/xbmc/pull/14291 also fixed the issue for you.

pOpY 

I was pretty weary of using a nightly, but I figure it is mostly in the same realm of stability as alpha3.

Leia is actually pretty stable for me so far, it seems to be a better experience than v17 was, and I no longer have any hangs when trying to exit Kodi (which happened all the time in v17). With this fix everything is pretty much perfect for now Big Grin
Reply
Even am facing the same issue for very long, better wait for 10-15mins or it's turning dark and being same.

With Regards,
Xovo Larjem
Reply
Hey guys,

update from my side regarding some external player issues: https://forum.kodi.tv/showthread.php?tid...pid2760425

pOpY
Reply
Hi,
I‘ve windows 10 x64 et added VLC in using this XML :


<playercorefactory>
<players>
<player name="VLC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Programmes\VideoLAN\VLC\VLC.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
</playercorefactory>


However, HDR does not work.
I am under windows 10 and the HDR is correctly activated.
So it appears clearly on the screen, but 4K videos under Kodi are very pale, grayed out
Like when HDR is not activated.
Do you have a solution?
Thank you in advance and sorry for my bad English, I am French ^^
Reply
Does HDR work without Kodi?
Reply
Thanks for the response,
Yes, without Kodi HDR work, so i don't understand why with Kodi no... Rolleyes
Reply
Try MPC with madVR. You can disable Windows HDR if you have a Nvidia or AMD GPU. It will switch to HDR automatically.
Reply
Okay, i will try Wink
Reply
What rule should I use to set the NextPVR Live TV stream only to the internal player and have everything else use VLC?
Seems that any external player I tried doesn't play the live TV stream, so I want everything else to use VLC.

Any way to do that?
Reply
Does anyone have any idea why any movie or show does not turn to "watched" after playing them with MPC-BE ?

My playercorefactory.xml is:

<playercorefactory>
<players>
    <player name="MPC-BE" type="ExternalPlayer" audio="false" video="true">
      <filename>C:\Users\FAMILY\AppData\Roaming\Kodi\userdata\MPCBE3DISO.bat</filename>
      <playcountminimumtime>1140</playcountminimumtime>
    </player>
</players>
<rules action="prepend">
    <rule filename=".*HDR10.*|.*HDR.*|.*hdr.*" player="MPC-BE"/>
    <rule filename=".*.MVC.*|MVC.*" player="MPC-BE"/>
    <rule filetypes="iso|bdmv|mpls|m2ts|mkv|mk3d|.*3D.*|.*.3D.iso|3D.*" player="MPC-BE"/> 
</rules>
</playercorefactory>


Thanks
W10 1809/MPC-BE KODI/1060 6GB/YCbCr 4:4:4/12bit Desktop mode=23Hz Video mode=Matched Refresh rates/LG OLED65E6V UHD HDR 3D/ Pioneer SC-LX901
Reply
  •   
  • 1
  • 100
  • 101
  • 102(current)
  • 103
  • 104
  • 106
  •   



Logout Mark Read Team Forum Stats Members Help
[WINDOWS] External Player Support Thread11
This forum uses Lukasz Tkacz MyBB addons.