•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 9
  •   
Win HOW-TO start XBMC in fullscreen on secondary monitor with custom resolution
#16
Blackkatt Wrote:If you use -fs instead of SDL_FULLSCREEN_HEAD=2 you will get these problems, there by this guide. Your not doing as the guide say's, no wounder you got problems!


You're obviously not getting what i'm saying..

Will test some more.
Reply
#17
Does this guide apply to vista?
Reply
#18
PJ_Hooker Wrote:Does this guide apply to vista?

Yes I run Vista or did, now on WIN7 where it also works. If you use UAC, run XBMC as admin the first time when you configure it Big Grin
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#19
Just wanted to comment that this worked great for me. I initially tried using xbmcLauncher - but I couldn't get it to work right (it would go to my 2nd display, but wouldn't fill the screen. I'd have to manually go into settings and re-apply a 1080i screen resolution each time).

Your steps were very clear and allowed me to do exactly what I wanted. Thanks!
Reply
#20
logicalinsanity Wrote:Just wanted to comment that this worked great for me. I initially tried using xbmcLauncher - but I couldn't get it to work right (it would go to my 2nd display, but wouldn't fill the screen. I'd have to manually go into settings and re-apply a 1080i screen resolution each time).

Your steps were very clear and allowed me to do exactly what I wanted. Thanks!

Sounds good, I'm happy it works for you Big Grin
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#21
Also wanted to mention that, if you're on Windows 7 and trying to use the 3.0.4 beta of UltraMon - you'll need to do a few registry tweaks to get UltraMon running - as some of the features aren't compatible yet with Windows 7.

There's a forum post about it on the UltraMon site. However, I've outlined them again below:

Making UltraMon work with Windows 7

Problem:
After installation, when you try to run UltraMon, you get the following Fatal Error when launching UltraMon:


Version 3.04
OS: 6.1.7000 x32
Source file .\ButtonRenderVistaComposited.cpp
Line 43
Retrun value 0
Last Error: 1814


To fix this, you need to edit UltraMon's Window Button setting in the registry:

1. Go to: Start > Type 'regedit' in the search field

2. Navigate to [HKEY_CURRENT_USER\Software\Realtime Soft\UltraMon\3.0.4\Window Buttons]

3. Set the following keys to "0"
"Move Window Button"
"Maximize to Desktop Button"

The above should be all you need to do if you're on build 7000 of Windows 7. If you're on an earlier release or UltraMon still won't launch - then try doing the couple of extra registry changes outlined in that forum thread.

Also, some users reported that they didn't need to perform any registry tweaks if they used UltraMon 2.7.1 instead of the newer beta.
Reply
#22
Your right, i totally forgot about that. I will add that to the guide, thnx.
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#23
Had similar probs as Hasselstrom and solved it like this, also i found u could avoid using step 3a and getaway with a less complicated environment variable.

Im using winXP btw, so if ur using it to try these steps first. They also make do whatever u need on screen1 while xbmc runs on screen2, before i had some issues with every window i opened when xbmc was running, went to screen 2.

BIG creds to Blackkatt.

Try this:

1. Get Ultramon.
2. Copy your XBMC.exe
3. Rightclick where you want your shortcut and press "Paste shortcut"
4. Rightclick your new shortcut, select "Properties.
5. In Target, add -fs. Should look like this: "C:\Program Files\XBMC\XBMC.exe" -fs.
6. Press apply and select "UltraMon - Window" tab. Select "Use custom settings" and choose Monitor2, then also select "Centered".
7. Hit "OK", open the shortcut, should now be displayed on your screen of chooise.
8. Go to your skins settings and choose wanted resolution.
Reply
#24
thnx, added it to the guide.
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#25
I'm not sure what I'm missing, but I installed UltraMon but I don't get the mentioned UltraMon specific tabs in the properties of my XBMC shortcut.

Do I have to activate any special option in UltraMon or something?

Thanks for the help.
Reply
#26
Montellese Wrote:I'm not sure what I'm missing, but I installed UltraMon but I don't get the mentioned UltraMon specific tabs in the properties of my XBMC shortcut.

Do I have to activate any special option in UltraMon or something?

Thanks for the help.


weird, try this instead.

1. Get Ultramon
2. Rightclick Ultramon ikon in the bottom right corner of your taskbar.
3. Select Shortcuts then "New shortcut"
4. in "Application, script or document" browse your xbmc.exe, leave the other field "start in" blank, click next.
5. Select "use custom settings", "show" should be set to Normal, change to monitor 2 and check "centered". Click next, then next again.
6. Name your shortcut, place it where you want, press finish.
7. Go into settings on your xbmc skinn, change resolution, restart.

try this and get back on how it went, peace.

edit: added #7
Reply
#27
Ah way better.
Shame on me I didn't see that option ^^
But I only looked over the settings available in UltraMon Options...

Only issue now is that it opens XBMC in Windows Mode with a screen resolution of approximatly 1280x768.

My primary monitor is 22'' with a resolution of 1680x1050 and my secondary is 24'' with 1920x1200. I already tried the "-fs" parameter. It opened the XBMC window with a size of 1680x1050 but still not fullscreen 1920x1200. Is this even possible? I also tried to adjust the screen size in XBMC settings but highest resolutiion I could choose was the one of my primary monitor.

I know it's quite rare having 2 monitors with different resolutions and size, but I always use my 24'' monitor to watch movies because it can show 1080p movies without downscaling to 1680x1050 which looks way better.

Thanks for your help, I really appreciate it.

EDIT: I just tried the SDL_FULLSCREEN_HEAD=2 mentioned in the first post of this thread as well, didn't change anything.
Reply
#28
Montellese Wrote:Ah way better.
Shame on me .

i forgot one step, after u got it running on the other screen, u go into settings on your skin and change resolution to 1080p and restart it.

try it and get back.
Reply
#29
I couldn't try that yet coz I'm at work right now and won't be home till late tonight so this might be a stupid question but actually the resolution of my 24'' monitor isn't really 1080p as it isn't even 16:9 but rather 16:10.
Doesn't setting the resolution to 1080p stretch the XBMC skin to the size of my bigger resolution? I could imagine that this could ruin a really excellent looking skin like Aeon Stark.

But I will try it as soon as I get home from work (unfortunately this is around 11pm GMT+1 today) and let you know how it worked out.
Reply
#30
Montellese Wrote:I couldn't try that yet coz I'm at work right now and won't be home till late tonight so this might be a stupid question but actually the resolution of my 24'' monitor isn't really 1080p as it isn't even 16:9 but rather 16:10.
Doesn't setting the resolution to 1080p stretch the XBMC skin to the size of my bigger resolution? I could imagine that this could ruin a really excellent looking skin like Aeon Stark.

But I will try it as soon as I get home from work (unfortunately this is around 11pm GMT+1 today) and let you know how it worked out.

try some different resolutions, dont think it will strech, rather not use all of the height on your screen, simply use a black background. The only concern is if it will look like a window or not.
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 9
  •   



Logout Mark Read Team Forum Stats Members Help
HOW-TO start XBMC in fullscreen on secondary monitor with custom resolution4
This forum uses Lukasz Tkacz MyBB addons.