•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 9
  •   
Win HOW-TO start XBMC in fullscreen on secondary monitor with custom resolution
#61
cmbx Wrote:Hi, are all those steps needed?

If I create a shortcut and add "SDL_FULLSCREEN_HEAD=2", then xbmc starts up fine, full screen on the secondary monitor.

And also if I set only the ultramon window tab, without the other steps, it also starts fine, full screen on monitor2.

So am I missing something by doing ALL of the above steps?


The only problem is that uice wont start from the shortcut, only from the actual executable, so it still will only load up onto my primary display, and windowed! Is there any way to start the shortcut with uice??


thanks.

This guide is meant too help you get XBMC on secondary display with custom resolution getting XBMC too launch on secondary display was never a problem. Big Grin
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#62
coreythemaggot Wrote:Hello and thanks for a really useful guide. I've used it now since it's first issue.

But I'va got this problem. When looking at the secondary display (720p TV with XBMC) there is a vertical row of rectangulars at the left side of the screen. Also, I have always noticed an unsynced framerate both in movies and menys compared to the "swap main-display"-mode.

This goes for all tried graphisdriver versions and xbmc-versions.

Anyone else seen this? Is there a solution? Smile

Thanks! ///ctm555

@coreythemaggot, Homerjr43, mason

This is a Windows problem with some blame on Nvidia I guess.. You can solve this easy by following these simple steps.

1. Right-Click on XBMC.exe, goto "Compatibility"
2. Now check, "disable visual themes" "disable desktop composition" "disable display scaling on high DPI settings"

TaDa! ShockedNod
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#63
Thank you! No more black boxes! SmileSmileSmile


///ctm
Reply
#64
coreythemaggot Wrote:Thank you! No more black boxes! SmileSmileSmile


///ctm

You are very much welcome Big Grin
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#65
I hate to be a dick but why do we need 3rd party software for this?
Why is this feature not built into the program?
Kind of lame if you ask me..
Especially since ultramon is not free!!
There are easy ways to code how to control which monitor a program can display on!!
Reply
#66
surge Wrote:I hate to be a dick but why do we need 3rd party software for this?
Why is this feature not built into the program?
Kind of lame if you ask me..
Especially since ultramon is not free!!
There are easy ways to code how to control which monitor a program can display on!!

LOL go do it yourself then. Don't demand anything from the dev witch so kindly have given us XBMC!
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#67
Blackkatt Wrote:This is a Windows problem with some blame on Nvidia I guess.. You can solve this easy by following these simple steps.

1. Right-Click on XBMC.exe, goto "Compatibility"
2. Now check, "disable visual themes" "disable desktop composition" "disable display scaling on high DPI settings"

TaDa! ShockedNod

Same problem here, with black squares on both my primary on secondary monitor.

Image

But if I check the 3 "disable" options, everything seems fine but a different graphical bug appears on my primary display :

- black window during 1-2 secs

Image

- blank window with a magnifying glass icon, it disapears when i switch windows or after 1 min

Image

- Aero is disabled which means my windows theme is disabled or buggy, the soft I use to swithc windows just like in OSX no longer works ...

http://img22.imageshack.us/i/graphicbug4.jpg/


This bug seems to occur because of the "disable desktop composition". If i let it uncheck, my primary display looks fine but then again black squares.

Some informations on my config :
-Windows Vista SP2 running with BootCamp --> Graphic card : ATI MOBILITY RADEON HD 2600 XT
last official drivers with Mobility Modder
-Aero enabled with visual style
- UltraMon (last release and beta versions tested --> both share these bugs)
- Display 1 : iMac screen (1680x1050)
Display 2 : HDTV (1360x768 @ 60 Hz)

If someone knows how to solve this ? Thanks in advance. Wink
Reply
#68
ghostnelson Wrote:Same problem here, with black squares on both my primary on secondary monitor.

But if I check the 3 "disable" options, everything seems fine but a different graphical bug appears on my primary display :

- black window during 1-2 secs
- blank window with a magnifying glass icon, it disapears when i switch windows or after 1 min
- Aero is disabled which means my windows theme is disabled or buggy, the soft I use to swithc windows just like in OSX no longer works ...

This bug seems to occur because of the "disable desktop composition". If i let it uncheck, my primary display looks fine but then again black squares.

Some informations on my config :
-Windows Vista SP2 running with BootCamp --> Graphic card : ATI MOBILITY RADEON HD 2600 XT
last official drivers with Mobility Modder
-Aero enabled with visual style
- UltraMon (last release and beta versions tested --> both share these bugs)
- Display 1 : iMac screen (1680x1050)
Display 2 : HDTV (1360x768 @ 60 Hz)

If someone knows how to solve this ? Thanks in advance. Wink

I can say with most certainty, this is not a problem with my "guide" software used. It could either be a ATI, + Vista/OSX problem. Have no solution for you atm, sorry.

BTW, Are you using Vista on OSX? and are you running XBMC on Vista on the Mac? if so wtf! Shocked do you know that XBMC exist for OSX too?
http://sourceforge.net/projects/xbmc/fil...0-%209.04/
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#69
hey guys i see the windows of xbmc in part on my first display. My second display it's a 4:3 tv... do you think that's that the cause? Or i can solve in some way? Thank you. Bye bye
Reply
#70
nevermind! i solved it, im such a noob
Reply
#71
the guide worked perfectly for me but i use eventghost and when i point it to the shortcut i created using this guide it won't launch xbmc. anyone know how to fix this?
Reply
#72
Using event ghost, you put the path to xbmc in the first box and then all the arguments in the second box.

Image
Life's not too short, you're just dead for so long.
Image

HP Pavilion m9500y
AMD Athlon64 x4 - 4gb RAM 4.5TB HDD RAID
Mac OS 10.6 - XBMC Dharma RC2
Reply
#73
so the argument for it to start on the second monitor is '-p'? that didn't work for me
Reply
#74
lonchaney Wrote:so the argument for it to start on the second monitor is '-p'? that didn't work for me

Hi, It's no "-p" and there's no need to use any, anymore. just download latest SVN XBMC and there will be an option to run on secondary display. If not. Use my Guide Wink
The Problem is not the problem. The problem is your attitude about the problem.
Do you understand?
Reply
#75
Hi to all,

I have just installed the Ver. "XBMC_for_Windows-9.04.1-repack2" on a Windows 7 Ultimate 64bit PC, and I read in the update of the first post that now it's not necessary to use the "workaround" with Ultramon to launch XBMC in fullscreen in the secondary monitor.

I try to see if a look for an option to switch between a monitor and the other but I cannot find nothing.

Where I can find this option ?

Is the version that I use correct or I need a different version ?

Thank you to all in advance for your attention and a big hello from Italy.

Bye
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 9
  •   



Logout Mark Read Team Forum Stats Members Help
HOW-TO start XBMC in fullscreen on secondary monitor with custom resolution4
This forum uses Lukasz Tkacz MyBB addons.