HOW TO Zalman HD135 VFD with Proper Driver
#16
Dave,

Would similar instructions work on XBMC Live? I basically gave up on my HD135's VFD and used win7 instead. I'd prefer to get XBMC live going on it, especially if I can get the VFD and remote working.

Maybe I should try to find that remote Big Grin
Reply
#17
Another thing just noticed: If LCDd is running, then remote stops working after awaking up from sleep; restarting lirc doesn't help at all. Anyone else seeing this as well? Cheers!!
MINIX Neo U9-H | Pioneer SC-LX701 | KEF Q50 | KEF T301c | KEF KHT3005SE-W | LG OLED55C7 | OpenELEC
Reply
#18
thecapsaicinkid Wrote:Hi all,

I have the Zalman HD135 HTPC case and while attempting to fix an LCDproc issue (by installing a newer version) I seem to have caused a weird issue with
the IR portion of the unit. As soon as I put power to the machine the
little red led next to the IR sensor lights and stays on permanently,
it seems no IR signals are being passed through the interface either
(shared with the VFD on /dev/ttyUSB0 using the FTDI serial module)
Powering down doesn't help, as does removing all traces of
LCDproc/Lirc etc. I know this isn't strictly an LCDproc issue but I'm
at a total loss on how to fix this and wondered if anyone had any
thoughts on what the issue could be. It's possible the unit has gone
faulty or maybe the bios for the display has got into an inconsistent
state?


Any ideas at all welcome.


Thanks

brief overview:
trying to use features on my Zalman HD135 with "VL System M-Play Blast - 5.25" Black w/ Blue VFD"

installed ubuntu 10.04 amd64 with defaults and updates.
removed movie player, rythmbox; installed vlc.
tweaks to firefox.
installed lirc 0.8.6-0ubuntu4.1 via "Ubuntu Software Center"

installed XBMC 1:9.11-lucid3 using http://wiki.xbmc.org/index.php?title=HOW...Step_Guide . Some video formats not decoding properly; also seeming random lockups requiring hard reset. Not t/s yet, as many other options are available for this, and largely pointless without the remote.

followed "HOW TO Zalman HD135 VFD with Proper Driver" located at http://forum.xbmc.org/showthread.php?tid=45924 with limited success. "wget" failed, so lcdproc-0.5.2.tar.gz was obtained elsewhere. (there is a 0.5.3, but search yielded low confidence with patch.) Smooth up until part 6. Not clear what to do with output from "dmesg". Tried a few, but settled on ttyUSB0. Sometimes when I "sudo /etc/init.d/LCDd start", it gives me no such device for ttyUSB?. (Is there a different thing I need to stop?) Anyhow, VFD changes to read "HD44780 20x2", "LPT 0x378", so there is some progress anyway. Red light on front still persists. (see above quote).

I found this seemingly relevant thread http://lists.omnipotent.net/pipermail/lc...11959.html so I may try bothering some of these guys for ideas. Not sure if its the same or perhaps a relative of the patch covered in the previous paragraph.

If you know what you're doing, anything is easy. For me, this is difficult.

Thanks!!
-Brian M. Abel
Reply
#19
do7phin Wrote:Anyhow, VFD changes to read "HD44780 20x2", "LPT 0x378", so there is some progress anyway.
That's the one thing I'm very confused about - do you have a physical parallel port on your machine? I certainly don't. what do you see on the display when you start LCDd? Cheers!!
MINIX Neo U9-H | Pioneer SC-LX701 | KEF Q50 | KEF T301c | KEF KHT3005SE-W | LG OLED55C7 | OpenELEC
Reply
#20
MacUsers Wrote:That's the one thing I'm very confused about - do you have a physical parallel port on your machine? I certainly don't. what do you see on the display when you start LCDd? Cheers!!
No physical parallel port. Haven't figured out how to start/stop LCDd yet. Huh
I did get a useful reply from https://bugs.launchpad.net/bugs/574432 . The short version is: wake up the IR with "screen /dev/ttyUSB0 9600" (can be tucked into /etc/rc.local to load with boot).
I had no /dev/tty/USB0 , which was resolved by uninstalling brltty (a braille assistant that came default with 10.04 apparently). So now, it goes from the Zalman spash display to "HD44780 20x2", "LPT 0x378" (possibly the result of a bad file edit), and it blinks the red light next to the display in response to pushing buttons. I totally count that as a win.. but I don't get anything back when I run irw. Oh well... getting closer still.
Not sure what I'm doing, but that's really just a minor setback.

-Brian M. Abel
Reply
#21
Brian,

You may want to go back to launchpad and figure out why any LUCID kernel after .22 produces the messages (breaks LCDproc with this VFD) you are seeing on your screen all the way up to the backported maverick kernels.

you need to change the port in your LCDd.conf to have the display read dev/ttyUSB

If you want to start LCdd just run sudo /etc/init.d/LCDd (start)(stop)(restart) I have this setup in my resume scripts to run when I wake up the system and setting your defaults as I show in the first couple post of this thread usually gets LCDd in the right order.

Dave
Reply
#22
Quote:PART 6

We are almost finished! Let's edit your LCDd.conf file. I use vim as my editor in the example below you can use any editor you like just change vim to vi, nano etc. before we do this you should run dmesg and see what USB port your FTDI device was assigned. just run dmesg from the command line and then look through the list for FTDI or FD232L(D) assigned on ttyUSB? you will need this in your LCDd.conf file.

I have a VLsys M-Play 202 Plus connected to USB port on Ubuntu 11.4, but I don't have any ttyUSB line under dev/(i can't find in dmesg list FTDI or FD232L(D).

Can someone help me out? :confused2:

thx in advanced
Reply
#23
Sorry for the massive case of thread necromancy, but this seemed like the most appropriate thread to post in!

I'm trying to get the LCD and IR receiver in a Zalman HD135 case to work with OpenElec/Kodi. I've followed the instructions in the first post of this thread, and have done a lot of reading on other posts and forums, but I can't quite seem to get everything working. (It probably also doesn't help that my Linux skills are almost non-existant....!)

I originally posted this in this thread on the OpenElec forums but never managed to get a response, and as this thread seemed the most authoritative on using the HD135 with Kodi under Linux I thought it might be worth also asking the question here. Big Grin

I have created an LCDd.conf file configured to use the HD44780 driver, with an 'mplay' connection type. This gives me a working LCD display but also causes the IR receiver (or what I assume is the USB-to-serial device) to be present:

Code:
[    2.600373] usbcore: registered new interface driver usbserial
[    2.601223] usbcore: registered new interface driver ftdi_sio
[    2.601234] usbserial: USB Serial support registered for FTDI USB Serial Device
[    2.601280] ftdi_sio 4-1.5:1.0: FTDI USB Serial Device converter detected
[    2.601300] usb 4-1.5: Detected FT232RL
[    2.602351] usb 4-1.5: FTDI USB Serial Device converter now attached to ttyUSB0

However I can't seem to get the remote to do anything with regards to controlling Kodi. If I run irw I don't see any commands being received, but if I run cat /dev/ttyUSB0 I can see that commands must be being received as characters are printed to the console:

Code:
OpenELEC (official) Version: 5.95.5
OpenELEC:~ # cat /dev/ttyUSB0
~~B~~~C~C~~T~C~C~C~CCCCC~~B^C
(The characters above appeared on screen in response to buttons being pressed on the remote control).

As part of setting this up I have created the following configuration files which I copy to my OpenElec installation (I've uploaded all of these files to pastebin and linked them I the list below):

/storage/.config/autostart.sh
/storage/.config/LCDd.conf
/storage/.config/lircd.conf
/storage/.kodi/userdata/LCD.xml
/storage/.kodi/userdata/lircmap.xml
/storage/.kodi/userdata/keymaps/remote.xml

I think I have all of the correct configuration files, all in the right places, etc., and I think the hardware is now correctly configured as I can receive data on the IR device. It seems like there is just a missing piece in linking the hardware to lirc.

Would anyone be able to offer any further assistance with this? Apologies if this isn't the right place to post but I hoped/assumed that there was enough similarity between the Kodi Linux release and OpenElec that the question would still be relevant.
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
HOW TO Zalman HD135 VFD with Proper Driver51
This forum uses Lukasz Tkacz MyBB addons.