XBMC interface running at 100% CPU?
#1
Hi guys, didn't really find anyone with a problem similar to mine, so hopefully you can help me.

I'm currently at work, so I'll just start out with a description that is as clear as possible. Tonight I'll be able to provide logs as needed.

Yesterday, I installed a fresh Ubuntu 8.10 on my aging Asus Pundit-R system. It runs on a Pentium 4 2,53GHz (Northwood) with a SiS650 chipset and 1 gig of RAM. Ubuntu seems to recognize all my devices perfectly fine and runs very smoothly.

I got xbmc from the Intrepid PPA (I will check out the exact revision ASAP), and everything installed fine, without a problem.

When starting XBMC, however, I notice my CPU usage shooting up to 100% for as long as the software is running (XBMC itself taking up an average of 95%).

This makes video playback pretty much impossible (cpu time is saturated before even starting it, if I'm lucky I get 1fps, if I'm not, it just hangs until I force quit), and even navigating the menus is rather difficult.

As soon as I quit xbmc, and play my files in Totem, the movies play just fine.

Mind you, this happens for any videofile, many of which are plain old divx. I realize that playing HD videos would be a bit over the top for this system, and that is definitely not my intention.

Will provide more info as soon as possible, but maybe this rings a bell with someone already.

So, tl;dr here

1. Linux distro: Ubuntu 8.10
2. Architecture: x86-32
3. Install method: Intrepid PPA
4. SVN revision: installed yesterday, will add ASAP
5. How to reproduce: Basically just start up XBMC and my CPU hits the ceiling, making proper video playback impossible.
6. Debug log: Will provide asap.

Thanks alot!
Reply
#2
I'm not sure if this applies but I had the same problems on windows version a while back. Here 2 solutions I came across.

1. If your video card doesn't support a high enough version of openGL it will cause said issues. I had to update my card because I was running an old radeon 7000. also check to make sure you are using the latest drivers for your card.

2. Try to disable vsync if the above doesn't apply. I know it was a problem in the windows build a while back (3 months or so). I'm sure its fixed but if you are using the old 8.10 release I don't think it is patched in there. also try using the newest SVN build. things get patched daily.

hope this helps
Reply
#3
Thanks alot, darxide.

The machine is running on a sis650 chipset with integrated graphics. I suppose this might be the culprit?

If so, I may have the option of "upgrading" to an old PCI Geforce FX 5200 card I'll need to dig up from somewhere. Think that one might do the trick?

Also, as far as I remember, vsync was disabled by default. I may need to get a bit more adventurous, and try the newest SVN build, though. I'm relatively new to Linux for something other than SBC, so that'll be a challenge. I'll give it a go, though, thanks alot! Smile
Reply
#4
Lizz the Blizz Wrote:Also, as far as I remember, vsync was disabled by default.

Enable it. There are known problems xbmc's GUI maxing out the cpu if it is disabled. I also have one core of my amd x2 saturated if vsync is off.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#5
Haggy Wrote:Enable it. There are known problems xbmc's GUI maxing out the cpu if it is disabled. I also have one core of my amd x2 saturated if vsync is off.

Thanks for the tip, I'll give that a try as soon as I get home!
Reply
#6
Also make sure the xorg driver itself supports openGL, not just the hardware, otherwise everything is rendered by the CPU = Very slow.

If you go to the system info page in the UI of XBMC it'll tell if it's rendering by Software.
Reply
#7
I'm surprised it even started on the sis650. The fx5200 probably won't be a whole lot better. IIRC it doesn't have GLSL which is a requirement.
Reply
#8
Alright, I'll have a go at it later with the GeForce FX 5200, and if that doesn't work out, I'll slap in a Sparkle GeForce 8400GS 256MB PCI, I reckon that should do the trick.

I'll report back if it turns out to be something else. Smile
Reply
#9
Might wanna spring for the 512MB version (if you haven't purchased yet) to ensure you have enough VRAM for 1080p on VDPAU.
Reply
#10
althekiller Wrote:Might wanna spring for the 512MB version (if you haven't purchased yet) to ensure you have enough VRAM for 1080p on VDPAU.

That's interesting. Why do you need so much video ram for 1080p? One frame should only need:

1920 x 1080 x 4byte = 8294400 byte

So with 512 MB video ram you could cache about 64 frames. Why do you need that much ram?

Temar
Reply
#11
Temar Wrote:That's interesting. Why do you need so much video ram for 1080p? One frame should only need:

1920 x 1080 x 4byte = 8294400 byte

So with 512 MB video ram you could cache about 64 frames. Why do you need that much ram?

Temar

http://forum.xbmc.org/showthread.php?p=2...post292882
Reply
#12
yeah,

then multiply that by 16 (backreferences), add atleast 2 (front/back buffers).
then add all textures and other uses of graphics memory (z-buffer and so on). you'll quickly exceed 256
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC interface running at 100% CPU?00