Thread Rating:
  • 2 Vote(s) - 5 Average
[RELEASE] GoogleReader (Programs) Plugin
#1
Thumbs Up 
Plugin to provide a way of browsing and reading all your subscriptions and items from your GoogleReader account.

Install to your Program Plugins area.
(You may need to change your skin settings to show the 'Programs' label on XBMC Home Page)

On first run it'll ask you to complete setup ie. Google Username & Password.
You can change 'items perpage' and if to fetch images etc.

v1.0 Allows you to browse by:
  • Subscriptions
  • Subscriptions By Label (ie all feeds in the group 'Sports')
  • Items
  • Items By Label
  • Starred
  • Shared
  • Notes

Supplied with PM3.HD and PMIII skins for item content dialog. Defaults to PMIII if your using another skin.

Supplied with English, German and Finnish translations (Thanks to Bootsy and Kottis for those)

(additional skin and language translations welcome - PM or email me)

Manually Download and install v1.0 from Box.net Or using the 'SVN Repo Installer' plugin

cheers

BBB
Retired from Add-on dev
Reply
#2
Great plugin. Thanks so much.
Reply
#3
Changes:

Date: 20 April 2009
added: Search option
added: XBMC compatibility check on startup
added: Context Menu View readme & changelog
updated: improved content decoding
updated: strings
Retired from Add-on dev
Reply
#4
Hi,

It gives me an error: <urlopen error unknown url type: https>

Do you have any idea on how can I solve this?
Reply
#5
What options did you select?

If you can reproduce it and send me the xbmc.log that would be helpful.

thanks
Retired from Add-on dev
Reply
#6
BigBellyBilly Wrote:What options did you select?

If you can reproduce it and send me the xbmc.log that would be helpful.

thanks

Surely I can reproduce, as it is always giving me this message.
At the first start I didn't changed anything, but the account settings (e-mail/pass).

I will provide you the log in the evening (10:51am here).

Thank you
Reply
#7
here it is:
http://pastebin.com/m303920f3

Seems to me, that there is something wrong with the authentication? Huh
Reply
#8
yes, i see. your runnning the linux port, which is a platform I don't have setup so havn't tested on.

Was v1.0 of the script ok , or did it run ok on a xbmc build prior to your 'Apr 21 2009 (SVN:19572)' ?

As its fine on xbox and win32, I'm thinking it might be a https issue with your xbmc port and/or build ?

Maybe you could try another plugin that also uses https - Picasaweb springs to mind.
Retired from Add-on dev
Reply
#9
BigBellyBilly Wrote:yes, i see. your runnning the linux port, which is a platform I don't have setup so havn't tested on.

Was v1.0 of the script ok , or did it run ok on a xbmc build prior to your 'Apr 21 2009 (SVN:19572)' ?

As its fine on xbox and win32, I'm thinking it might be a https issue with your xbmc port and/or build ?

Maybe you could try another plugin that also uses https - Picasaweb springs to mind.

Thanks for the feedback!
I've never tried to run before, so I have no experience with v1.0, nor with svn build prior 19572.

Is v1.0 still available to download?
Nevertheless I have the same issue with Picasa, posted the problem there as well.
Reply
#10
tbh, the authenticate func hasn't changed and as it doesn't also work with another https plugin (you might want to try some others too to be sure) I think you've found a xbmc linux problem. I'd suggest raising it in the relevant linux branch section as a potential bug ?
Retired from Add-on dev
Reply
#11
http://forum.xbmc.org/showpost.php?p=320738&postcount=1

This is a post from today from the Picasa thread. I thought it is relating and/or originated by the same root cause.
Reply
#12
Unable to tell which xbmc platform hes running. 403 error is usually associated with bad user/pwd

Maybe you could rollback to an earlier rev?

I'll updated my own win32/xbox builds to ensure they really haven't been affected too.
Retired from Add-on dev
Reply
#13
Kricker is maintaining win32 svn builds, so I guess he is running that platform... Rofl
Reply
#14
olympia Wrote:Kricker is maintaining win32 svn builds, so I guess he is running that platform... Rofl
Yup! Win32 latest SVN as of last night.
Read this before using these builds.
Changelog
Reply
#15
This is the error I get with GoogleRead on the win32 build.
Image

On the xbox t3ch SVN 4-4-09 rev19213 build it is working fine.

EDIT:
Updated win32 build to SVN 19607 and all is well.
Read this before using these builds.
Changelog
Reply



[RELEASE] GoogleReader (Programs) Plugin52