[RELEASE] GoogleReader (Programs) Plugin
#16
I updated throu several revisions (using Krickers build) upto 607, and its fine for me.

Thanks for the input Kricker.
Retired from Add-on dev
Reply
#17
BigBellyBilly Wrote:I updated throu several revisions (using Krickers build) upto 607, and its fine for me.

Thanks for the input Kricker.
I did get the same error last night again using rev 607. It was working one second the quit the next. I'll try it again today and see what happens.
Read this before using these builds.
Changelog
Reply
#18
I do very occasionally get that error too, but a restart of XBMC seems to clear it.

It was a known xbmc problem: http://forum.xbmc.org/showthread.php?tid...ight=https - but was considered fixed.
Retired from Add-on dev
Reply
#19
Unfortunately it seems not working on Linuxport...
Would be great if somebody else could also confirm...
Reply
#20
As its not specific to this Plugin, could you post a bug in the xbmc Linux branch, so all may benifit from a https fix ?
Retired from Add-on dev
Reply
#21
Something has changed recently on SVN and now authentication is working.

But for some reason, some of my subscription make the plugin fail.

If I subscribe for the following feeds:
- http://prohardver.hu/rss/anyagok.xml
- http://index.hu/24ora/rss/

When I click on subscriptions in GoogleReader, I get the following error:

Code:
Googlereader error!

Main
u'\xf3'

OK

While CNN for example working without any problem...

Debug log:
http://xbmc.pastebin.com/m2f300932
Reply
#22
looks like a unicode character thats spoiling things, I'll try and sort it. thanks for letting me know.
Retired from Add-on dev
Reply
#23
olympia: I've subscribed to both your sample rss feeds and they both show correctly on win32 and xbox xbmc. So, unfortunately its looking like an issue just on the Linux branch again, so my help is limited.

The plugin creates a file called special://temp//GoogleReader_subs.dat (mapped to XBMC/cache) after you've selected 'Subscriptions' and in that file should be that feed entry (for 24ora) - my file has it as u'title': u'Index - 24\xf3ra'(unicode) Does yours?
Retired from Add-on dev
Reply
#24
nahh just stupid encode problem.
GoogleReader/pluginAPI/bbbLib.py line 98

Code:
return repr( quote_plus(text.replace("'", '"')) )
to
return repr( quote_plus(text.encode('utf-8')) )

solve all linux keyerror problem.
Reply
#25
Sorry for the late feedback, guys.

@queeup
Thank you for the suggestion, works great Smile
Reply
#26
Thanks for the fix queeup.

During my look into this I did actually have an "encode" on that string but it made little difference on xbox/win32. I'm still not sure why it only help Linux, I'm guessing the default codec is different ?

The Plugin has had a slow take-up, I guess GoogleReader isn't as popular a RSS aggregator as I imagined.

I'll update release asap.
BBB
Retired from Add-on dev
Reply
#27
Well, got this working, started playing with plugins last night.
Used the script "Installer Passion-XBMC"
which is another nice 'addon'.

Using the ubuntu jaunty release of xbmc, in juanty.

Your plugin works for a fair few feeds from google reader, but less success with others, for example the BBC world news feed (http://newsrss.bbc.co.uk/rss/newsonline_...ge/rss.xml)

Bit of a newbie, so sorry if I've done something stupid.Oo
Reply
#28
have you tried putting in the mod to bbbLib.py that queeup posted above ?

infact a combination of original code and the mod might be best, as without it, it has trouble with feed titles using single quotes.

Quote:return repr( quote_plus(text.replace("'", '"').encode('utf-8')) )

that feed (with mod in) tested ok on xbox/win32 builds.

if not, maybe post the log (pastebin).
Retired from Add-on dev
Reply
#29
Something on this plugin isn't working for me.

I got the URLOPEN Error in the XMBC Window, but in the Log i got this error
Code:
#
15:37:40 T:3648 M:945250304   ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting plugin://programs/GoogleReader/
#
15:37:40 T:3648 M:945250304   ERROR: CGUIMediaWindow::GetDirectory(plugin://programs/GoogleReader/) failed
http://pastebin.com/f7a70c4a6

i installed Google Reader through the SVN Repo Installer. Also i copied all the files in the programm files/xbmc/plugins/programs/ directory after i read the error in the logs. But it hasn't changed anything.

Any advice?
Reply
#30
hi. on holiday at momentso can´t offer to much advice,apart from maybe do a fresh install,into Plugins Programs keeping the folder structure intact. Then using the settingsenter your google id andpass (a lot of ppl forget that bit!)
Retired from Add-on dev
Reply
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] GoogleReader (Programs) Plugin52