Thread Rating:
  • 2 Vote(s) - 5 Average
[LIVE] HOW-TO mount hard disk drives on XBMC Live 9.04
#1
Due to previous incidents where mounting local drives in special configurations lead to data corruptions, a new token has been introduced in the kernel parameter "xbmc".

By default XBMC Live does not mount fixed fisks any more; ito run the automount script at boot you need to remove the token "nodiskmount" form the kernel command line.

There are two ways to achieve this:

1. for temporary use: use the grub functionalities and edit the kernel line when booting. The change will be limited to the session only.

2. for permanent use: open the file /boot/grub/menu.lst, remove the token and save the file.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#2
I've tested this out on two machines with no luck. Eliminating nodisckmount sends the machine in an infinite loop never loading, the screen just flashes. Strangely enough, the laptop I tested it on went into a fit sending a high pitch sound into the speakers. Sounded like a tea kettle!

Both my test machines have IntelGpu.

EDIT: Works fine!
Ive encountered problems initially but I formatted the USBdrive and did a fresh install.
Reply
#3
l.capriotti Wrote:By default XBMC Live does not mount fixed fisks any more; ito run the automount script at boot you need to remove the token "nodiskmount" form the kernel command line.

Sorry for being a total noob. But I have pretty much zero knowledge when it comes to Linux.

Does that mean that if I use XBMC Live I won't be able to easily access my HDs that are locally installed (all NTFS)? And that if I force mount them I get a good chance of data corruption?

Huh

I'm thinking about trying XBMC Live. I really like the windows version, but the lack of GPU assistance is strating to bug me (I don't need it that much for smooth playback, but the possibility of a lower noise non overclocked HTPC really seems great).

Thx.
Image
Reply
#4
Discaciate Wrote:Does that mean that if I use XBMC Live I won't be able to easily access my HDs that are locally installed (all NTFS)? And that if I force mount them I get a good chance of data corruption?

Huh

i don't know about "a good chance", but i have been mounting some NTFS formatted drives in my XBMCLive box for a month or two now without problem. these used to be in my windows box and when it died, i moved them into the xbmc box since they only store my movies. also, i don't export them to the network.

-miked
Reply
#5
miked2024 Wrote:i don't know about "a good chance", but i have been mounting some NTFS formatted drives in my XBMCLive box for a month or two now without problem. these used to be in my windows box and when it died, i moved them into the xbmc box since they only store my movies. also, i don't export them to the network.

-miked
Thx a lot for your reply. I fell like trying it now.

But could anyone elaborate a bit better on what are those data corruptions? Can they lead to full HD data failure?
Image
Reply
#6
Discaciate Wrote:But could anyone elaborate a bit better on what are those data corruptions? Can they lead to full HD data failure?

There was a case in the past, I can't find the related thread, in which automounting internal hard drives caused a total loss of information.
Apparently that was a case of software disk mirroring or similar, that was not recognized as such so each volume got mounted and the result was the destruction of a working setup.

Since similar setups can be encountered, I decided to disable by default the functionality, allowing each user to enable it.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#7
l.capriotti Wrote:Due to previous incidents where mounting local drives in special configurations lead to data corruptions, a new token has been introduced in the kernel parameter "xbmc".

By default XBMC Live does not mount fixed fisks any more; ito run the automount script at boot you need to remove the token "nodiskmount" form the kernel command line.



2. for permanent use: open the file /boot/grub/menu.lst, remove the token and save the file.

I did this,
but I don´t see Drive C:
listed.

I only see the Home Directory:

/home/xbmc

I have a PC with Intel 915 onboard graphics card.
and the Live installation was installed onto the Harddisk
and it plays fine videos from CD-R and also
plays music from Shoutcast.

So how do I get access to Drive C: then ?

Many thanks.
Reply
#8
Smile 
Hi There,
I'm very new to this OS, I installed Xbox live on my PC works great. But I would like to know how add another harddrive to my XBOX live setup. Could someone tell me step by step how to excute commands to do this ?


Thank you
Palant Smile
Reply
#9
Hello,
can this error be finally address and be fixed ?

Many thanks in advance.

Regards, Stefan.


hartiberlin Wrote:I did this,
but I don´t see Drive C:
listed.

I only see the Home Directory:

/home/xbmc

I have a PC with Intel 915 onboard graphics card.
and the Live installation was installed onto the Harddisk
and it plays fine videos from CD-R and also
plays music from Shoutcast.

So how do I get access to Drive C: then ?

Many thanks.
Reply
#10
l.capriotti Wrote:Due to previous incidents where mounting local drives in special configurations lead to data corruptions, a new token has been introduced in the kernel parameter "xbmc".

By default XBMC Live does not mount fixed fisks any more; ito run the automount script at boot you need to remove the token "nodiskmount" form the kernel command line.

There are two ways to achieve this:

1. for temporary use: use the grub functionalities and edit the kernel line when booting. The change will be limited to the session only.

2. for permanent use: open the file /boot/grub/menu.lst, remove the token and save the file.

is there a way to apply theses parameters on another distro. i'm using gentoo and /boot is not mounted per default. when i install a new kernel, i have to mount boot. so when xbmc is running it would automount /boot and interrupt playback at the same time.
Reply
#11
l.capriotti Wrote:Due to previous incidents where mounting local drives in special configurations lead to data corruptions, a new token has been introduced in the kernel parameter "xbmc".

By default XBMC Live does not mount fixed fisks any more; ito run the automount script at boot you need to remove the token "nodiskmount" form the kernel command line.

There are two ways to achieve this:

1. for temporary use: use the grub functionalities and edit the kernel line when booting. The change will be limited to the session only.

2. for permanent use: open the file /boot/grub/menu.lst, remove the token and save the file.



In other words, go to the folder /boot/grub/menu.lst open it with WORDPAD , erase the word unmount disk of your graphic option, close and save.
Reply
#12
i don't see this using xbmc on minimal ubuntu install. nothing about mounting, now, that said i had no issues doing this with the live version. this is the new beta 1 btw, i have a feeling it should be something else in grub now?
Reply
#13
l.capriotti Wrote:2. for permanent use: open the file /boot/grub/menu.lst, remove the token and save the file.

EDIT: Thrdr attempts were made with XBMC live 9.11 b2

Umm - i've removed all instances of "nodiskmount" from /boot/grub/menu.lst and my drives still aren't mounted Sad


Tried reformatting my flash stick & installing XBMClive again, (as per an earlier poster) but still no dice.


Any suggestions people?
Reply
#14
Beta2 was released with a bug inverting the login of "nodiskmount"; basically if nodiskmount is present in the parameters the disk should mount.
A fix is committed already, pls verify that having nodiskmount within the options leads to disk being mounted - or check the commit for the fix.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#15
l.capriotti Wrote:Beta2 was released with a bug inverting the login of "nodiskmount"; basically if nodiskmount is present in the parameters the disk should mount.
A fix is committed already, pls verify that having nodiskmount within the options leads to disk being mounted - or check the commit for the fix.


ok, installed beta 2, removed the "nodiskmount" tokens from all grub lines, and guess what, no disks where mounted lol, thankfully found this post and as you say, added the "nodiskmount" back to the lines and my disks are mounted lol.


cheers
Reply



Logout Mark Read Team Forum Stats Members Help
[LIVE] HOW-TO mount hard disk drives on XBMC Live 9.0452