•   
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7(current)
How can i switch to [email protected]
#91
firaX Wrote:Will try this. About the judder issue - i will try "Sync video to display" and see if that fixes it. I hope it will.

That's what I meant. I use the option "drop audio".

/Söder
Vero 4K with unRAID server and mysql (mariadb)
Reply
#92
I have found that 1280x720 @ 50Hz is a mode that works well with my TV. The TV supports 49 - 61 Hz vertical refresh rate as reported by EDID. I wonder if I in XBMC setup select "Sync Video To Display" and using "resample audio" as syncing method, can I then view 23.976 fps video upspeeded to 25 Hz (the video and sudio played faster) just like they do it when viewing film on PAL TV transmissions? I am using XBMC beta 9.11 on ubuntu 9.04. I think in the windows there is an application called reclock that does a similar thing but I want it on XBMC in Linux.

This would be my preferred way of watching NTSC movies on my PAL TV.

Another question:
There is a valid mode of 720x576 that I can use in XBMC and it works when calibrated inside XBMC but on ubuntu desktop (TV is set to 16:9 display) the desktop is stretched horisontally and for instance when watching web video in firefox it gets horisontally stretched (can be fixed by setting TV to 4:3 but then the whole screen is not used).

Is it possible to set a 1024x576 modeline and use it despite of the fact that it is not reported as a valid mode by EDID? My TV is a CRT model with HDMI input and the real resolution is actually not more than 1024x576 but it can handle HDTV signals over HDMI (but probably downscaled by the TV). This is my TV:
http://www.p4c.philips.com/files/3/32pw9...ss_aen.pdf

Supported Display Resolution
Video formats Resolution Refresh rate
1080i 50, 60Hz
480p 60Hz
720p 50, 60Hz
576p 50Hz

You may ask why I not just use 1280x720 resolution on the desktop? Well the problem is that my PCI (not PCIe) videocard nvidia 8400GS seems to be too slow to upscale flash video to fullscreen because I get framedrops at 1280x720. However by using a lower resolution less frames are dropped. But in XBMC I can play all resolutions with no frame drops because of VDPAU acceleration. I have not tried playing flash video through plugins and scripts in XBMC, maybe that is the solution of my problems?
Reply
#93
dlmh Wrote:Will this fix the refreshrates or just the resolution? I DO get 1080p60 whatever refreshrate I choose from display settings (which strangely says 51,52,53,54,55,56 Hz, but not 23.976H,24,25,30,50 and 60Hz).

Am I able to run those commands from XBMC Live or just in Linux? (pardon my noobiness, I'm very familiar with OSX and quite some with Windows, Linux never really has been my thing)

The reason you have 51,52,53... as refresh rates is that twinview is enabled.
If you disable twinview in you xorg.conf the resolutions will work as expected, but you will of course lose the twinview functionality.
Reply
#94
I can now confirm that with 50 Hz display refresh rate and "sync video to display" with "resample audio" as sync method works perfectly with 23.976 fps and 24 fps test clips. The video is automatic speeded up to 25 Hz and the motion is perfectly fluid on my TV and there are no audio sync problems. I have set my video resolution to 1280x720 50 Hz and I am really satisfied with this solution of the "24 fps problem".
Reply
#95
I'm also having the problem, that XBMC does not switch to 24Hz when needed (in 1080p).

After reading all hints here an the forum, i successfully managed to get XBMC to "think" it does [email protected], but sadly it does not really do it (as my screen tells me, and i see the pulldown-judder).

After long searched I think that "RandR" has something to do with this. As it seems, this is the tool XBMC uses for the resolution changes. When I type "xrandr" in die command line, i'm just getting a

Quote:No screens found.

... message. I've looked around for a whole day, but I didn't find a solution for that :-(

UPDATE:

Alright, i've come one step further, xrandr works now after exporting the display using

Quote:export DISPLAY=:0.0

in the terminal...

Now I need a way to tell XBMC the same thing, because until now XBMC doesn't want to change the resolution at all :-(

UPDATE2:

After running the Export-command i get the following result von xrandr when running the menu:

Code:
Screen 0: minimum 320 x 175, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      60.0*    24.0     50.0     30.0     25.0

This is correct. When starting a movie that is encoded in [email protected] (having auto refresh-rate-handling activated), i'm getting:

Code:
Screen 0: minimum 320 x 175, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      60.0     24.0*    50.0     30.0     25.0

And nvidia-settings (as well as my TV itself) shows me:

Code:
nvidia-settings -nt -q RefreshRate
60.00 Hz

Looking in my /var/log/Xorg.0.log I also see:

Code:
(II) Jan 04 14:05:47 NVIDIA(0): Setting mode "1920x1080_24"

which tells me that setting the manual modeline should be working... but it isn't.

Somehow xrandr does not really effect the refresh rate, it just thinks it does. Does anyone have an idea how to fix xrandr? I actually think xrandr is talking about another screen than nvidia, but that did not help me so far in finding a solution.

I've alrey set a manual modeline that has been reported as valid, but this didn't change anything.

UPDATE3:

I think i'm gonna dump XBMC Live and install Ubuntu and XBMC on top of it. Maybe this way i'll get this to work (AND the remote)...
Reply
#96
I don't know exactly what, but it does the job for me too! Thanks much to cejstrup!
Xorg seems to be much more complicated than I've thought. There was the first
time I saw all these unbelievable options you've mentioned.

If you could share where did you get all the information, it would be fantastic!
Reply
  •   
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7(current)
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
How can i switch to [email protected]00